Bug 993073 - [6.3.z] [RFE] Client tools should pass up CPU Socket information
Summary: [6.3.z] [RFE] Client tools should pass up CPU Socket information
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools
Version: 6.5
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Stephen Herr
QA Contact: Lukas Pramuk
URL:
Whiteboard:
: 949638 (view as bug list)
Depends On: 949640
Blocks: 835616 sat560-splice 948337 949615 949617 949619 949620 949622 949623
TreeView+ depends on / blocked
 
Reported: 2013-08-05 15:00 UTC by Chris Pelland
Modified: 2019-07-11 07:44 UTC (History)
20 users (show)

Fixed In Version: rhn-client-tools-1.0.0.1-8.el6
Doc Type: Enhancement
Doc Text:
* While Satellite 5.3.0 now has the ability to get the number of CPUs via an API call, there was no function to obtain the number of sockets from the registered systems. This update adds a function to get the number of physical CPU sockets in a managed system from Satellite via an API call.
Clone Of:
Environment:
Last Closed: 2013-10-01 00:47:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1384 normal SHIPPED_LIVE rhn-client-tools bug fix and enhancement update 2013-10-01 01:52:19 UTC

Description Chris Pelland 2013-08-05 15:00:36 UTC
This bug has been copied from bug #949640 and has been proposed
to be backported to 6.3 z-stream (EUS).

Comment 4 Stephen Herr 2013-08-07 13:46:33 UTC
*** Bug 949638 has been marked as a duplicate of this bug. ***

Comment 7 Lukas Pramuk 2013-09-06 17:38:36 UTC
VERIFIED.
rhn-client-tools-1.0.0.1-8.el6.noarch
rhn-setup-1.0.0.1-8.el6.noarch
rhnlib-2.5.22-15.el6.noarch
subscription-manager-1.1.23.1-1.el6_4.x86_64 (installed/uninstalled)

against Satellite-5.6.0-RHEL5-re20130812.0

Reproducer (unregistered client):
1. register client to satellite
2. @webui: navigate to <system> - tab Details - subtab Hardware - section General

Reproducer (registered client):
1. @client: # rhn-profile-sync
2. @webui: navigate to <system> - tab Details - subtab Hardware - section General

REPRO:
Sockets: <empty>

vs.

FIX:
Sockets: 2


>>> old client has sockets field empty, new client reports number of sockets correctly even if subscription-manager was uninstalled
>>> webui corresponds with api results

Comment 9 errata-xmlrpc 2013-10-01 00:47:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1384.html


Note You need to log in before you can comment on or make changes to this bug.