Bug 950504 - AttributeError: 'Iso9660FS' object has no attribute 'partedDisk'
Summary: AttributeError: 'Iso9660FS' object has no attribute 'partedDisk'
Keywords:
Status: CLOSED DUPLICATE of bug 950510
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-10 11:17 UTC by Petr Schindler
Modified: 2013-04-10 14:04 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-10 14:04:32 UTC
Type: Bug


Attachments (Terms of Use)
traceback (159.52 KB, application/octet-stream)
2013-04-10 11:19 UTC, Petr Schindler
no flags Details
anaconda.log (1.97 KB, text/x-log)
2013-04-10 11:19 UTC, Petr Schindler
no flags Details
program.log (1.48 KB, text/x-log)
2013-04-10 11:19 UTC, Petr Schindler
no flags Details
storage.log (11.34 KB, text/x-log)
2013-04-10 11:20 UTC, Petr Schindler
no flags Details

Description Petr Schindler 2013-04-10 11:17:59 UTC
Description of problem:
This happens during start of anaconda before gui appears.

I reproduced it on two different machines with install DVD on flash disk which was written by dd (it works with live-iso-to-disk).

The whole traceback:

Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 1150, in __init__
    self._partedPartition = self.disk.format.partedDisk.getPartitionByPath(self.path)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 812, in addUdevPartitionDevice
    exists=True, parents=[disk])
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1046, in addUdevDevice
    device = self.addUdevPartitionDevice(info)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1866, in _populate
    self.addUdevDevice(dev)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1810, in populate
    self._populate()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 406, in reset
    self.devicetree.populate(cleanupOnly=cleanupOnly)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 137, in storageInitialize
    storage.reset()
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 141, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'Iso9660FS' object has no attribute 'partedDisk'


Version-Release number of selected component (if applicable):
Fedora-19-Alpha-x86_64-DVD.iso RC2

anaconda 19.17-1

How reproducible:
100%

Steps to Reproduce:
1. try to start installer from installation dvd
  
Actual results:
anaconda doesn't start

Expected results:
anaconda starts

Additional info:

Comment 1 Petr Schindler 2013-04-10 11:19:07 UTC
Created attachment 733632 [details]
traceback

Comment 2 Petr Schindler 2013-04-10 11:19:31 UTC
Created attachment 733633 [details]
anaconda.log

Comment 3 Petr Schindler 2013-04-10 11:19:58 UTC
Created attachment 733634 [details]
program.log

Comment 4 Petr Schindler 2013-04-10 11:20:26 UTC
Created attachment 733635 [details]
storage.log

Comment 5 satellitgo 2013-04-10 11:40:13 UTC
duplicate?: https://bugzilla.redhat.com/show_bug.cgi?id=950510

Comment 6 Chris Lumens 2013-04-10 14:04:32 UTC

*** This bug has been marked as a duplicate of bug 950510 ***


Note You need to log in before you can comment on or make changes to this bug.