Bug 950510 - AttributeError: 'Iso9660FS' object has no attribute 'partedDisk'
Summary: AttributeError: 'Iso9660FS' object has no attribute 'partedDisk'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:928091aa5353fb59e543fd8d26c...
: 950504 951782 951899 (view as bug list)
Depends On:
Blocks: F19Alpha-accepted, F19AlphaFreezeException F19Beta, F19BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2013-04-10 11:27 UTC by satellitgo
Modified: 2013-04-19 20:31 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-19 05:49:27 UTC


Attachments (Terms of Use)
File: anaconda-tb (123.80 KB, text/plain)
2013-04-10 11:29 UTC, satellitgo
no flags Details
File: anaconda.log (1.78 KB, text/plain)
2013-04-10 11:29 UTC, satellitgo
no flags Details
File: backtrace (1.23 KB, text/plain)
2013-04-10 11:29 UTC, satellitgo
no flags Details
File: environ (760 bytes, text/plain)
2013-04-10 11:29 UTC, satellitgo
no flags Details
File: ifcfg.log (490 bytes, text/plain)
2013-04-10 11:29 UTC, satellitgo
no flags Details
File: lsblk_output (1.90 KB, text/plain)
2013-04-10 11:29 UTC, satellitgo
no flags Details
File: nmcli_dev_list (7.14 KB, text/plain)
2013-04-10 11:30 UTC, satellitgo
no flags Details
File: packaging.log (412 bytes, text/plain)
2013-04-10 11:30 UTC, satellitgo
no flags Details
File: program.log (14.37 KB, text/plain)
2013-04-10 11:30 UTC, satellitgo
no flags Details
File: storage.log (9.22 KB, text/plain)
2013-04-10 11:30 UTC, satellitgo
no flags Details
File: syslog (96.83 KB, text/plain)
2013-04-10 11:30 UTC, satellitgo
no flags Details

Description satellitgo 2013-04-10 11:27:49 UTC
Description of problem:
dd DVD RC2 trying to start anaconda
The following was filed automatically by anaconda:
anaconda 19.17-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 1150, in __init__
    self._partedPartition = self.disk.format.partedDisk.getPartitionByPath(self.path)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 812, in addUdevPartitionDevice
    exists=True, parents=[disk])
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1046, in addUdevDevice
    device = self.addUdevPartitionDevice(info)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1866, in _populate
    self.addUdevDevice(dev)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1810, in populate
    self._populate()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 406, in reset
    self.devicetree.populate(cleanupOnly=cleanupOnly)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 137, in storageInitialize
    storage.reset()
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 141, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'Iso9660FS' object has no attribute 'partedDisk'

Version-Release number of selected component:
anaconda-19.17-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Alpha\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-0.rc4.git0.1.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Alpha

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 141, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 137, in storageInitialize
    storage.reset()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 406, in reset
    self.devicetree.populate(cleanupOnly=cleanupOnly)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1810, in populate
    self._populate()
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1866, in _populate
    self.addUdevDevice(dev)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1046, in addUdevDevice
    device = self.addUdevPartitionDevice(info)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 812, in addUdevPartitionDevice
    exists=True, parents=[disk])
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 1150, in __init__
    self._partedPartition = self.disk.format.partedDisk.getPartitionByPath(self.path)
AttributeError: 'Iso9660FS' object has no attribute 'partedDisk'

Comment 1 satellitgo 2013-04-10 11:29:46 UTC
Created attachment 733639 [details]
File: anaconda-tb

Comment 2 satellitgo 2013-04-10 11:29:48 UTC
Created attachment 733640 [details]
File: anaconda.log

Comment 3 satellitgo 2013-04-10 11:29:51 UTC
Created attachment 733641 [details]
File: backtrace

Comment 4 satellitgo 2013-04-10 11:29:53 UTC
Created attachment 733642 [details]
File: environ

Comment 5 satellitgo 2013-04-10 11:29:55 UTC
Created attachment 733643 [details]
File: ifcfg.log

Comment 6 satellitgo 2013-04-10 11:29:57 UTC
Created attachment 733644 [details]
File: lsblk_output

Comment 7 satellitgo 2013-04-10 11:30:00 UTC
Created attachment 733645 [details]
File: nmcli_dev_list

Comment 8 satellitgo 2013-04-10 11:30:02 UTC
Created attachment 733646 [details]
File: packaging.log

Comment 9 satellitgo 2013-04-10 11:30:05 UTC
Created attachment 733647 [details]
File: program.log

Comment 10 satellitgo 2013-04-10 11:30:08 UTC
Created attachment 733648 [details]
File: storage.log

Comment 11 satellitgo 2013-04-10 11:30:12 UTC
Created attachment 733649 [details]
File: syslog

Comment 12 satellitgo 2013-04-10 11:40:48 UTC
see duplicate: https://bugzilla.redhat.com/show_bug.cgi?id=950504
filed automatically from USB stick

Comment 13 Chris Lumens 2013-04-10 14:04:32 UTC
*** Bug 950504 has been marked as a duplicate of this bug. ***

Comment 14 Kamil Páral 2013-04-10 16:19:31 UTC
Proposing a Beta blocker:
The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to a USB stick with any of the officially supported methods 
http://fedoraproject.org/wiki/Fedora_19_Beta_Release_Criteria

Comment 15 satellitgo 2013-04-10 17:05:13 UTC
adamw said to add as CommonBugs

Comment 16 satellitgo 2013-04-10 17:09:39 UTC
Fedora-19-Alpha-x86_64-DVD.iso boots and installs default desktop in VirtualBox
2450 memory 16 GB VBox HD with networking
reboots to G-I-S in gnome

Comment 17 satellitgo 2013-04-10 17:14:30 UTC
(In reply to comment #16)
> Fedora-19-Alpha-x86_64-DVD.iso boots and installs default desktop in
> VirtualBox
> 2450 memory 16 GB VBox HD with networking
> reboots to G-I-S in gnome

L-I-T-D USB installs and boots gnome in G-I-S on bare metal

Comment 18 Kamil Páral 2013-04-10 17:26:28 UTC
(In reply to comment #16)
(In reply to comment #17)

Yes, thanks, but this bug is about "dd". The other approaches are not affected.

Comment 19 Stephen John Smoogen 2013-04-10 20:23:10 UTC
Added info in case it is needed. Bug is change in some code between TC5 and RC2. With the fact that USB is the only way to test the extra large install isos.. I can't test the EUFI at the moment.

Comment 20 David Lehman 2013-04-10 21:19:59 UTC
To test a potential fix (with RC2, which includes anaconda-19.17-1), add the following to the boot command line:

  inst.updates=http://dlehman.fedorapeople.org/updates/updates-950510.0.img

Don't forget to report your results. Thanks.

Comment 21 Stephen John Smoogen 2013-04-10 23:01:19 UTC
Update allows system to proceed on install. I am now stuck on a different bug in EFI :).

Comment 22 Adam Williamson 2013-04-10 23:02:16 UTC
Proposing as FE for alpha - depending on how things go with the UEFI bugs we're currently fighting, we might want to pull this fix into another build.

Comment 23 Charles R. Anderson 2013-04-11 08:01:42 UTC
(In reply to comment #20)
> To test a potential fix (with RC2, which includes anaconda-19.17-1), add the
> following to the boot command line:
> 
>   inst.updates=http://dlehman.fedorapeople.org/updates/updates-950510.0.img
> 
> Don't forget to report your results. Thanks.

Confirmed that this update image fixes the dd install.

Comment 24 Petr Schindler 2013-04-11 08:56:48 UTC
Anaconda boots properly with the update.

Comment 25 Petr Schindler 2013-04-11 09:39:52 UTC
This bug is related to Live CDs too. dlehman's updates image fixes Live too.

Comment 26 Adam Williamson 2013-04-13 01:45:40 UTC
Whoops, I meant to see if we could get this fix into TC6. dlehman, any chance you could get it posted and reviewed so we can possibly get it in for RC3? Thanks!

Comment 27 Chris Lumens 2013-04-15 12:59:48 UTC
*** Bug 951899 has been marked as a duplicate of this bug. ***

Comment 28 Chris Lumens 2013-04-15 12:59:51 UTC
*** Bug 951782 has been marked as a duplicate of this bug. ***

Comment 29 Adam Williamson 2013-04-15 17:30:32 UTC
Discussed at 2013-04-15 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-04-15/f19alpha-blocker-review-7.2013-04-15-16.00.log.txt . Accepted as a freeze exception as fixing dd'ed USB sticks is obviously valuable, particularly to testers who aren't currently running Fedora and so can't use litd.

Comment 30 Fedora Update System 2013-04-15 21:18:23 UTC
python-blivet-0.11-1.fc19, anaconda-19.19-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-blivet-0.11-1.fc19,anaconda-19.19-1.fc19

Comment 31 Fedora Update System 2013-04-16 16:11:36 UTC
Package python-blivet-0.11-1.fc19, anaconda-19.19-1.fc19, lorax-19.2-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.11-1.fc19 anaconda-19.19-1.fc19 lorax-19.2-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5795/lorax-19.2-1.fc19,python-blivet-0.11-1.fc19,anaconda-19.19-1.fc19
then log in and leave karma (feedback).

Comment 32 Fedora Update System 2013-04-17 16:28:06 UTC
Package python-blivet-0.11-1.fc19, lorax-19.2-1.fc19, anaconda-19.20-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.11-1.fc19 lorax-19.2-1.fc19 anaconda-19.20-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5795/lorax-19.2-1.fc19,python-blivet-0.11-1.fc19,anaconda-19.20-1.fc19
then log in and leave karma (feedback).

Comment 33 Fedora Update System 2013-04-19 05:49:31 UTC
python-blivet-0.11-1.fc19, lorax-19.2-1.fc19, anaconda-19.20-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 34 Adam Williamson 2013-04-19 20:31:07 UTC
Fixed, no longer needs to be commonbugs.


Note You need to log in before you can comment on or make changes to this bug.