Bug 950509 - [NetKVM] Build NDIS6.x drivers using Visual Studio 2012 project only
Summary: [NetKVM] Build NDIS6.x drivers using Visual Studio 2012 project only
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win
Version: 6.5
Hardware: Unspecified
OS: Windows
unspecified
medium
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 950517 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-10 11:27 UTC by Yan Vugenfirer
Modified: 2013-12-06 07:39 UTC (History)
11 users (show)

Fixed In Version: virtio-win-prewhql-0.1-59
Doc Type: Enhancement
Doc Text:
Feature: Build drivers with Visual Studio. Reason: With Windows 8 DDK drivers can no longer be built with DDK command line tools. Result (if any): All NetKVM driver build facilities converted to Visual Studio projects\solutions.
Clone Of:
Environment:
Last Closed: 2013-11-22 00:07:38 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1729 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2013-11-21 00:39:25 UTC

Description Yan Vugenfirer 2013-04-10 11:27:48 UTC
Description of problem:

Currently we have a mixed up build for our drivers. 
As Windows 8 DDK can work only through Visual Studio - we are building Windows 8 (Windows Server 2012) driver using new DDK. The older versions are build with Windows 7 DKK.

This BZ is a placeholder for the move to compile all the NDIS6.x drivers (Vista and up) using Visual Studio 2012 only.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 4 Mike Cao 2013-04-18 06:22:04 UTC
Seems md5 can not verify this issue for the older os (as the timestamp will change) .

Could you show us a way to verify it ?Acceptance Test for win2k3 ?

Comment 5 Yan Vugenfirer 2013-04-18 07:52:53 UTC
Sorry but this one will be quite a lot of work.
As we changed build system (build tools and packaging scripts) I think the following will be a good test case:


1. Test the driver packaging :

1.1. NetKVM driver should be packaged correctly for all the supported OSes: NetKVM.sys, NetKVM.inf and NetKVM.cat are present; for OSes Vista and up: readme.doc and netkvmco.dll present as well.

1.2. Test that the driver can be installed on every supported OS (maybe we should ask autotest group to do this test?).


2. Basic driver functionality

2.1. Installation - guest gets IP address.

2.2. Data transfer (receive\transmit).



Best regards,
Yan.

Comment 6 Yan Vugenfirer 2013-04-18 08:22:43 UTC
To all who are using test certificate (NetKVMTemporaryCert) - please reinstall it.

Best regards,
Yan.

Comment 7 Yan Vugenfirer 2013-04-18 08:23:04 UTC
*** Bug 950517 has been marked as a duplicate of this bug. ***

Comment 9 guo jiang 2013-06-19 01:56:08 UTC
According to comment #5, QE tested this issue on virtio-win-prewhql-0.1.64 and platform:win7-32/64,win2k8-32/64/R2,win8-32/64,win2012

Steps
1.Run 2 windows guests

2.Install NetKVM driver

3.check guest ip and transfer data(receive\transmit)

Actual Result
on virtio-win-prewhql-0.1.64 and every test platform, guest could get ip normally and transfer data(receive\transmit) successfully.

Comment 10 guo jiang 2013-06-19 09:31:53 UTC
QE also tested this issue on virtio-win-prewhql-0.1.64 and platform: winxp, win2k3-32/64

Steps
1.Run 1 windows guests

2.Install NetKVM driver

3.check guest ip and transfer data(receive\transmit)

Actual Result
on virtio-win-prewhql-0.1.64 and every test platform, guest could get ip normally and transfer data(receive\transmit) successfully.

Comment 11 Mike Cao 2013-06-20 06:33:37 UTC
Based on comment #9&Comment #10 ,this issue has been fixed ald .Move status to VERIFIED

Comment 16 errata-xmlrpc 2013-11-22 00:07:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1729.html


Note You need to log in before you can comment on or make changes to this bug.