Bug 950517 - [NetKVM] Build all NDIS6.x drivers using Visual Studio 2012 project only
Summary: [NetKVM] Build all NDIS6.x drivers using Visual Studio 2012 project only
Keywords:
Status: CLOSED DUPLICATE of bug 950509
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Yvugenfi@redhat.com
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-10 11:35 UTC by Yvugenfi@redhat.com
Modified: 2013-07-01 04:44 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 59
Environment:
Last Closed: 2013-04-18 08:23:04 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yvugenfi@redhat.com 2013-04-10 11:35:02 UTC
Description of problem:

Currently we have a mixed up build for our drivers. 
As Windows 8 DDK can work only through Visual Studio - we are building Windows 8 (Windows Server 2012) driver using new DDK. The older versions are build with Windows 7 DKK.

This BZ is a placeholder for the move to compile all the NDIS6.x drivers (Vista and up) using Visual Studio 2012 only.

1. Create project file for all the needed build configurations
2. Enable the build of debug version
3. Driver signing, driver inf stamping, package creation and etc should be done through project settings
4. Cleanup of W4 warnings as a result of new default compilation settings
5. Enable the usage of multiple threads during the build (new feature in VS2012).
6. Remove tabs from NetKVM and Virtio library source files.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 2 Yvugenfi@redhat.com 2013-04-10 11:40:08 UTC
To all who are using test certificate (NetKVMTemporaryCert) - please reinstall it.

Best regards,
Yan.

Comment 3 Yvugenfi@redhat.com 2013-04-18 08:23:04 UTC

*** This bug has been marked as a duplicate of bug 950509 ***


Note You need to log in before you can comment on or make changes to this bug.