Bug 950700 - NameError: global name 'encryption_changed' is not defined
NameError: global name 'encryption_changed' is not defined
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:62d60e86e9f97ca2fdb73747f0a...
:
: 951013 953103 (view as bug list)
Depends On:
Blocks: F19Alpha-accepted/F19AlphaFreezeException F19PPCAlpha/F19PPCAlphaBlocker/PPCAlphaBlocker
  Show dependency treegraph
 
Reported: 2013-04-10 13:09 EDT by Tim Flink
Modified: 2013-04-19 01:49 EDT (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-19 01:49:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Flink 2013-04-10 13:09:12 EDT
Description of problem:
I selected encrypted disks before going into custom partitioning and canceled out of the passphrase dialog before de-selecting "encrypt my disks" and going back into custom partitioning. I got this TB when I made the first change in the custom partitioning spoke
The following was filed automatically by anaconda:
anaconda 19.17-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1213, in _save_right_side
    do_reformat = (reformat and (encryption_changed or
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2432, in on_apply_clicked
    self._save_right_side(self._current_selector)
NameError: global name 'encryption_changed' is not defined

Version-Release number of selected component:
anaconda-19.17-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/syslinux/vmlinuz inst.stage2=hd:UUID=988A-61DF xdriver=vesa nomodeset quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-0.rc4.git0.1.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Alpha

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2432, in on_apply_clicked
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1213, in _save_right_side
    do_reformat = (reformat and (encryption_changed or
NameError: global name 'encryption_changed' is not defined
Comment 1 Reartes Guillermo 2013-04-10 21:30:48 EDT
Description of problem:
i am not sure, i was trying to reproduce another issue so i needed a partial raid setup.
i installed f19a rc2 on a md raid1 ok.
launched anaconda and deleted and recerated the / but ass md raid0, and <maybe> clicking and unlclicking 'encription' but i did not use it, so i don't know why the crash references encryption.

Version-Release number of selected component:
anaconda-19.17-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Alpha\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-0.rc4.git0.1.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Alpha

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2432, in on_apply_clicked
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1213, in _save_right_side
    do_reformat = (reformat and (encryption_changed or
NameError: global name 'encryption_changed' is not defined
Comment 2 Reartes Guillermo 2013-04-10 21:43:01 EDT
This is the first bur-report for f19 in which i could use abrt.

I did noticed that there are no attachments. Is this new expected behavior for abrt reported bug-reports?

I saved the logs just in case.
Comment 3 Chris Lumens 2013-04-11 09:41:16 EDT
*** Bug 951013 has been marked as a duplicate of this bug. ***
Comment 4 Adam Williamson 2013-04-11 15:50:11 EDT
Discussed at 2013-04-11 F19 Alpha go/no-go meeting, acting as a blocker review meeting: http://meetbot.fedoraproject.org/fedora-meeting-1/2013-04-11/f19_alpha_gono-go_meeting.2013-04-11-17.00.log.html . Agreed that as this involves custom partitioning and we do not require any kind of functionality at all from custom partitioning at Alpha stage, this is rejected as a blocker. It is, however, accepted as a freeze exception issue, as it can certainly interfere with testing we would like to run against Alpha.
Comment 5 Shawn Starr 2013-04-12 00:44:53 EDT
Description of problem:
Attempted a custom partition, EXT2 for /root LVM setup, deleting swap and resizing / to use the space from the swap partition, attempted to set encryption on but somehow after adjusting partitioning twice Anaconda got confused, crashed,

Version-Release number of selected component:
anaconda-19.17-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Alpha\x20x86_64 quiet slub_debug=- BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-0.rc4.git0.1.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Alpha

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2432, in on_apply_clicked
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1213, in _save_right_side
    do_reformat = (reformat and (encryption_changed or
NameError: global name 'encryption_changed' is not defined
Comment 6 Victor Costan 2013-04-12 23:25:24 EDT
Description of problem:
Tried to install Fedora 19 using the Alpha 2 desktop install DVD. I already have a Fedora 17 setup, and I was trying to re-format the root and swap partitions from that installation.

Version-Release number of selected component:
anaconda-19.17-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Alpha\x20x86_64 rd.live.check quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-0.rc4.git0.1.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Alpha

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2432, in on_apply_clicked
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1213, in _save_right_side
    do_reformat = (reformat and (encryption_changed or
NameError: global name 'encryption_changed' is not defined
Comment 7 A.J. Werkman 2013-04-13 03:09:22 EDT
Description of problem:
Trying to reconfigure a harddisc that was previously used as F18 disc, this exeption occured.

Version-Release number of selected component:
anaconda-19.17-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz nomodeset ip=212.115.199.60::212.115.199.57:255.255.255.192:cfl.digifarma.nl::none noipv6 nameserver=212.115.199.57 inst.stage2=hd:LABEL=TEST_19
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-0.rc4.git0.1.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Alpha

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2432, in on_apply_clicked
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1213, in _save_right_side
    do_reformat = (reformat and (encryption_changed or
NameError: global name 'encryption_changed' is not defined
Comment 8 G.Wolfe Woodbury 2013-04-14 20:24:48 EDT
Description of problem:
19-Alpha-TC6  DVD.iso in VBox guest
Custom partitioning:
   select swap from old install
   select reformat
   hit apply changes


Python complains about "encryption_changes" global not being defined

Version-Release number of selected component:
anaconda-19.18-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Alpha-TC6\x20x86_64  BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-0.rc6.git2.1.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Alpha-TC6

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2432, in on_apply_clicked
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1213, in _save_right_side
    do_reformat = (reformat and (encryption_changed or
NameError: global name 'encryption_changed' is not defined
Comment 9 Fedora Update System 2013-04-15 17:01:55 EDT
python-blivet-0.11-1.fc19,anaconda-19.19-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-blivet-0.11-1.fc19,anaconda-19.19-1.fc19
Comment 10 Fedora Update System 2013-04-16 12:11:15 EDT
Package python-blivet-0.11-1.fc19, anaconda-19.19-1.fc19, lorax-19.2-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.11-1.fc19 anaconda-19.19-1.fc19 lorax-19.2-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5795/lorax-19.2-1.fc19,python-blivet-0.11-1.fc19,anaconda-19.19-1.fc19
then log in and leave karma (feedback).
Comment 11 Dale Turner 2013-04-16 22:13:30 EDT
Description of problem:
Tried to add a mount point to an existing partition

Version-Release number of selected component:
anaconda-19.18-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Alpha-TC6\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-0.rc6.git2.1.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Alpha-TC6

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2432, in on_apply_clicked
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1213, in _save_right_side
    do_reformat = (reformat and (encryption_changed or
NameError: global name 'encryption_changed' is not defined
Comment 12 Chris Lumens 2013-04-17 09:45:41 EDT
*** Bug 953103 has been marked as a duplicate of this bug. ***
Comment 13 Fedora Update System 2013-04-17 12:27:45 EDT
Package python-blivet-0.11-1.fc19, lorax-19.2-1.fc19, anaconda-19.20-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.11-1.fc19 lorax-19.2-1.fc19 anaconda-19.20-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5795/lorax-19.2-1.fc19,python-blivet-0.11-1.fc19,anaconda-19.20-1.fc19
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2013-04-19 01:49:09 EDT
python-blivet-0.11-1.fc19, lorax-19.2-1.fc19, anaconda-19.20-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.