Bug 951034 - Rebase libtevent to version 0.9.18
Rebase libtevent to version 0.9.18
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libtevent (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Jakub Hrozek
Kaushik Banerjee
: Rebase, ZStream
Depends On:
Blocks: 883504 980956
  Show dependency treegraph
 
Reported: 2013-04-11 07:18 EDT by Andreas Schneider
Modified: 2013-11-21 00:42 EST (History)
6 users (show)

See Also:
Fixed In Version: libtevent-0.9.18-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
The libtevent package has been upgraded to upstream version 0.9.18, which provides a number of bug fixes and enhancements over the previous version.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 00:42:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Schneider 2013-04-11 07:18:31 EDT
Currently we have version 0.9.16 in RHEL 6.4. We would like to update to version 0.9.18 cause it has a lot of important bugfixes we would like to have in RHEL 6.5. It would be possible to backport all patches, but we want really most of them cause they improve libtevent.


Some background:
-----------------

We found these bugs cause of a customer (not a RH customer) having problems with the poll backend in winbind. After changing the winbind code to fully use libtevent epoll backend, winbind went down from running at 100% to nearly never seen in top.

Testing:
---------
There is no additional testing needed beside running the testsuite of libtevent. The tests we are running in Samba or sssd cover libtevent functionality too.


Here are some details about the changes:
-----------------------------------------

0.9.17 added a thread safe poll backend (not in use by samba or ipa/sssd). This is a small patch.

0.9.18 is a bugfix release, with a lot of fixes. A rebase would just be 
simpler for us. libtevent is a low-level library. Patches need to be tested 
well and we require testcases upstream from changes.

    - Adding new timer events is now faster, if there's
      a large number of timer events.
    
    - sigprocmask does not work on FreeBSD to stop further signals in a signal
      handler.
    
    - TEVENT_NUM_SIGNALS is calculated by configure in order
      to support realtime signals on freebsd.
    
    - ./configure --disable-python was fixed for the standalone build.
    
    - Several crash bugs in the poll backend are fixed.
    
    - The poll backend removes deleted events from the
      cached pollfd array now.
    
    - The poll doesn't pass pollfd.events == 0 to poll()
      and maintains a list of disabled events,
      instead of consuming 100% cpu and/or triggering
      the callers handler.
    
    - The poll backend detects POLLNVAL and reports EBADF
      instead of consuming 100% cpu.
    
    - The select backend supports separate handlers
      for TEVENT_FD_READ and TEVENT_FD_WRITE.
    
    - The poll and select backends are now doing fair
      queuing of fd events.
    
    - The epoll has better error checking
      and supports separate handlers
      for TEVENT_FD_READ and TEVENT_FD_WRITE.
    
    - The standard backend was rewritten to be a tiny
      wrapper on top of epoll with a fallback to poll,
      which means that it doesn't use select directly anymore.
    
    - TEVENT_TRACE_BEFORE_LOOP_ONCE and TEVENT_TRACE_AFTER_LOOP_ONCE
      are added in order to allow the application to hook in
      before and after the loop_once() backend function is called.
      The TEVENT_HAS_LOOP_ONCE_TRACE_POINTS define can be used to
      detect the new feature.
Comment 2 Scott Haines 2013-06-20 02:15:00 EDT
Proposing this rebase bug also be approved for 6.4.z. Upcoming Storage 2.1.0 release which is based upon RHEL 6.4 EUS will be impacted otherwise.
Comment 10 Amith 2013-10-25 10:07:20 EDT
Verified the bug on libtevent version: libtevent-0.9.18-3.el6

Sanity tests passed and no related regression detected.
Comment 12 errata-xmlrpc 2013-11-21 00:42:08 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1552.html

Note You need to log in before you can comment on or make changes to this bug.