Bug 952727 - NameError: global name 'fs_type_changed' is not defined
Summary: NameError: global name 'fs_type_changed' is not defined
Keywords:
Status: CLOSED DUPLICATE of bug 952662
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:34074b77e0f978944931a9abb9a...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-16 14:51 UTC by A.J. Werkman
Modified: 2013-04-16 15:52 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-16 15:52:13 UTC


Attachments (Terms of Use)
File: anaconda-tb (1009.28 KB, text/plain)
2013-04-16 14:51 UTC, A.J. Werkman
no flags Details
File: anaconda.log (12.68 KB, text/plain)
2013-04-16 14:51 UTC, A.J. Werkman
no flags Details
File: backtrace (386 bytes, text/plain)
2013-04-16 14:51 UTC, A.J. Werkman
no flags Details
File: environ (958 bytes, text/plain)
2013-04-16 14:52 UTC, A.J. Werkman
no flags Details
File: ifcfg.log (405 bytes, text/plain)
2013-04-16 14:52 UTC, A.J. Werkman
no flags Details
File: lsblk_output (1.98 KB, text/plain)
2013-04-16 14:52 UTC, A.J. Werkman
no flags Details
File: nmcli_dev_list (1.29 KB, text/plain)
2013-04-16 14:52 UTC, A.J. Werkman
no flags Details
File: packaging.log (620.40 KB, text/plain)
2013-04-16 14:52 UTC, A.J. Werkman
no flags Details
File: program.log (35.70 KB, text/plain)
2013-04-16 14:52 UTC, A.J. Werkman
no flags Details
File: storage.log (87.56 KB, text/plain)
2013-04-16 14:52 UTC, A.J. Werkman
no flags Details
File: syslog (108.77 KB, text/plain)
2013-04-16 14:52 UTC, A.J. Werkman
no flags Details

Description A.J. Werkman 2013-04-16 14:51:42 UTC
Description of problem:
In custom partyitioning I type the name of the mount poitn, then I check " Reformet". On clicking the Update settings buttion, the system becomes non-responsive and after a while this error occures.
The following was filed automatically by anaconda:
anaconda 19.19-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1214, in _save_right_side
    fs_type_changed or
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2432, in on_apply_clicked
    self._save_right_side(self._current_selector)
NameError: global name 'fs_type_changed' is not defined

Version-Release number of selected component:
anaconda-19.19-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz nomodeset ip=212.115.199.60::212.115.199.57:255.255.255.248:testsys.digifarma.nl::none noipv6 nameserver=212.115.199.57 inst.stage2=hd:LABEL=TEST_19 repo=http://thlin.digifarma.nl/fedora/releases/19-Alpha-RC3/Fedora/x86_64/os
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-0.rc6.git2.3.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Alpha

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2432, in on_apply_clicked
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1214, in _save_right_side
    fs_type_changed or
NameError: global name 'fs_type_changed' is not defined

Comment 1 A.J. Werkman 2013-04-16 14:51:50 UTC
Created attachment 736340 [details]
File: anaconda-tb

Comment 2 A.J. Werkman 2013-04-16 14:51:57 UTC
Created attachment 736341 [details]
File: anaconda.log

Comment 3 A.J. Werkman 2013-04-16 14:51:59 UTC
Created attachment 736342 [details]
File: backtrace

Comment 4 A.J. Werkman 2013-04-16 14:52:01 UTC
Created attachment 736343 [details]
File: environ

Comment 5 A.J. Werkman 2013-04-16 14:52:03 UTC
Created attachment 736344 [details]
File: ifcfg.log

Comment 6 A.J. Werkman 2013-04-16 14:52:05 UTC
Created attachment 736345 [details]
File: lsblk_output

Comment 7 A.J. Werkman 2013-04-16 14:52:07 UTC
Created attachment 736346 [details]
File: nmcli_dev_list

Comment 8 A.J. Werkman 2013-04-16 14:52:11 UTC
Created attachment 736347 [details]
File: packaging.log

Comment 9 A.J. Werkman 2013-04-16 14:52:16 UTC
Created attachment 736348 [details]
File: program.log

Comment 10 A.J. Werkman 2013-04-16 14:52:18 UTC
Created attachment 736349 [details]
File: storage.log

Comment 11 A.J. Werkman 2013-04-16 14:52:21 UTC
Created attachment 736350 [details]
File: syslog

Comment 12 David Lehman 2013-04-16 15:52:13 UTC

*** This bug has been marked as a duplicate of bug 952662 ***


Note You need to log in before you can comment on or make changes to this bug.