Bug 952662 - Traceback when doing custom partitioning: NameError: global name 'fs_type_changed' is not defined
Summary: Traceback when doing custom partitioning: NameError: global name 'fs_type_cha...
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: ppc64
OS: Linux
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
Whiteboard: RejectedBlocker AcceptedFreezeException
: 952727 (view as bug list)
Depends On:
Blocks: F19Alpha-accepted, F19AlphaFreezeException F19PPCAlpha, F19PPCAlphaBlocker, PPCAlphaBlocker
TreeView+ depends on / blocked
Reported: 2013-04-16 11:37 UTC by Karsten Hopp
Modified: 2013-04-19 05:48 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2013-04-19 05:48:22 UTC
Type: Bug

Attachments (Terms of Use)

Description Karsten Hopp 2013-04-16 11:37:54 UTC
Description of problem:
I've tried a custom partition installation on PPC64 with the latest install images which contain anaconda-19.19-1.fc19 and python-blivet-0.11-1.fc19 to work around bug #950700.
The previous system had several partitions, 2 of them encrypted. 
When I tried to re-use one of them (doesn't matter if encrypted or not), selected 'reformat', unselected 'encrypt' and pressed 'apply' I got the following error:

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 239, in _onSelectorClicked
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2065, in on_selector_clicked
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2055, in _save_current_selector
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1214, in _save_right_side
    fs_type_changed or
NameError: global name 'fs_type_changed' is not defined

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. re-install an older Fedora system
2. re-use one of the existing partitions
3. press 'Apply'
Actual results:

Expected results:

Additional info:

Comment 1 David Lehman 2013-04-16 15:52:13 UTC
*** Bug 952727 has been marked as a duplicate of this bug. ***

Comment 2 Adam Williamson 2013-04-16 16:36:08 UTC
-1 blocker, custom partitioning does not block Alpha. Unfortunate, though. Is this a new bug compared to RC2 or TC6?

Comment 3 David Lehman 2013-04-16 20:53:50 UTC
(In reply to comment #2)
> -1 blocker, custom partitioning does not block Alpha. Unfortunate, though.
> Is this a new bug compared to RC2 or TC6?

It was introduced at the same times as 950700. The fix for that exposed this.

Comment 4 Adam Williamson 2013-04-16 21:07:45 UTC
ah, so basically, the practical upshot is that custom partitioning is fairly borked in both RC2 and RC3. not great, but not terrible.

Comment 5 Adam Williamson 2013-04-16 21:39:03 UTC
https://www.happyassassin.net/extras/updates-952662.img should address this (fix thanks to dlehman). can those affected please check and see if it works for you, and if you can now use custom partitioning successfully without hitting any subsequent bugs? thanks.

Comment 6 Adam Williamson 2013-04-16 22:02:44 UTC
Better updates.img: https://www.happyassassin.net/extras/updates-952662-2.img

Comment 7 Adam Williamson 2013-04-16 23:02:54 UTC
I'd vote -1 blocker, +1 freeze exception. This bug affects all re-use of existing partitions in custom partitioning. This isn't required functionality for Alpha, but it would help testing coverage if we could make it work. Other votes?

Comment 8 Kevin Fenzi 2013-04-16 23:05:46 UTC
Ditto. -1 blocker, but +1 FE

Comment 9 Tim Flink 2013-04-16 23:07:42 UTC
-1 blocker, +1 FE for a well tested fix

That makes -3 blocker, +3 FE. Moving to RejectedBlocker, AcceptedFreezeException

Comment 10 Fedora Update System 2013-04-17 00:51:06 UTC
python-blivet-0.11-1.fc19, lorax-19.2-1.fc19, anaconda-19.20-1.fc19 has been submitted as an update for Fedora 19.

Comment 11 Fedora Update System 2013-04-17 16:27:13 UTC
Package python-blivet-0.11-1.fc19, lorax-19.2-1.fc19, anaconda-19.20-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.11-1.fc19 lorax-19.2-1.fc19 anaconda-19.20-1.fc19'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).

Comment 12 Adam Williamson 2013-04-18 03:45:03 UTC
Verified fix with RC4.

Comment 13 Fedora Update System 2013-04-19 05:48:25 UTC
python-blivet-0.11-1.fc19, lorax-19.2-1.fc19, anaconda-19.20-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.