Bug 953786 - Static calling in non-static method not behaves like $this
Summary: Static calling in non-static method not behaves like $this
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: php   
(Show other bugs)
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Web Stack Team
QA Contact: Martin Kyral
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-19 08:18 UTC by Remi Collet
Modified: 2014-10-14 06:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: A change in PHP 5.3.3 introduce an inconsistency which have be reverted in next versions. Consequence: A call from the context's class (name, static or self) inside a non-static method results to a static-call Fix: Standard behaviour have be restored Result: A call inside a non-static method is now non-static, and called method inherit $this.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 06:37:13 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1465 normal SHIPPED_LIVE php bug fix update 2014-10-14 01:10:51 UTC
PHP Bug Tracker 51176 None None None Never

Description Remi Collet 2013-04-19 08:18:11 UTC
The upstream bug 51176 have been fixed in 5.3.3 and reverted in 5.3.4

php53 in RHEL-5 have this fix reverted, so have the php >= 5.3.4 behaviour

php in RHEL-6 don't have it, si have php 5.3.3 only behaviour

Most important, php in RHEL-6 don't have the same behaviour than php53 in RHEL-5

Comment 2 RHEL Product and Program Management 2013-10-14 03:46:19 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 11 errata-xmlrpc 2014-10-14 06:37:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1465.html


Note You need to log in before you can comment on or make changes to this bug.