Bug 953945 - [abrt] lxappearance-0.5.2-3.fc19: preview_menu: Process /usr/bin/lxappearance was killed by signal 11 (SIGSEGV)
Summary: [abrt] lxappearance-0.5.2-3.fc19: preview_menu: Process /usr/bin/lxappearance...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lxappearance
Version: 19
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:8002e8ff72a596d5a9061cbe82b...
: 988792 (view as bug list)
Depends On:
Blocks: F19-accepted, F19FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2013-04-19 15:29 UTC by Dilyan Arsov
Modified: 2013-08-19 18:38 UTC (History)
14 users (show)

Fixed In Version: lxappearance-obconf-0.2.0-4.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-18 21:31:26 UTC


Attachments (Terms of Use)
File: backtrace (35.52 KB, text/plain)
2013-04-19 15:29 UTC, Dilyan Arsov
no flags Details
File: cgroup (130 bytes, text/plain)
2013-04-19 15:29 UTC, Dilyan Arsov
no flags Details
File: core_backtrace (582 bytes, text/plain)
2013-04-19 15:29 UTC, Dilyan Arsov
no flags Details
File: dso_list (7.54 KB, text/plain)
2013-04-19 15:29 UTC, Dilyan Arsov
no flags Details
File: environ (2.38 KB, text/plain)
2013-04-19 15:29 UTC, Dilyan Arsov
no flags Details
File: limits (1.29 KB, text/plain)
2013-04-19 15:29 UTC, Dilyan Arsov
no flags Details
File: maps (24.67 KB, text/plain)
2013-04-19 15:29 UTC, Dilyan Arsov
no flags Details
File: open_fds (273 bytes, text/plain)
2013-04-19 15:29 UTC, Dilyan Arsov
no flags Details
File: proc_pid_status (792 bytes, text/plain)
2013-04-19 15:29 UTC, Dilyan Arsov
no flags Details
File: var_log_messages (1.46 KB, text/plain)
2013-04-19 15:29 UTC, Dilyan Arsov
no flags Details

Description Dilyan Arsov 2013-04-19 15:29:14 UTC
Version-Release number of selected component:
lxappearance-0.5.2-3.fc19

Additional info:
backtrace_rating: 4
cmdline:        lxappearance
crash_function: preview_menu
executable:     /usr/bin/lxappearance
kernel:         3.9.0-0.rc6.git2.3.fc19.i686
runlevel:       N 5
uid:            1000
ureports_counter: 1

Truncated backtrace:
Thread no. 1 (6 frames)
 #0 preview_menu at src/preview.c:92
 #1 preview_theme at src/preview.c:803
 #2 preview_update_all at src/preview_update.c:60
 #3 theme_load_all at src/theme.c:242
 #4 plugin_load at src/main.c:231
 #5 plugins_init at plugin.c:62

Comment 1 Dilyan Arsov 2013-04-19 15:29:19 UTC
Created attachment 737666 [details]
File: backtrace

Comment 2 Dilyan Arsov 2013-04-19 15:29:25 UTC
Created attachment 737667 [details]
File: cgroup

Comment 3 Dilyan Arsov 2013-04-19 15:29:27 UTC
Created attachment 737668 [details]
File: core_backtrace

Comment 4 Dilyan Arsov 2013-04-19 15:29:30 UTC
Created attachment 737669 [details]
File: dso_list

Comment 5 Dilyan Arsov 2013-04-19 15:29:33 UTC
Created attachment 737670 [details]
File: environ

Comment 6 Dilyan Arsov 2013-04-19 15:29:35 UTC
Created attachment 737671 [details]
File: limits

Comment 7 Dilyan Arsov 2013-04-19 15:29:40 UTC
Created attachment 737672 [details]
File: maps

Comment 8 Dilyan Arsov 2013-04-19 15:29:44 UTC
Created attachment 737673 [details]
File: open_fds

Comment 9 Dilyan Arsov 2013-04-19 15:29:46 UTC
Created attachment 737674 [details]
File: proc_pid_status

Comment 10 Dilyan Arsov 2013-04-19 15:29:49 UTC
Created attachment 737675 [details]
File: var_log_messages

Comment 11 Adam Williamson 2013-05-21 04:04:14 UTC
Booted F19 Beta RC2 LXDE live image. Tried to open lxappearance.

reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        lxappearance
crash_function: preview_menu
executable:     /usr/bin/lxappearance
kernel:         3.9.2-301.fc19.x86_64
package:        lxappearance-0.5.2-4.fc19
reason:         Process /usr/bin/lxappearance was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
xsession_errors:

Comment 12 Adam Williamson 2013-05-21 04:05:39 UTC
Final FE, per the 'all apps must run' criterion for blocking desktops.

Comment 13 Fidel Leon 2013-06-07 14:10:10 UTC
Here too, with Fedora 19 Beta 1 LXDE installed in hard disk.

Comment 14 Joel Dávila 2013-07-06 19:05:01 UTC
It crashed at selecting the window border theme.

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        lxappearance
crash_function: preview_menu
executable:     /usr/bin/lxappearance
kernel:         3.9.8-300.fc19.x86_64
package:        lxappearance-0.5.2-4.fc19
reason:         Process /usr/bin/lxappearance was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000
xsession_errors:

Comment 15 christopher 2013-07-09 01:13:09 UTC
sudo lxappearance runs the gui.

Comment 16 Dicky Martin P 2013-07-12 07:35:03 UTC
i got this error 

[root@fedoraproject firefox]# lxappearance 
Segmentation fault (core dumped)

Comment 17 Micha Wali 2013-07-18 06:56:58 UTC
same error here. Is there a workaround beside giving the root password to the user?
micha

Comment 18 Christoph Wickert 2013-07-18 10:44:12 UTC
Why would anyone want to run lxappearance as root? lxappearance crashes regardless of the user.

Comment 19 Micha Wali 2013-07-18 10:48:16 UTC
  Hi Christoph
My comment was based on the hint in comment #15, but i've never tried that...
so forget about the root password ;-) but it's crashing though
micha

Comment 20 christopher 2013-07-18 16:56:26 UTC
(In reply to Christoph Wickert from comment #18)
> Why would anyone want to run lxappearance as root? lxappearance crashes
> regardless of the user.

running lxappearance as root only changes the appearance of root, not the user, so no one.
 
removing lxappearance-obconf worked for me.

Comment 21 David 2013-07-21 18:00:49 UTC
Same happening on a brand new Fedora 19 installation from scratch, both for normal and su user.

Comment 22 Christoph Wickert 2013-07-26 13:34:34 UTC
*** Bug 988792 has been marked as a duplicate of this bug. ***

Comment 23 Adrian Răduca 2013-08-05 06:54:11 UTC
After installing the Fedora 19 LXDE I tried to open lxappearance and got a error that it has crashed, without even opening.

reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        lxappearance
crash_function: preview_menu
executable:     /usr/bin/lxappearance
kernel:         3.9.5-301.fc19.x86_64
package:        lxappearance-0.5.2-4.fc19
reason:         Process /usr/bin/lxappearance was killed by signal 11 (SIGSEGV)
reported_to:    uReport: BTHASH=89f847ca7e582b2267fdb04ec71f20c65e355e5b
runlevel:       N 5
uid:            1000

Comment 24 Markku Piiroinen 2013-08-05 08:30:06 UTC
Try to run lxappearance application

reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        lxappearance
crash_function: preview_menu
executable:     /usr/bin/lxappearance
kernel:         3.10.4-300.fc19.i686
package:        lxappearance-0.5.2-4.fc19
reason:         Process /usr/bin/lxappearance was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000

Comment 25 Miroslav Lichvar 2013-08-13 13:54:39 UTC
This was probably caused by update of openbox from 3.5.0 to a git snapshot. It now fails to build. (bug #992155).

Comment 26 Fedora Update System 2013-08-15 14:31:58 UTC
lxappearance-obconf-0.2.0-4.fc19,obconf-2.0.4-1.fc19,openbox-3.5.2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/lxappearance-obconf-0.2.0-4.fc19,obconf-2.0.4-1.fc19,openbox-3.5.2-2.fc19

Comment 27 Fedora Update System 2013-08-15 23:27:53 UTC
Package lxappearance-obconf-0.2.0-4.fc19, obconf-2.0.4-1.fc19, openbox-3.5.2-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lxappearance-obconf-0.2.0-4.fc19 obconf-2.0.4-1.fc19 openbox-3.5.2-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14831/lxappearance-obconf-0.2.0-4.fc19,obconf-2.0.4-1.fc19,openbox-3.5.2-2.fc19
then log in and leave karma (feedback).

Comment 28 Peter Bieringer 2013-08-16 19:19:29 UTC
Saw same issue, fixed after proposed update from Comment 27

Comment 29 Fedora Update System 2013-08-18 21:31:26 UTC
lxappearance-obconf-0.2.0-4.fc19, obconf-2.0.4-1.fc19, openbox-3.5.2-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 30 fed-up 2013-08-19 18:38:08 UTC
Working!!!


Note You need to log in before you can comment on or make changes to this bug.