Bug 988792 - lxappearance fails to run on Fedora19. Exits with Segmentation Fault
lxappearance fails to run on Fedora19. Exits with Segmentation Fault
Status: CLOSED DUPLICATE of bug 953945
Product: Fedora
Classification: Fedora
Component: lxappearance (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 07:36 EDT by fed-up
Modified: 2013-07-26 09:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-26 09:34:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fed-up 2013-07-26 07:36:21 EDT
Description of problem:
=======================
GTK2/3 theme switcher applet for OpenBox and LXDE.
Starting lxappearance at LXDE terminal results in the following error:

GLib-GObject-CRITICAL, g_object_unref: assertion G_IS_OBJECT failed
Segmentation Fault


Version-Release number of selected component (if applicable):
=============================================================
Package: lxappearance-0.5.2-4.fc19.x86_64.rpm


How reproducible:
=================
Always reproducible.


Steps to Reproduce:
===================
1. # lxappearance
2.
3.


Actual results:
===============
GLib-GObject-CRITICAL, g_object_unref: assertion G_IS_OBJECT failed
Segmentation Fault


Expected results:


Additional info:
================
Issue is related to package lxappearance-obconf (0.2.0-2.fc19). The OpenBox theme switcher for lxappearance.

Removal (yum remove) of the package lxappearance-obconf (0.2.0-2.fc19) from the system allows lxappearance to run without the aforementioned Segmentation Fault.

This issue was not present in Fedora18 (Spherical Cow). New issue in Fedora19.
Comment 1 Christoph Wickert 2013-07-26 09:34:34 EDT

*** This bug has been marked as a duplicate of bug 953945 ***

Note You need to log in before you can comment on or make changes to this bug.