Bug 954190 - /etc/init.d/glusterfsd missing from upstream git compiled rpms
Summary: /etc/init.d/glusterfsd missing from upstream git compiled rpms
Keywords:
Status: CLOSED DUPLICATE of bug 950083
Alias: None
Product: GlusterFS
Classification: Community
Component: build
Version: mainline
Hardware: Unspecified
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-21 18:42 UTC by Justin Clift
Modified: 2015-07-13 04:35 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-20 13:17:17 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 819130 0 medium CLOSED Merge in the Fedora spec changes to build one single unified spec 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 950083 0 medium CLOSED Merge in the Fedora spec changes to build one single unified spec 2021-02-22 00:41:40 UTC

Internal Links: 819130 950083

Description Justin Clift 2013-04-21 18:42:59 UTC
Description of problem:

  The rpms created by compiling upstream gluster git (master) - as of Sun
  21st April 2013 - don't seem to be including /etc/init.d/glusterfsd.

  However, the installation rpm for glusterfs-server still seems to be
  expecting it, so a (non-fatal) error occurs at rpm installation time:

    $ sudo yum install glusterfs-3git-1.el6.x86_64.rpm glusterfs-debuginfo-3git-1.el6.x86_64.rpm glusterfs-devel-3git-1.el6.x86_64.rpm glusterfs-fuse-3git-1.el6.x86_64.rpm glusterfs-server-3git-1.el6.x86_64.rpm
    [verbose content snipped]
    Running rpm_check_debug
    Running Transaction Test
    Transaction Test Succeeded
    Running Transaction
      Installing : glusterfs-3git-1.el6.x86_64                                                                    1/9 
      Installing : libgssglue-0.1-11.el6.x86_64                                                                   2/9 
      Installing : libtirpc-0.2.1-5.el6.x86_64                                                                    3/9 
      Installing : rpcbind-0.2.0-11.el6.x86_64                                                                    4/9 
      Installing : fuse-2.8.3-4.el6.x86_64                                                                        5/9 
      Installing : glusterfs-fuse-3git-1.el6.x86_64                                                               6/9 
      Installing : glusterfs-server-3git-1.el6.x86_64                                                             7/9 
    error reading information on service glusterfsd: No such file or directory
      Installing : glusterfs-devel-3git-1.el6.x86_64                                                              8/9 
      Installing : glusterfs-debuginfo-3git-1.el6.x86_64                                                          9/9 
    [etc]


Version-Release number of selected component (if applicable):

  Upstream glusterfs git master, head branch, commit a1db18cf7a6cde96f2e5b920ffbbf88e72a21fd4.


How reproducible:

   Every time.


Steps to Reproduce:
  1. Build new glusterfs rpms on EL6 using the official instructions at http://www.gluster.org/community/documentation/index.php/CompilingRPMS.

  2. Install the glusterfs-server rpm.

     Error occurs here.

Comment 1 Kaleb KEITHLEY 2013-06-20 13:17:17 UTC
upstream glusterfs.org rpms have historically not provided a /etc/init.d/glusterfsd (or /var/lib/systemd/system/glusterfsd.service). Nor have downstream RHS rpms either, fwiw.

upstream fedoraproject.org rpms do have a /etc/init.d/glusterfsd (or /var/lib/systemd/system/glusterfsd.service)

But see http://review.gluster.org/5179 (release-3.4) and http://review.gluster.org/5230 (master) and feel free to review. In particular see the commit comment about "still considering whether to add fedora glusterfsd.{init,service} files to glusterfs or remove them from fedora."

*** This bug has been marked as a duplicate of bug 950083 ***

Comment 2 Justin Clift 2013-06-20 14:22:14 UTC
Understood.  I don't have a preference either way about the inclusion of glusterfsd in init.d (and maybe systemd equivalent?).

The problem I'm referring to in this bug is the warning message here:

  "error reading information on service glusterfsd: No such file or directory"

Something is creating that warning, which we should fix.  Whether it's by including the glusterfsd it's referring to, or just nuking the warning, I don't have a preference for.

My Gluster installation seems to be working fine (regardless of underlying OS), even when this warning happens... so maybe we should just kill the warning?


Note You need to log in before you can comment on or make changes to this bug.