Bug 955664 - No multipath disks selected
No multipath disks selected
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
ppc64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
RejectedBlocker AcceptedFreezeExcepti...
: CommonBugs
Depends On:
Blocks: F19-accepted/F19FinalFreezeException F19PPCBeta/F19PPCBetaBlocker/PPCBetaBlocker
  Show dependency treegraph
 
Reported: 2013-04-23 09:39 EDT by Mark Hamzy
Modified: 2013-07-05 18:44 EDT (History)
12 users (show)

See Also:
Fixed In Version: anaconda-19.30.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-12 17:45:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
No multipath disks selected (43.22 KB, image/png)
2013-04-23 09:39 EDT, Mark Hamzy
no flags Details
anaconda.log (6.20 KB, text/plain)
2013-04-23 09:42 EDT, Mark Hamzy
no flags Details
storage.log (117.97 KB, text/plain)
2013-04-23 09:42 EDT, Mark Hamzy
no flags Details
program.log (22.09 KB, text/plain)
2013-04-23 09:43 EDT, Mark Hamzy
no flags Details
syslog (128.99 KB, text/plain)
2013-04-23 09:44 EDT, Mark Hamzy
no flags Details
storage.log (56.58 KB, text/plain)
2013-05-03 13:46 EDT, Mark Hamzy
no flags Details
Video of problem (3.35 MB, application/octet-stream)
2013-05-08 11:17 EDT, Mark Hamzy
no flags Details
New storage.log (159.59 KB, text/plain)
2013-05-08 11:19 EDT, Mark Hamzy
no flags Details
New program.log (23.75 KB, text/plain)
2013-05-08 11:24 EDT, Mark Hamzy
no flags Details
Video of problem with 955664.img (2.83 MB, video/ogg)
2013-05-20 12:08 EDT, Mark Hamzy
no flags Details

  None (edit)
Description Mark Hamzy 2013-04-23 09:39:55 EDT
Created attachment 739000 [details]
No multipath disks selected

On an iso built with http://ppc.koji.fedoraproject.org/mash/branched-20130422/19-ppc/ppc64/os/ and a patched kernel ( 3.9.0-0.rc7.git3.1.gld.fc19.ppc64 with https://patchwork.kernel.org/patch/2183891/ ), I see a "no disks selected" error.

This is using:
anaconda-19.20-1.fc19.ppc64
python-blivet-0.11-1.fc19.noarch

[anaconda root@riley6 ~]# uname -a
Linux riley6.stglabs.ibm.com 3.9.0-0.rc7.git3.1.gld.fc19.ppc64 #1 SMP Mon Apr 22 13:33:44 CDT 2013 ppc64 ppc64 ppc64 GNU/Linux
[anaconda root@riley6 ~]# head -n 1 /tmp/anaconda.log
11:47:08,602 INFO anaconda: /sbin/anaconda 19.20-1
[anaconda root@riley6 ~]# multipath -ll
mpatha (3600507680281026d6800000000000001) dm-0 IBM     ,2145
size=15G features='1 queue_if_no_path' hwhandler='0' wp=rw
|-+- policy='service-time 0' prio=50 status=active
| |- 1:0:4:0 sda 8:0  active ready running
| `- 2:0:4:0 sdc 8:32 active ready running
`-+- policy='service-time 0' prio=10 status=enabled
  |- 1:0:5:0 sdb 8:16 active ready running
  `- 2:0:5:0 sdd 8:48 active ready running
[anaconda root@riley6 ~]# ls -l /dev/mapper/
total 0
crw-------. 1 root root 10, 236 Apr 23 11:46 control
lrwxrwxrwx. 1 root root       7 Apr 23 11:47 live-rw -> ../dm-4
lrwxrwxrwx. 1 root root       7 Apr 23 11:47 mpatha -> ../dm-0
lrwxrwxrwx. 1 root root       7 Apr 23 11:47 mpathap1 -> ../dm-1
lrwxrwxrwx. 1 root root       7 Apr 23 11:47 mpathap2 -> ../dm-2
lrwxrwxrwx. 1 root root       7 Apr 23 11:47 mpathap3 -> ../dm-3
[anaconda root@riley6 ~]# cat /etc/multipath/wwids
# Multipath wwids, Version : 1.0
# NOTE: This file is automatically maintained by multipath and multipathd.
# You should not need to edit this file in normal circumstances.
#
# Valid WWIDs:
/3600507680281026d6800000000000001/
Comment 1 Mark Hamzy 2013-04-23 09:42:11 EDT
Created attachment 739001 [details]
anaconda.log
Comment 2 Mark Hamzy 2013-04-23 09:42:39 EDT
Created attachment 739002 [details]
storage.log
Comment 3 Mark Hamzy 2013-04-23 09:43:46 EDT
Created attachment 739006 [details]
program.log
Comment 4 Mark Hamzy 2013-04-23 09:44:16 EDT
Created attachment 739007 [details]
syslog
Comment 5 Mark Hamzy 2013-04-26 10:39:18 EDT
Proposing as a FinalBlocker:

The installer must be able to complete an installation using any network-attached storage devices (e.g. iSCSI, FCoE, Fibre Channel)
Comment 6 Mark Hamzy 2013-05-03 13:45:21 EDT
This is what I currently see with:

kernel-3.9.0-301.fc19
anaconda-19.23-1.fc19
python-blivet-0.11-1.fc19
device-mapper-multipath-0.4.9-50.fc19
private patches from dlehman

http://hamzy.fedorapeople.org/out201305021358.avi

I see "Automatic partitioning selected."
I click on "Installation destination," select mpatha in "Specialized & Network Disks," and click "Done."
Now, on the main hub I see "No disks selected."
Going back into "Installation destination," I see no disks at all (either selected or unselected) in both "Local Standard Disks" and "Specialized & Network Disks."
Comment 7 Mark Hamzy 2013-05-03 13:46:08 EDT
Created attachment 743310 [details]
storage.log

New storage.log
Comment 8 Mark Hamzy 2013-05-03 13:47:32 EDT
[anaconda root@riley6 ~]# multipath -ll
mpatha (3600507680281026d6800000000000001) dm-0 IBM     ,2145            
size=15G features='1 queue_if_no_path' hwhandler='0' wp=rw
|-+- policy='service-time 0' prio=50 status=active
| |- 1:0:4:0 sde 8:64 active ready running
| `- 2:0:4:0 sdc 8:32 active ready running
`-+- policy='service-time 0' prio=10 status=enabled
  |- 1:0:5:0 sdf 8:80 active ready running
  `- 2:0:5:0 sdd 8:48 active ready running
[anaconda root@riley6 ~]# ls -l /dev/mapper
total 0
crw-------. 1 root root 10, 236 May  3 14:14 control
lrwxrwxrwx. 1 root root       7 May  3 14:14 live-rw -> ../dm-2
lrwxrwxrwx. 1 root root       7 May  3 14:14 mpatha -> ../dm-0
lrwxrwxrwx. 1 root root       7 May  3 14:14 mpatha1 -> ../dm-1
Comment 9 Fedora Update System 2013-05-03 19:04:12 EDT
anaconda-19.24-1.fc19, python-blivet-0.12-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-blivet-0.12-1.fc19,anaconda-19.24-1.fc19
Comment 10 Fedora Update System 2013-05-04 14:50:21 EDT
Package anaconda-19.24-1.fc19, python-blivet-0.12-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.24-1.fc19 python-blivet-0.12-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-7403/python-blivet-0.12-1.fc19,anaconda-19.24-1.fc19
then log in and leave karma (feedback).
Comment 11 Mark Hamzy 2013-05-04 17:25:29 EDT
The fix does not work.  I'm still seeing the system act like comment 6 and on.

I see "Automatic partitioning selected."
I click on "Installation destination," select mpatha in "Specialized & Network Disks," and click "Done."
Now, on the main hub I see "No disks selected."
Going back into "Installation destination," I see no disks at all (either selected or unselected) in both "Local Standard Disks" and "Specialized & Network Disks."
Comment 12 Mark Hamzy 2013-05-04 22:34:42 EDT
For a normal disk:

1) The disk is both highlighted and has a checkmark.

http://hamzy.fedorapeople.org/InstallationDestinationStandard1.png

2) Clicking removed both the highlight and the checkmark.

http://hamzy.fedorapeople.org/InstallationDestinationStandard2.png

3) Clicking again adds both the highlight and the checkmark.

http://hamzy.fedorapeople.org/InstallationDestinationStandard1.png



For a multipath disk:

1) The disk only has a checkmark

http://hamzy.fedorapeople.org/InstallationDestinationSpecialized1.png

2) Clicking removes the checkmark and highlights the disk

http://hamzy.fedorapeople.org/InstallationDestinationSpecialized2.png

3) Clicking again keeps the highlight and adds the checkmark

http://hamzy.fedorapeople.org/InstallationDestinationSpecialized3.png

4) Clicking again keeps the highlight and removes the checkmark.

http://hamzy.fedorapeople.org/InstallationDestinationSpecialized2.png



I believe that there are two problems.  1) The multipath disk should be highlighted. 2) If you click Done when the multipath disk is not checkmarked, the multipath disk disappears the next time you enter the dialog.
Comment 13 Mark Hamzy 2013-05-08 11:17:18 EDT
Created attachment 745285 [details]
Video of problem
Comment 14 Mark Hamzy 2013-05-08 11:18:41 EDT
1) at 0:04, the multipath disk does not have keyboard focus like a single disk would have (ex: the blue rectangle)
2) at 0:15 the multipath disk disappears because it was unchecked. This is different than the single disk case as well
3) at 0:20 the multipath disk is not in the multipath devices tab
4) at 0:49 it seems there is a multipath disk selected after all
Comment 15 Mark Hamzy 2013-05-08 11:19:31 EDT
Created attachment 745287 [details]
New storage.log
Comment 16 Mark Hamzy 2013-05-08 11:24:46 EDT
Created attachment 745288 [details]
New program.log
Comment 17 Samantha N. Bueno 2013-05-09 14:53:37 EDT
After discussing in #fedora-ppc and watching the video in comment 13, I think I see what the problems/confusion are:

01) You are used to seeing a disk highlighted _and_ selected (as described for a normal disk) when entering the storage spoke. mpath devices only show a checkmark. The checkmark over the disk icon is what indicates that the disk is selected for use though.
When you click the disk icon again, you are de-selecting the disk for use. This is why the checkmark vanishes and the storage spoke status is then set to 'No disks selected'.

02) Also, from what I can see in the video, when you go to 'Add a disk' in the storage spoke, the mpath device isn't listed in the 'Multipath Devices' tab, even though it does show up in the 'Search' tab.

03) After checking the device for use from the 'Search' tab, a disk icon still doesn't show up in the 'Specialized & Network Disks' area of the storage spoke.
Comment 18 Chris Lumens 2013-05-14 11:05:52 EDT
For #1 - The blue box now only indicates focus, not selection.  We could have done a better job explaining that change, but that's what is going on there.

For #2 - I think I have seen this before, but never consistently enough to be able to debug and fix.

For #3 - What version of anaconda are you using?  I can put together an updates.img for you.
Comment 19 Mark Hamzy 2013-05-14 14:44:48 EDT
We are using anaconda-19.25-1.

The following two issues, I believe are problems:

1)

at 0:04, the multipath disk does not have keyboard focus like a single disk would have (ex: the blue rectangle)

2)

at 0:15, the multipath disk is not seen (because it was unchecked the first time in the installation destination dialog (0:08)). This is different than the single disk case as well.
at 0:20, no multipath is also seen in the "Multipath Devices" tab
at 0:24, the disk shows up in the "Search" tab
at 0:49, the multipath disk is used

Do you agree? If so, we can use this bug 955664 for #2? Should I make a clone for #1?
Comment 20 Chris Lumens 2013-05-16 14:02:00 EDT
I really don't consider a keyboard focus thing to be big enough of a problem to deal with it right now.  It's certainly not going to be a blocker.

For disks not being seen, please try out http://clumens.fedorapeople.org/955664.img.  This is against anaconda-19.28 and requires python-blivet-0.12 or later as well.  Thanks.
Comment 21 Mark Hamzy 2013-05-17 10:27:08 EDT
There was no change on a system with anaconda-19.28-1.fc19 and python-blivet-0.14-1.fc19
Comment 22 Mark Hamzy 2013-05-17 10:27:50 EDT
Using

boot: linux inst.vnc inst.sshd inst.debug ip=9.114.214.127::9.114.214.254:255.255.255.0:riley6.stglabs.ibm.com:eth0:none nameserver=9.114.8.1 live.updates=http://clumens.fedorapeople.org/955664.img
Comment 23 Samantha N. Bueno 2013-05-20 09:43:14 EDT
Was there no change at all? E.g. did all three issues noted in comment 17 still persist? I don't think Chris was looking to fix the highlighting issue at this moment, but a disk icon should definitely be seen in the storage spoke after adding a multipath device.
Comment 24 Mark Hamzy 2013-05-20 12:08:31 EDT
Created attachment 750643 [details]
Video of problem with 955664.img

01 and 02 did not change.
03 did change.

However, the disk disappears at 0:22 in the new video. Which is not one of the problems you describe in comment #17.
Comment 25 Chris Lumens 2013-05-28 15:30:07 EDT
Okay, I see what's going on with disks disappearing from the multipath tab on the filter screen.  It appears to be related to you having the disk selected before, and then unselecting it.  I've mailed off a patch for that.

For the icon disappearing from the main storage spoke when you unselect it and go back and forth to the hub - I don't consider that a bug.  What's going on is that advanced disks are special.  You could potentially have a very large number of them, and we do not necessarily want to list them all in that box.  The filter UI is how you select disks for inclusion, so when you deselect a disk, you are essentially filtering it out.
Comment 26 Adam Williamson 2013-05-29 12:58:35 EDT
Discussed at 2013-05-29 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-29/f19final-blocker-review-1.2013-05-29-16.02.log.txt . From what we can read into this long bug, it looks like there's some check mark UI confusion - so see https://bugzilla.redhat.com/show_bug.cgi?id=967682 - and then an actual bug where multipath targets disappear after you ping-pong the spoke a bit. That's an inconvenience but doesn't seem to be a showstopper, so we rejected this as a blocker but accepted it as an FE issue.
Comment 27 Adam Williamson 2013-06-12 17:45:16 EDT
We're well past 19.30.1-1 now. This ought to be fixed, so closing. Mark, please re-open if you're still hitting this.
Comment 28 Mark Hamzy 2013-06-24 11:52:32 EDT
Adding the CommonBugs keyword as I believe that there are two gotchas which multipath users will hit.

1) A system with only a multipath disk acts differently than a system with only a scsi disk (or other normal disk).  The blue selection is not applied to the multipath disk.  And you you select it, you then uncheck it.

2) If a multipath disk is unchecked and you come back to the installation disk dialog, then the multipath disk is no longer seen.  You need to search for it or go to the multipath tab to find it again. This is different than how a normal disk is handled.
Comment 29 Adam Williamson 2013-07-01 02:04:22 EDT
1) is not 'differently' to any other system. This was changed between F18 and F19. Regular disks also use the checkmark selection indicator in F19. The blue highlight is really a highlight now, not a selection indicator. There is already a Common Bugs note for this.

2) sounds like it should be documented indeed.
Comment 30 Mark Hamzy 2013-07-01 10:39:31 EDT
Adam,

Have you tried running the installer on a system which only have a multipath disk on it?  I can upload two different videos which clearly demonstrates #1.
Comment 31 Adam Williamson 2013-07-01 11:32:24 EDT
No, I don't have any multipath disks. Can you provide a better description? (Or a video would be fine).
Comment 32 Mark Hamzy 2013-07-02 11:32:51 EDT
Okay, I tested on a system with only one SCSI disk and Fedora 19-GA and Comment 12 is not the default anymore. That is, you do not see http://hamzy.fedorapeople.org/InstallationDestinationStandard1.png when you click "Installation Destination" anymore.

So now the CommonBugs is:

1) If a multipath disk is unchecked, you click Done, and come back to the installation disk dialog, then the multipath disk is no longer seen.  You need to search for it or go to the multipath tab to find it again. This is different than how a normal disk is handled.

Note You need to log in before you can comment on or make changes to this bug.