This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 967682 - Check mark used to indicate selected target disks on Installation Destination is not sufficiently obvious
Summary: Check mark used to indicate selected target disks on Installation Destination...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 19
Hardware: All All
unspecified
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException https://fedor...
Keywords: CommonBugs
Depends On:
Blocks: F19-accepted, F19FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2013-05-28 02:05 UTC by Adam Williamson
Modified: 2014-01-14 21:00 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-14 20:46:37 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Williamson 2013-05-28 02:05:45 UTC
In Fedora 18, disks selected as installation targets on the Installation Screen were indicated by being highlighted in blue. This I think had its own issues, but it was at least pretty obvious.

In Fedora 19 this has been changed so that 'selected' status is indicated by a relatively unobtrusive check mark. Reports in the forums and elsewhere have suggested that not all users pick up on this; it seems that several users have thought their single disk was not selected when they entered the screen, and so clicked on it to 'select' it (in fact doing precisely the reverse) and then clicked Done only to find themselves back at the hub with a 'No disks selected' warning.

Also note https://bugzilla.redhat.com/show_bug.cgi?id=959677 : as we understand it, most of the reporters of that bug most likely made this same mistake, indicating that it is relatively common and hence that the UI is not totally clear.

Perhaps the check mark could be made bigger, or more colorful, or more prominent in some other way?

Comment 1 Adam Williamson 2013-05-28 23:40:43 UTC
proposing as a Final freeze exception, this has definitely been catching users out and it'd be nice if we can improve it somehow.

Comment 2 Adam Williamson 2013-05-29 16:49:35 UTC
Another piece of supporting evidence from 959677, https://bugzilla.redhat.com/show_bug.cgi?id=959677#c41 :

"I went into the hard disk install location screen, picked the only available hard disk and clicked on "Done"."

Of course, what he actually did was *un*pick the only available hard disk, but clearly that wasn't obvious to him.

Comment 3 Dennis Jacobfeuerborn 2013-05-30 11:03:49 UTC
I initially was caught by this as well. One issue I think is the fact that unselected disks don't get an icon at all which makes it easy to mistake a disk that is highlighted due to a click as "selected".

What I would propose is to make the selection icon both a bit larger and a bright green to make it visually stand out but also add a similar icon with a red X for unselected disks. That way the disk can be more explicitly seen as unselected even with the blue highlight background.

Comment 4 Adam Williamson 2013-05-30 18:46:04 UTC
Discussed at 2013-05-30 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-30/f19final-blocker-review-1.1.2013-05-30-16.02.log.txt . Accepted as a freeze exception issue: if anaconda team agrees this needs to change, it obviously makes sense to fix it for F19 Final, the fix should be fairly safe and we can't fix it with an update.

Comment 5 Chris Lumens 2013-12-09 18:05:46 UTC
mizmo - Can we just make the checkmark bigger?

Comment 6 Máirín Duffy 2013-12-21 05:30:51 UTC
I think when the icons for the disks get shrunk, keeping the checkboxes the same size would make them effectively bigger, so maybe see how that looks.

Comment 7 Chris Lumens 2014-01-14 20:46:37 UTC
As part of changing the custom part workflow, I've also made the checkmarks larger relative to the size of the disk icon.

Comment 8 Adam Williamson 2014-01-14 21:00:22 UTC
...and if that doesn't work we'll just keep making 'em bigger till the whole damn *screen* is a checkmark.

and then make it blink. ;)


Note You need to log in before you can comment on or make changes to this bug.