Bug 956290 - [netkvm] Race condition on surprise removal in XP/2003 driver
Summary: [netkvm] Race condition on surprise removal in XP/2003 driver
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win
Version: 6.5
Hardware: Unspecified
OS: Windows
unspecified
low
Target Milestone: rc
: ---
Assignee: Dmitry Fleytman
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-24 15:22 UTC by Dmitry Fleytman
Modified: 2013-12-06 07:47 UTC (History)
8 users (show)

(edit)
Cause: 
Surprise removal of the device might cause the driver to hang. While reproduce in test only environment this condition can theoretically appear during device hot unplug.

Consequence: 
Driver hangs and cannot be unloaded. No network on the guest reboot. 

Fix: 
Fix locking sequence.

Result: 
Driver will no longer hang during surprise removal.
Clone Of:
(edit)
Last Closed: 2013-11-22 00:10:37 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1729 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2013-11-21 00:39:25 UTC

Description Dmitry Fleytman 2013-04-24 15:22:04 UTC
Description of problem:

There is a race condition in XP/2003 drivers that may lead to driver unload failure in case of surprise removal under heavy traffic.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 3 Mike Cao 2013-05-30 03:28:09 UTC
Hi, Dima 

How to verify this bug ,Is runing HCK "Plug and Play job" enough ? 

BTW, We have MSFT Manual Errata about Plug and Play job hangs at "TestSurpriseRemove operation timed out" details referring to Bug 834230 ,Will your patch make QE no more hit this issue ?

Thanks,
Mike

Comment 5 Dmitry Fleytman 2013-06-17 15:24:39 UTC
Hello Mike,

Sorry for not answering before, I've missed your comment.

This is a theoretic case, I'm not sure it is possible to reproduce it artificially. In any case, please run "Plug and Play job" and verify there is no regression.

Also I'm pretty sure this is not the reason why we observe "TestSurpriseRemove operation timed out" in this test, so errata still needed.

Dmitry. 

(In reply to Mike Cao from comment #3)
> Hi, Dima 
> 
> How to verify this bug ,Is runing HCK "Plug and Play job" enough ? 
> 
> BTW, We have MSFT Manual Errata about Plug and Play job hangs at
> "TestSurpriseRemove operation timed out" details referring to Bug 834230
> ,Will your patch make QE no more hit this issue ?
> 
> Thanks,
> Mike

Comment 6 Min Deng 2013-06-18 03:07:59 UTC
(In reply to Dmitry Fleytman from comment #5)
> Hello Mike,
> 
> Sorry for not answering before, I've missed your comment.
> 
> This is a theoretic case, I'm not sure it is possible to reproduce it
> artificially. In any case, please run "Plug and Play job" and verify there
> is no regression.
> 
> Also I'm pretty sure this is not the reason why we observe
> "TestSurpriseRemove operation timed out" in this test, so errata still
> needed.
> 
> Dmitry. 
> 
> (In reply to Mike Cao from comment #3)
> > Hi, Dima 
> > 
> > How to verify this bug ,Is runing HCK "Plug and Play job" enough ? 
> > 
> > BTW, We have MSFT Manual Errata about Plug and Play job hangs at
> > "TestSurpriseRemove operation timed out" details referring to Bug 834230
> > ,Will your patch make QE no more hit this issue ?
> > 
> > Thanks,
> > Mike

Hi all,
   I've tested Plug and Play job on win2k3-32/64 and winxp guest via build 64,it fortunately passed on winxp guest but still failed on win2k3-32/64 guest.So there is still a issue for this part and then the failure reason is  "TestSurpriseRemove operation timed out",it's same to the errata descriptions

Best regards,
Min

Comment 7 Min Deng 2013-06-18 03:29:03 UTC
   In a word,we can use manual errata #1019 to filter the failure for win2k3-32/64 via build 64.
   FYI,
   Manual Errata #1019 - Job:Plug and Play job description:Plug and Play job hangs at "TestSurpriseRemove operation timed out".It is ever requested by Yan.
   Any issues please let me know.
Best regards
Min
   (In reply to dengmin from comment #6)
> (In reply to Dmitry Fleytman from comment #5)
> > Hello Mike,
> > 
> > Sorry for not answering before, I've missed your comment.
> > 
> > This is a theoretic case, I'm not sure it is possible to reproduce it
> > artificially. In any case, please run "Plug and Play job" and verify there
> > is no regression.
> > 
> > Also I'm pretty sure this is not the reason why we observe
> > "TestSurpriseRemove operation timed out" in this test, so errata still
> > needed.
> > 
> > Dmitry. 
> > 
> > (In reply to Mike Cao from comment #3)
> > > Hi, Dima 
> > > 
> > > How to verify this bug ,Is runing HCK "Plug and Play job" enough ? 
> > > 
> > > BTW, We have MSFT Manual Errata about Plug and Play job hangs at
> > > "TestSurpriseRemove operation timed out" details referring to Bug 834230
> > > ,Will your patch make QE no more hit this issue ?
> > > 
> > > Thanks,
> > > Mike
> 
> Hi all,
>    I've tested Plug and Play job on win2k3-32/64 and winxp guest via build
> 64,it fortunately passed on winxp guest but still failed on win2k3-32/64
> guest.So there is still a issue for this part and then the failure reason is
> "TestSurpriseRemove operation timed out",it's same to the errata descriptions
> 
> Best regards,
> Min
   In a word,we can use manual errata #1019 to filter the failure for win2k3-32/64 via build 64.
   FYI,
   Manual Errata #1019 - Job:Plug and Play job description:Plug and Play job hangs at "TestSurpriseRemove operation timed out".It is ever requested from MS by Yan.
   Any issues please let me know.
Best regards
Min

Comment 8 Mike Cao 2013-06-21 06:07:25 UTC
Move status to VERIFIED according to comment #7.

Comment 13 errata-xmlrpc 2013-11-22 00:10:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1729.html


Note You need to log in before you can comment on or make changes to this bug.