Bug 956333 - colord-kde doesn't see displays - starting too early?
Summary: colord-kde doesn't see displays - starting too early?
Keywords:
Status: CLOSED DUPLICATE of bug 956438
Alias: None
Product: Fedora
Classification: Fedora
Component: colord-kde
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Reznik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-24 17:28 UTC by Ian Pilcher
Modified: 2013-04-27 18:21 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-27 18:21:14 UTC
Type: Bug


Attachments (Terms of Use)

Description Ian Pilcher 2013-04-24 17:28:26 UTC
Description of problem:
Trying to apply an ICC color profile to my laptop display, I have found that colord does not see any displays until it is restarted.  For example:

[ipilcher@localhost ~]$ colormgr get-devices
Object Path:   /org/freedesktop/ColorManager/devices/sysfs_Ricoh_Company_Ltd__Integrated_Camera
Owner:         root
Created:       April 25 2013, 02:10:19 AM
Modified:      April 25 2013, 02:10:19 AM
Type:          webcam
Enabled:       Yes
Embedded:      Yes
Model:         Integrated Camera
Vendor:        Ricoh Company
Serial:        /sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6/1-1.6:1.0/video4linux/video0
Seat:          seat0
Colorspace:    rgb
Device ID:     sysfs-Ricoh_Company_Ltd.-Integrated_Camera
Metadata:      CMS=colord

[ipilcher@localhost ~]$ sudo systemctl restart colord.service

[ipilcher@localhost ~]$ colormgr get-devices
Object Path:   /org/freedesktop/ColorManager/devices/sysfs_Ricoh_Company_Ltd__Integrated_Camera
Owner:         root
Created:       April 25 2013, 02:16:02 AM
Modified:      April 25 2013, 02:16:02 AM
Type:          webcam
Enabled:       Yes
Embedded:      Yes
Model:         Integrated Camera
Vendor:        Ricoh Company
Serial:        /sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6/1-1.6:1.0/video4linux/video0
Seat:          seat0
Colorspace:    rgb
Device ID:     sysfs-Ricoh_Company_Ltd.-Integrated_Camera
Metadata:      CMS=colord

Object Path:   /org/freedesktop/ColorManager/devices/xrandr_Seiko_Epson_Corporation_ipilcher_1000
Owner:         ipilcher
Created:       April 25 2013, 02:16:02 AM
Modified:      April 25 2013, 02:16:02 AM
Type:          display
Enabled:       Yes
Embedded:      No
Model:         2356JK8
Vendor:        Lenovo
Serial:        unknown
Seat:          seat0
Scope:         temp
Colorspace:    rgb
Device ID:     xrandr-Seiko Epson Corporation
Profile 1:     icc-b65629910a84555316258eb6148af930
               /var/lib/colord/icc/t430s_1600x900.icc
Profile 2:     icc-419595cdf6b987e214e808ee976e4643
               /home/ipilcher/.local/share/icc/edid-58b75c5ef69738473c9f7daf76241804.icc
Metadata:      XRANDR_name=LVDS1
Metadata:      OwnerCmdline=kded4

Version-Release number of selected component (if applicable):
colord-kde-0.2.0-2.fc18.x86_64

How reproducible:
100%

Steps to Reproduce:
1.  Log in to KDE.
2.  Run "colormgr get-devices"; note that display(s) are not shown.
3.  Restart colord -- "sudo systemctl restart colord.service".
4.  Run "colormgr get-devices"; not that display(s) are now shown.
  
Actual results:
colord does not see displays until restarted.

Expected results:
colord should automatically detect displays.

Additional info:

Comment 1 Ian Pilcher 2013-04-24 21:14:24 UTC
I have changed X-KDE-Kded-phase to 2 in /usr/share/kde4/services/kded/colord.desktop, and my display(s) now show up when I run "colormgr get-devices" immediately after logging in.

Comment 2 Ian Pilcher 2013-04-27 18:21:14 UTC
Even though this isn't really the same bug, I'm closing this as a duplicate of 956438, since both issues are fixed in upstream git.

*** This bug has been marked as a duplicate of bug 956438 ***


Note You need to log in before you can comment on or make changes to this bug.