Bug 956438 - Selected color profile not actually applied to display at startup
Summary: Selected color profile not actually applied to display at startup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: colord-kde
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukáš Tinkl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 956333 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-24 22:25 UTC by Ian Pilcher
Modified: 2015-07-13 17:35 UTC (History)
7 users (show)

Fixed In Version: colord-kde-0.3.0-1.fc18
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-06 01:36:04 UTC
Type: Bug


Attachments (Terms of Use)
SPEC file to build from upstream git (1.90 KB, text/plain)
2013-04-27 18:24 UTC, Ian Pilcher
no flags Details

Description Ian Pilcher 2013-04-24 22:25:34 UTC
Description of problem:
When a non-default color profile has been selected for a display, it is not actually applied during KDE startup.  I have to use the System Settings --> Color applet to "toggle" the display's profile to something else and then back to the desired color profile, at which point it is actually applied.

Version-Release number of selected component (if applicable):
colord-kde.x86_64  0.2.0-2.fc18

How reproducible:
100%

Steps to Reproduce:
1.  Use the Color applet to select a visually distinctive color profile for
    a display.  ("Test profile: Blue" seems to work best.)  Note that the
    display immediately looks bluish, because the selected color profile has
    been applied.
2.  Log out and log back in to KDE.
3.  Note that display does not have a bluish appearance.
4.  Open Color applet and note that "Test profile: Blue" is still the selected
    profile for the display, even thought it's not actually being used.
5.  Select the default profile for the display and then re-select "Test
    profile: Blue".  Note that the display once again appears bluish.
  
Actual results:
Selected color profile is not applied at KDE startup.

Expected results:
Selected color profile should be automatically applied.

Additional info:
GNOME does not suffer from this issue.  The selected profile is used automatically (even if it has been selected in KDE).

Comment 1 Lukáš Tinkl 2013-04-25 12:40:14 UTC
New release (fixing this bug and others) pending, stay tuned :)

Comment 2 Ian Pilcher 2013-04-26 15:34:28 UTC
(In reply to comment #1)
> New release (fixing this bug and others) pending, stay tuned :)

Hmm, I don't see anything in Koji.  I hope you're not planning on waiting for a new upstream release.

Comment 3 Ian Pilcher 2013-04-27 18:21:14 UTC
*** Bug 956333 has been marked as a duplicate of this bug. ***

Comment 4 Ian Pilcher 2013-04-27 18:24:20 UTC
Created attachment 740867 [details]
SPEC file to build from upstream git

I don't have any confidence that there will be a new upstream release any time soon.  Here is a SPEC file to build from the current git snapshot, which fixes both this issue and 956333.

Comment 5 Daniel Nicoletti 2013-04-29 13:38:35 UTC
Yes there will be, I have only a few TODOs pending before I do one.

Comment 6 Ian Pilcher 2013-05-24 17:51:30 UTC
(In reply to Daniel Nicoletti from comment #5)
> Yes there will be, I have only a few TODOs pending before I do one.

I am happy to see that my scepticism was unfounded.  Thank you, Daniel!

Lukáš - Can we get an update to 0.3.0?  (And I'd suggest updating the %files section, so that the RPM doesn't claim /usr/share/kde4/services/kded.)

Thanks!

Comment 7 Fedora Update System 2013-05-27 13:42:51 UTC
colord-kde-0.3.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/colord-kde-0.3.0-1.fc18

Comment 8 Fedora Update System 2013-05-28 01:00:30 UTC
Package colord-kde-0.3.0-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing colord-kde-0.3.0-1.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9402/colord-kde-0.3.0-1.fc18
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2013-06-06 01:36:04 UTC
colord-kde-0.3.0-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.