Bug 956908 - Evolution forgets account settings
Summary: Evolution forgets account settings
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 19
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-26 00:20 UTC by Ankur Sinha (FranciscoD)
Modified: 2013-05-02 09:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-26 15:18:19 UTC
Type: Bug


Attachments (Terms of Use)
Screen shot showing that no settings are present. (25.95 KB, image/png)
2013-04-26 00:20 UTC, Ankur Sinha (FranciscoD)
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 698726 0 None None None Never
Red Hat Bugzilla 954046 0 unspecified CLOSED [abrt] gnome-online-accounts-3.8.1-1.fc19: Process /usr/libexec/goa-daemon was killed by signal 11 (SIGSEGV) 2021-02-22 00:41:40 UTC

Internal Links: 954046

Description Ankur Sinha (FranciscoD) 2013-04-26 00:20:19 UTC
Created attachment 740133 [details]
Screen shot showing that no settings are present.

Description of problem:
Sometimes, evolution starts up and all the account settings that had been made are missing. They are back to blank, as if the account was newly made. 

Version-Release number of selected component (if applicable):
evolution-3.8.1-1.fc19.x86_64

How reproducible:
Frequently

Steps to Reproduce:
1. Open evolution
2. Right click on an account, check settings
3.
  
Actual results:
Settings are all blank, as if the account was just set up

Expected results:
Account settings should be retained

Additional info:
It's annoying, since all settings need to be remade:

gpg keys, sent/draft folders, what folders to sync, signatures for each account (signatures remain, but are not anchored to any account)

I've already had to do this a couple of times. Could be after evolution or a related binary crashes, but I can't be certain.

Comment 1 Milan Crha 2013-04-26 06:38:40 UTC
Thanks for a bug report. I would guess this happened after some update, some libraries might not be read/loaded properly, because the screenshot seems to me as being from an account editor, not a wizard which runs when there are no accounts found, and it's missing quite few items on the left side, as far as I can tell.

Could you run evolution from a console, and check whether it claims anything there, please? Also, could you try to figure out after what circumstances you get this brokenness? I guess if the terminal will be filled with some critical warnings, then we'll have a little clue at least.

Comment 2 Ankur Sinha (FranciscoD) 2013-04-26 07:40:13 UTC
Hi Milan,

Running evolution from a console did nothing. The screenshot is of my google account preferences in evolution (right click account > properties). The account is part of my google setup using goa. I think this happens each time either goa-daemon or evolution-source-registry crashes. It just happened again. ABRT pointed me to 

https://bugzilla.redhat.com/show_bug.cgi?id=954046

Goa crashed, none of the accounts came up in evolution. I manually started goa-daemon. Nothing came up, so I killed evolution-source-registry. Now the accounts have come up (one gmail, one exchange, both setup using goa), but their settings aren't there. I must set them up again.

Thanks,
Ankur

Comment 3 Milan Crha 2013-04-26 14:54:09 UTC
Aah, I see, configured from GOA, that makes sense. I saw a discussion about this just yesterday. Let's try to bring in more people. Ray?

Comment 4 Milan Crha 2013-04-26 15:18:19 UTC
I was pointed to [1], let's go there with this issue.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=698726

Comment 5 Ankur Sinha (FranciscoD) 2013-04-26 16:08:12 UTC
Added myself to upstream bug. Thanks Milan. I'll follow it there.

Warm regards,
Ankur

Comment 6 Ankur Sinha (FranciscoD) 2013-04-30 23:59:39 UTC
Hi Milan,

The upstream bug has been resolved as FIXED with a git commit available. When do you think 3.8.2 will hit fedora? Evolution is becoming *really* difficult to use. goa has crashed on me 5 times successively this morning and with it all my accounts from evolution have gone too, and all my settings. It's a productivity killer I'm afraid. Would it be possible to please use a patch and push an update for the current evolution version? I'd really like to have my mail client back ASAP :(

Thanks,
Ankur

Comment 7 Milan Crha 2013-05-02 08:45:04 UTC
Sure, 3.8.2 release is planned around May 13th, thus I'm building an update for you. Please note that it's possible that the package will make it in stable not that early, but it'll be available in updates-testing shortly after I build it and file the update for it. Also note that the right fix would come to GOA itself, to not crash.

Comment 8 Ankur Sinha (FranciscoD) 2013-05-02 08:49:19 UTC
Sounds good Milan. Thanks. I'll test the update and give it karma. Since I'm on F19, updates-testing is enabled at the moment.

I read the upstream comments. It doesn't look like goa upstream is planning a fix at the moment. The upstream bug was closed as RESOLVED with Matthew's evolution patch. I'll keep an eye out for it though. 

Thanks again,
Warm regards,
Ankur

Comment 9 Fedora Update System 2013-05-02 09:17:59 UTC
evolution-data-server-3.8.1-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/evolution-data-server-3.8.1-2.fc19

Comment 10 Milan Crha 2013-05-02 09:21:38 UTC
(In reply to comment #8)
> I read the upstream comments. It doesn't look like goa upstream is planning
> a fix at the moment. The upstream bug was closed as RESOLVED with Matthew's
> evolution patch. I'll keep an eye out for it though. 

I didn't mean the signal emission changes, I rather thought of the reason why GOA crashes for you in general. Once it'll stop crashing you might not need the workaround in eds code.

Comment 11 Ankur Sinha (FranciscoD) 2013-05-02 09:41:50 UTC
Ah, OK. Abrt has been filing bugs against goa for me. One is here: https://bugzilla.redhat.com/show_bug.cgi?id=958336 but it isn't the only one :/


Note You need to log in before you can comment on or make changes to this bug.