Bug 958336 - Crash in xmlOutputBufferClose when called from ews_client_autodiscover_data_free()
Summary: Crash in xmlOutputBufferClose when called from ews_client_autodiscover_data_f...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-online-accounts
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Debarshi Ray
QA Contact: Debarshi Ray
URL:
Whiteboard: abrt_hash:84e3519025eab7ba91f2cc891d3...
: 954046 981193 984856 988388 1016392 1027858 1031257 1046999 1057549 1076510 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-01 01:22 UTC by Ankur Sinha (FranciscoD)
Modified: 2014-09-18 11:41 UTC (History)
11 users (show)

Fixed In Version: gnome-online-accounts-3.10.5-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-03 06:45:44 UTC
Type: ---


Attachments (Terms of Use)
File: cgroup (128 bytes, text/plain)
2013-05-01 01:23 UTC, Ankur Sinha (FranciscoD)
no flags Details
File: core_backtrace (1.25 KB, text/plain)
2013-05-01 01:23 UTC, Ankur Sinha (FranciscoD)
no flags Details
File: dso_list (11.86 KB, text/plain)
2013-05-01 01:23 UTC, Ankur Sinha (FranciscoD)
no flags Details
File: environ (1.00 KB, text/plain)
2013-05-01 01:23 UTC, Ankur Sinha (FranciscoD)
no flags Details
File: limits (1.29 KB, text/plain)
2013-05-01 01:23 UTC, Ankur Sinha (FranciscoD)
no flags Details
File: maps (59.13 KB, text/plain)
2013-05-01 01:23 UTC, Ankur Sinha (FranciscoD)
no flags Details
File: open_fds (1.10 KB, text/plain)
2013-05-01 01:23 UTC, Ankur Sinha (FranciscoD)
no flags Details
File: proc_pid_status (932 bytes, text/plain)
2013-05-01 01:23 UTC, Ankur Sinha (FranciscoD)
no flags Details
File: var_log_messages (3.20 KB, text/plain)
2013-05-01 01:23 UTC, Ankur Sinha (FranciscoD)
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 699553 0 None None None Never

Description Ankur Sinha (FranciscoD) 2013-05-01 01:22:57 UTC
Description of problem:
Seems to be related to an exchange account. I added one, and then it crashed. Seems to work okay if I remove this account from goa.

Version-Release number of selected component:
gnome-online-accounts-3.8.1-1.fc19

Additional info:
backtrace_rating: 4
cmdline:        /usr/libexec/goa-daemon
crash_function: xmlOutputBufferClose__internal_alias
executable:     /usr/libexec/goa-daemon
kernel:         3.9.0-301.fc19.x86_64
runlevel:       N 5
uid:            1000
ureports_counter: 1

Truncated backtrace:
Thread no. 1 (2 frames)
 #5 xmlOutputBufferClose__internal_alias at xmlIO.c:2609
 #6 ews_client_autodiscover_data_free at goaewsclient.c:105

Comment 1 Ankur Sinha (FranciscoD) 2013-05-01 01:23:00 UTC
Created attachment 742053 [details]
File: backtrace

Comment 2 Ankur Sinha (FranciscoD) 2013-05-01 01:23:02 UTC
Created attachment 742054 [details]
File: cgroup

Comment 3 Ankur Sinha (FranciscoD) 2013-05-01 01:23:04 UTC
Created attachment 742055 [details]
File: core_backtrace

Comment 4 Ankur Sinha (FranciscoD) 2013-05-01 01:23:07 UTC
Created attachment 742056 [details]
File: dso_list

Comment 5 Ankur Sinha (FranciscoD) 2013-05-01 01:23:12 UTC
Created attachment 742057 [details]
File: environ

Comment 6 Ankur Sinha (FranciscoD) 2013-05-01 01:23:14 UTC
Created attachment 742058 [details]
File: limits

Comment 7 Ankur Sinha (FranciscoD) 2013-05-01 01:23:16 UTC
Created attachment 742059 [details]
File: maps

Comment 8 Ankur Sinha (FranciscoD) 2013-05-01 01:23:19 UTC
Created attachment 742060 [details]
File: open_fds

Comment 9 Ankur Sinha (FranciscoD) 2013-05-01 01:23:21 UTC
Created attachment 742061 [details]
File: proc_pid_status

Comment 10 Ankur Sinha (FranciscoD) 2013-05-01 01:23:23 UTC
Created attachment 742062 [details]
File: var_log_messages

Comment 11 Milan Crha 2013-05-03 06:45:44 UTC
Thanks for a bug report. I moved this upstream as [1]. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

I hope they will notice this better than when it's hidden here in downstream bugzilla.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=699553

Comment 12 Ankur Sinha (FranciscoD) 2013-05-03 07:02:23 UTC
Thanks Milan, CC'd myself to upstream bug.

Comment 13 Debarshi Ray 2013-06-10 16:50:51 UTC
*** Bug 954046 has been marked as a duplicate of this bug. ***

Comment 14 Debarshi Ray 2014-06-02 12:47:52 UTC
*** Bug 988388 has been marked as a duplicate of this bug. ***

Comment 15 Debarshi Ray 2014-06-02 12:48:16 UTC
*** Bug 1076510 has been marked as a duplicate of this bug. ***

Comment 16 Debarshi Ray 2014-06-02 12:48:36 UTC
*** Bug 1057549 has been marked as a duplicate of this bug. ***

Comment 17 Debarshi Ray 2014-06-02 12:48:38 UTC
*** Bug 1027858 has been marked as a duplicate of this bug. ***

Comment 18 Debarshi Ray 2014-06-02 12:48:56 UTC
*** Bug 984856 has been marked as a duplicate of this bug. ***

Comment 19 Debarshi Ray 2014-06-02 12:50:43 UTC
*** Bug 1046999 has been marked as a duplicate of this bug. ***

Comment 20 Debarshi Ray 2014-06-02 13:37:43 UTC
Can you please test the patch attached to https://bugzilla.gnome.org/show_bug.cgi?id=699553 ?

Comment 21 Mikhail 2014-06-02 14:36:54 UTC
(In reply to Debarshi Ray from comment #20)
> Can you please test the patch attached to
> https://bugzilla.gnome.org/show_bug.cgi?id=699553 ?

I afraid no one has no idea how to reproduce it.

Comment 22 Debarshi Ray 2014-06-03 10:08:03 UTC
(In reply to Mikhail from comment #21)
> (In reply to Debarshi Ray from comment #20)
> > Can you please test the patch attached to
> > https://bugzilla.gnome.org/show_bug.cgi?id=699553 ?
> 
> I afraid no one has no idea how to reproduce it.

It is explained on the upstream bug. I think you are using Exchange, so if you add your account and use Evolution for a few days and things don't crash like this, then it should be OK.

Comment 23 Fedora Update System 2014-06-09 15:10:57 UTC
gnome-online-accounts-3.10.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gnome-online-accounts-3.10.5-1.fc20

Comment 24 Fedora Update System 2014-06-19 22:54:45 UTC
gnome-online-accounts-3.10.5-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 25 Debarshi Ray 2014-09-18 11:34:17 UTC
*** Bug 1031257 has been marked as a duplicate of this bug. ***

Comment 26 Debarshi Ray 2014-09-18 11:38:26 UTC
*** Bug 981193 has been marked as a duplicate of this bug. ***

Comment 27 Debarshi Ray 2014-09-18 11:41:59 UTC
*** Bug 1016392 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.