Bug 957252 - [abrt] pragha-1.1.1-3.fc19: add_folder_file: Process /usr/bin/pragha was killed by signal 6 (SIGABRT)
Summary: [abrt] pragha-1.1.1-3.fc19: add_folder_file: Process /usr/bin/pragha was kill...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pragha
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:fe61103cb69f8140cea22276491...
: 869394 951824 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-26 18:36 UTC by Michael Schwendt
Modified: 2013-10-09 14:44 UTC (History)
3 users (show)

Fixed In Version: pragha-1.1.2.1-2.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-10-08 11:27:17 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (20.59 KB, text/plain)
2013-04-26 18:36 UTC, Michael Schwendt
no flags Details
File: cgroup (128 bytes, text/plain)
2013-04-26 18:36 UTC, Michael Schwendt
no flags Details
File: core_backtrace (944 bytes, text/plain)
2013-04-26 18:36 UTC, Michael Schwendt
no flags Details
File: dso_list (13.99 KB, text/plain)
2013-04-26 18:36 UTC, Michael Schwendt
no flags Details
File: environ (1.64 KB, text/plain)
2013-04-26 18:36 UTC, Michael Schwendt
no flags Details
File: limits (1.29 KB, text/plain)
2013-04-26 18:36 UTC, Michael Schwendt
no flags Details
File: maps (69.30 KB, text/plain)
2013-04-26 18:36 UTC, Michael Schwendt
no flags Details
File: open_fds (574 bytes, text/plain)
2013-04-26 18:36 UTC, Michael Schwendt
no flags Details
File: proc_pid_status (927 bytes, text/plain)
2013-04-26 18:36 UTC, Michael Schwendt
no flags Details
File: var_log_messages (227 bytes, text/plain)
2013-04-26 18:36 UTC, Michael Schwendt
no flags Details

Description Michael Schwendt 2013-04-26 18:36:18 UTC
Description of problem:
Have had a first look at "pragha", but it no longer manages to start:

$ pragha 
**
pragha:ERROR:librarytree.c:126:add_folder_file: assertion failed: (prefix != NULL)
Aborted (core dumped)

Version-Release number of selected component:
pragha-1.1.1-3.fc19

Additional info:
backtrace_rating: 4
cmdline:        pragha
crash_function: add_folder_file
executable:     /usr/bin/pragha
kernel:         3.9.0-0.rc8.git0.2.fc19.x86_64
runlevel:       N 5
uid:            1000
ureports_counter: 1

Truncated backtrace:
Thread no. 1 (4 frames)
 #4 add_folder_file at librarytree.c:126
 #5 init_library_view at librarytree.c:1825
 #6 _init_gui_state at init.c:98
 #7 gtk_main at gtkmain.c:1249

Potential duplicate: bug 869394

Comment 1 Michael Schwendt 2013-04-26 18:36:20 UTC
Created attachment 740566 [details]
File: backtrace

Comment 2 Michael Schwendt 2013-04-26 18:36:26 UTC
Created attachment 740568 [details]
File: cgroup

Comment 3 Michael Schwendt 2013-04-26 18:36:28 UTC
Created attachment 740569 [details]
File: core_backtrace

Comment 4 Michael Schwendt 2013-04-26 18:36:31 UTC
Created attachment 740570 [details]
File: dso_list

Comment 5 Michael Schwendt 2013-04-26 18:36:33 UTC
Created attachment 740571 [details]
File: environ

Comment 6 Michael Schwendt 2013-04-26 18:36:35 UTC
Created attachment 740572 [details]
File: limits

Comment 7 Michael Schwendt 2013-04-26 18:36:37 UTC
Created attachment 740573 [details]
File: maps

Comment 8 Michael Schwendt 2013-04-26 18:36:40 UTC
Created attachment 740574 [details]
File: open_fds

Comment 9 Michael Schwendt 2013-04-26 18:36:42 UTC
Created attachment 740575 [details]
File: proc_pid_status

Comment 10 Michael Schwendt 2013-04-26 18:36:44 UTC
Created attachment 740576 [details]
File: var_log_messages

Comment 11 Michael Schwendt 2013-04-27 10:53:40 UTC
Work-around: Remove ~/.config/pragha/pragha.db (SQLite file, size 30 KiB).

~/.config/pragha/config file is 0 bytes long, but not the culprit.

Comment 12 Christoph Wickert 2013-05-18 17:20:18 UTC
*** Bug 951824 has been marked as a duplicate of this bug. ***

Comment 13 Christoph Wickert 2013-05-18 17:20:25 UTC
*** Bug 869394 has been marked as a duplicate of this bug. ***

Comment 14 qub.box 2013-09-16 14:16:17 UTC
I opened the music player and then he fell

reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        /usr/bin/pragha
crash_function: add_folder_file
executable:     /usr/bin/pragha
kernel:         3.10.11-200.fc19.x86_64
package:        pragha-1.1.1-3.fc19
reason:         Process /usr/bin/pragha was killed by signal 6 (SIGABRT)
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 15 Fedora Update System 2013-09-27 18:40:57 UTC
pragha-1.1.2.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/pragha-1.1.2.1-1.fc20

Comment 16 Fedora Update System 2013-09-27 18:41:25 UTC
pragha-1.1.2.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/pragha-1.1.2.1-1.fc19

Comment 17 Fedora Update System 2013-09-27 18:43:37 UTC
pragha-1.1.2.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/pragha-1.1.2.1-1.fc18

Comment 18 Fedora Update System 2013-09-29 01:33:04 UTC
Package pragha-1.1.2.1-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pragha-1.1.2.1-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17894/pragha-1.1.2.1-1.fc18
then log in and leave karma (feedback).

Comment 19 Fedora Update System 2013-10-08 11:27:17 UTC
pragha-1.1.2.1-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2013-10-08 11:35:13 UTC
pragha-1.1.2.1-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2013-10-09 14:44:23 UTC
pragha-1.1.2.1-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.