Bug 957364 - fedup-cli fails on "getting boot images"
fedup-cli fails on "getting boot images"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
: 980818 981423 986718 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-27 13:18 EDT by Alen Siljak
Modified: 2013-12-24 16:38 EST (History)
9 users (show)

See Also:
Fixed In Version: fedup-0.8.0-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 02:21:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fedup_f18.log.badrepo (58.34 KB, text/plain)
2013-12-15 07:35 EST, Petr Spacek
no flags Details

  None (edit)
Description Alen Siljak 2013-04-27 13:18:09 EDT
Description of problem:
Running "sudo fedup-cli --network 19", from a working Fedora 18 x64 system.
After downloading all the packages, fedup fails with the error message below.


Version-Release number of selected component (if applicable):
18

How reproducible:
Run "sudo fedup-cli --network 19" from a working Fedora 18 system.

Steps to Reproduce:
1. Run "sudo fedup-cli --network 19" from a working Fedora 18 system.
2.
3.
  
Actual results:

getting boot images...
Traceback (most recent call last):
  File "/bin/fedup-cli", line 285, in <module>
    main(args)
  File "/bin/fedup-cli", line 236, in main
    raise NotImplementedError("use --instrepo or --skipkernel")
NotImplementedError: use --instrepo or --skipkernel


Expected results:
System upgrade from v18 to v19.

Additional info:
Comment 1 Michal Kovarik 2013-05-29 08:26:27 EDT
I've tried this with fedup-0.7.3-4.fc18.noarch and no traceback appeared. Just error message.
This is caused by upgrading to unreleased version of fedora. Boot images will be available after final release. For now you can use --instrepo 
According to fedup manual: 
       --instrepo REPOID
           Get upgrader boot images from the repo named REPOID. The repo must
           contain a valid .treeinfo file which points to the location of
           usable kernel and upgrade images.

           By default, fedup will ask https://mirrors.fedoraproject.org/ for
           the installable tree for the given --networkVERSION. The actual
           filename requested is:

           /metalink?repo=fedora-install-$releasever&arch=$basearch

           where $basearch is the system’s arch (i386, x86_64, etc.) and
           $releasever is the VERSION given with the --network option.

               Note
               You should only need to use this option if you’re testing fedup
               before the release is public.

Newest instrepo is available here - http://alt.fedoraproject.org/pub/fedora/linux/development/19/x86_64/os/
Comment 2 Alen Siljak 2013-05-29 08:37:01 EDT
Great, thanks for confirming the URL for the pre-release repo! I've written a short post about upgrade to v19 here: http://alensiljak.blogspot.co.at/2013/04/upgrading-fedora-18-19-with-fedup.html
Comment 3 Will Woods 2013-10-09 15:58:04 EDT
*** Bug 980818 has been marked as a duplicate of this bug. ***
Comment 4 Will Woods 2013-10-09 15:58:10 EDT
*** Bug 981423 has been marked as a duplicate of this bug. ***
Comment 5 Will Woods 2013-10-09 16:26:38 EDT
This will also happen if you run fedup before the new release has made it to your local mirror(s). The error looks like this:

  Downloading failed: couldn't get boot images:
  curl#22 - "The requested URL returned error: 404 Not Found"

Or:

  Error: can't get boot images.
  The installation repo isn't available.
  You need to specify one with --instrepo.

The solution is, basically, to wait and try again.

The error message could probably be clarified, e.g.:
  
  Error: can't get boot images.
  The requested release might not be available yet. Try again later.

As mentioned in the man page, --instrepo should only be needed by people testing fedup before the release is public, so we probably don't need to suggest it here.
Comment 6 bob mckay 2013-10-09 20:36:21 EDT
Re comment 5, a note of clarification about bug 980818,  just in case marking it as a dupe leads to an important difference being missed. While it's describing the same problem, it's with the production repo, so it does need the clarified message.
Comment 7 Will Woods 2013-10-10 14:59:55 EDT
Yes, both cases need the clarified message.

You could make the argument that --instrepo should have a different error message, like:

  Error: can't get boot images.
  Please check the --instrepo URL to make sure .treeinfo or .treeinfo.signed
  exists, contains the proper boot images, and that the boot images are readable.

but since --instrepo is for Testers Only, we can assume that anyone who uses it is an expert, and they should know that "Error: can't get boot images." means ".treeinfo or vmlinuz or upgrade.img is missing or unreadable". So I'm not going to bother adding extra code for that.
Comment 8 Will Woods 2013-10-10 15:50:49 EDT
*** Bug 986718 has been marked as a duplicate of this bug. ***
Comment 9 Will Woods 2013-12-06 16:58:15 EST
This commit should clarify the error message:

  https://github.com/wgwoods/fedup/commit/f9e5de6c

It'll be in fedup-0.8.0.
Comment 10 Fedora Update System 2013-12-11 17:11:50 EST
fedup-0.8.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc19
Comment 11 Fedora Update System 2013-12-11 17:20:07 EST
fedup-0.8.0-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc20
Comment 12 Fedora Update System 2013-12-11 17:21:59 EST
fedup-0.8.0-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc18
Comment 13 Fedora Update System 2013-12-13 00:09:13 EST
Package fedup-0.8.0-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedup-0.8.0-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23316/fedup-0.8.0-3.fc19
then log in and leave karma (feedback).
Comment 14 Petr Spacek 2013-12-15 07:34:21 EST
fedup-0.8.0-3.fc18.noarch failed to upgrade my Fedora 18 machine to Fedora 19.

I used this command: fedup -v --debuglog /root/fedup_f18.log --reboot --network 19

Repo files are the default ones from installation:

fedora.repo:
[fedora]
mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=$basearch

I'm attaching the log file fedup_f18.log.badrepo.

Workaround was to add inst repo parameter:
--instrepo=ftp://ftp.linux.cz/pub/linux/fedora/linux/releases/1
9/Fedora/i386/os/

Note that Fedora 19 was released months ago so it doesn't seem like mirror inconsistency.
Comment 15 Petr Spacek 2013-12-15 07:35:18 EST
Created attachment 836927 [details]
fedup_f18.log.badrepo
Comment 16 Will Woods 2013-12-16 09:28:44 EST
Different problem. See bug 1040689.
Comment 17 Fedora Update System 2013-12-19 02:21:37 EST
fedup-0.8.0-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2013-12-19 20:44:11 EST
fedup-0.8.0-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2013-12-22 00:34:18 EST
fedup-0.8.0-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Richard 2013-12-22 12:00:10 EST
I've just tried to upgrade FC18 to FC19 or FC20 and I get the error about no more mirrors with fedup-0.8.0-3.fc18.noarch
Comment 21 Richard 2013-12-23 14:05:44 EST
To get up upgrade to work using fedup, I had to run this command:

$ fedup --network 19 --instrepo=http://fedora.mirror.nexicom.net/linux/releases/19/Fedora/x86_64/os

Once I did that, the upgrade worked well.

Rich

Note You need to log in before you can comment on or make changes to this bug.