Bug 986718 - fedup fails to update f18 to f19
fedup fails to update f18 to f19
Status: CLOSED DUPLICATE of bug 957364
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
18
i386 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-21 17:16 EDT by Sam Grinstead
Modified: 2013-10-10 15:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-10 15:50:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Grinstead 2013-07-21 17:16:45 EDT
Description of problem:
Running fedup on my system, fedup exits without doing anything.

Version-Release number of selected component (if applicable):
fedup 0.7.3-4.fc18.noarch

How reproducible:
Run fedup on my Fedora 18 system?

Steps to Reproduce:
1. fedup-cli --network 19 --debuglog /root/fedupwithfedup.log
2. Cleared yum and fedup data with "clean," still failed
3. System is not behind a proxy
4. Seems to fail to find metadata for the defaultinstall repo?
5. If I can provide any other info that would be helpful, I will try to do so.

Actual results:   
Error: can't get boot images.
The installation repo isn't available.
You need to specify one with --instrepo.


Expected results:
Upgraded system

Additional info:
[     0.258] (II) fedup:<module>() /usr/bin/fedup-cli starting at Sun Jul 21 17:14:08 2013
[     0.311] (DD) fedup:setup_downloader() setup_downloader(version=19, repos=[])
[     0.311] (II) fedup.yum:__init__() FedupDownloader(version=19, cachedir=/var/tmp/fedora-upgrade)
[     0.312] (DD) fedup.yum:__init__() prerepoconf.cache=0
[     0.312] (II) fedup.yum:setup_repos() checking repos
[     0.397] (DD) fedup.yum:_getConfig() conf.cache=0
[     0.544] (II) fedup.yum:setup_repos() repo adobe-linux-i386 seems OK
[     1.444] (II) fedup.yum:setup_repos() can't find valid repo metadata for default-installrepo
[     1.461] (II) fedup.yum:setup_repos() repo fedora seems OK
[     1.467] (II) fedup.yum:setup_repos() repo google-earth seems OK
[     1.472] (II) fedup.yum:setup_repos() repo google-talkplugin seems OK
[     1.482] (II) fedup.yum:setup_repos() repo rpmfusion-free seems OK
[     1.490] (II) fedup.yum:setup_repos() repo rpmfusion-free-updates seems OK
[     1.500] (II) fedup.yum:setup_repos() repo rpmfusion-nonfree seems OK
[     1.516] (II) fedup.yum:setup_repos() repo rpmfusion-nonfree-updates seems OK
[     1.521] (II) fedup.yum:setup_repos() repo updates seems OK
[     1.522] (DD) fedup.yum:setup_repos() repos.cache=0
[     1.523] (II) fedup:<module>() /usr/bin/fedup-cli exiting at Sun Jul 21 17:14:10 2013
~
Comment 1 Sam Grinstead 2013-07-21 17:21:42 EDT
This identical error occurs on my laptop and media server.
Comment 2 Will Woods 2013-10-09 15:19:47 EDT
This looks like a (transient) mirror problem. Did you ever get the upgrade to work?
Comment 3 Will Woods 2013-10-09 16:41:25 EDT
If you're still having this problem, let me know, otherwise I'll close this as a duplicate of 957364.
Comment 4 Sam Grinstead 2013-10-09 23:58:37 EDT
I never got it to work, I ended up doing a fresh install on both systems.  You can close this bug as a duplicate if you like.
Comment 5 Will Woods 2013-10-10 15:50:49 EDT

*** This bug has been marked as a duplicate of bug 957364 ***

Note You need to log in before you can comment on or make changes to this bug.