Bug 957505 - QEMU assertion when windows guest returns from hibernation
Summary: QEMU assertion when windows guest returns from hibernation
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win
Version: 6.5
Hardware: Unspecified
OS: Windows
unspecified
medium
Target Milestone: rc
: ---
Assignee: Dmitry Fleytman
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 920928 959154 960503
TreeView+ depends on / blocked
 
Reported: 2013-04-28 15:16 UTC by Dmitry Fleytman
Modified: 2013-12-06 07:49 UTC (History)
9 users (show)

(edit)
Cause: 
Setting virtio features to 0 before hibernation

Consequence: 
QEMU assertion

Fix: 
Do not set feature bits to 0.

Result: 
Guest can hibernate without a problem.
Clone Of:
(edit)
Last Closed: 2013-11-22 00:11:40 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1729 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2013-11-21 00:39:25 UTC

Description Dmitry Fleytman 2013-04-28 15:16:16 UTC
Description of problem:

QEMU asserts when guest returns from hibernation

Version-Release number of selected component (if applicable):

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 2 Mike Cao 2013-05-02 08:03:46 UTC
Could anyone provide QE the steps to reproduce this bug ?

Comment 3 Dmitry Fleytman 2013-05-02 08:43:28 UTC
Hello Mike,

Basically what you need is to make VM hibernate and re-run the qemu.
However this bug is a race condition by nature so it does not show up on every hibernation cycle, we saw it almost every time on MPE test while working on BZ#920928.

Dmitry

Comment 4 Mike Cao 2013-05-02 08:53:26 UTC
(In reply to comment #3)
> Hello Mike,
> 
> Basically what you need is to make VM hibernate and re-run the qemu.
> However this bug is a race condition by nature so it does not show up on
> every hibernation cycle, we saw it almost every time on MPE test while
> working on BZ#920928.
> 
> Dmitry

Got it ,QE will run 1000 times s4 cycle to reproduce it ,

Comment 5 Dmitry Fleytman 2013-05-13 07:58:54 UTC
Another incarnation if this bug is device queues stuck after NDIS reset callback invocation. This explains failures of other HCK tests like MPE, RESET and MINI6SEND.

Comment 6 Mike Cao 2013-05-30 03:23:06 UTC
dengmin ,pls verify it according to comment #3

Comment 7 Min Deng 2013-06-07 03:45:30 UTC
Hi all,
   Re-test the bug via build 63 and MPE job has passed.
   According to comments 3,the bug has been fixed
Best regards,
Min

Comment 9 Mike Cao 2013-06-17 06:54:13 UTC
Based on comment #7 ,Move Status to VERIFIED

Comment 14 errata-xmlrpc 2013-11-22 00:11:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1729.html


Note You need to log in before you can comment on or make changes to this bug.