Bug 960503 - [virtio-win][netkvm] The connection status of Red Hat VirtIO Ethernet Adapter is always "Identifying..." after doing S3 or S4
Summary: [virtio-win][netkvm] The connection status of Red Hat VirtIO Ethernet Adapter...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win
Version: 6.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 957505
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-07 09:45 UTC by guo jiang
Modified: 2013-11-22 00:05 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Setting virtio features to 0 before hibernation Consequence: No network on the guest. Fix: Do not set feature bits to 0. Result: Guest can hibernate without a problem.
Clone Of:
Environment:
Last Closed: 2013-11-22 00:05:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1729 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2013-11-21 00:39:25 UTC

Description guo jiang 2013-05-07 09:45:16 UTC
Description of problem:

The status of Red Hat VirtIO Ethernet Adapter is always "Identifying..." and we can't ping between guest and external host any more, after S4(Hibernate).

Version-Release number of selected component (if applicable):
virtio-win-prewhql-0.1-59

How reproducible:
3 times

Steps to Reproduce:
1.start guest win2k8-R2/virtio-net-pci
   /usr/libexec/qemu-kvm -M rhel6.4.0 -m 4G -smp 4 -cpu cpu64-rhel6,+x2apic,+sep,family=0xf -usb -device usb-tablet -drive file=win2k8-R2.qcow2,format=qcow2,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:21:21:24:34:10,bus=pci.0,addr=0x4,id=virtio-net-pci0 -uuid e9b5ca3a-1419-4514-bb76-8fe8250884e1 -rtc-td-hack -no-kvm-pit-reinjection -rtc base=localtime,clock=host,driftfix=slew -chardev socket,id=111a,path=/tmp/monitor-win2k8-R2-network,server,nowait -mon chardev=111a,mode=readline -name win2k8-R2-network -spice port=5931,disable-ticketing -vga qxl -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio

2.Ping between guest and external host 
  from external host to guest: ping -c 10 $guest_ip
  from guest to external host: ping -n 10 $external-host_ip

3.Hibernate (S4) 
  "ctrl+alt+del"--"Hibernate"

4.After qemu quit, reboot guest with the step1's script again.

5.After wake from S4,login to guest

6.Check netkvm driver by opening "Device Manager" and clicking "Network adapters"--->right-clicking "Properties" of "Red Hat VirtIO Ethernet Adapter"

7.Check the network connection status of "Red Hat VirtIO Ethernet Adapter" by opening "Control Panel" and clicking "View network status and tasks"--->clicking "Change adapter settings"

8.Repeat the step 2.
   
Actual results:
 
  After S4(Hibernate), the network connection status of "Red Hat VirtIO Ethernet Adapter" is always holding "identifying..." and we can't ping between guest and external host any more.

Expected results:
   After S4(Hibernate), the network connection status of "Red Hat VirtIO Ethernet Adapter" should be "enable" and ping between guest and external host is ok.

Additional info:
1.opening "Control Panel" and clicking "View network status and tasks"--->clicking "Change adapter settings"--->right clicking "Ted Hat VirtIO Ethernet Adapter"
   --->clicking "Diagnose", the windows network diagnostics report: Troubleshooting couldn't Diagnostics.
   --->clicking "Disable",there is not any effect after this.
2.If we restart the guest again, the status is what we expected.
3.Reboot don't have this problem.

Comment 2 guo jiang 2013-05-08 01:31:18 UTC
There is the same problem after doing S3(sleep)

Comment 5 guo jiang 2013-05-08 08:27:05 UTC
Packages:

    * Red Hat Enterprise Linux Server release 6.4 (Santiago)
    * kernel-2.6.32-369.el6.x86_64
    * qemu-kvm-rhev-0.12.1.2-2.359.el6.x86_64
    * virtio-win-prewhql-0.1-59
    * spice-server-0.12.0-12.el6.x86_64
    * seabios-0.6.1.2-27.el6.x86_64
    * vgabios-0.6b-3.7.el6.noarch

Comment 6 Dmitry Fleytman 2013-05-13 08:29:17 UTC
Fixed by BZ#957505.
Please verify.

Comment 10 guo jiang 2013-05-30 08:34:04 UTC
QE test the bug via build 63

Version-Release number of selected component (if applicable):
    * kernel-2.6.32-369.el6.x86_64    
    * qemu-img-rhev-0.12.1.2-2.359.el6.x86_64
    * virtio-win-prewhql-0.1-63
    * spice-server-0.12.0-12.el6.x86_64
    * seabios-0.6.1.2-27.el6.x86_64
    * vgabios-0.6b-3.7.el6.noarch

How reproducible:
3 times

Steps to Reproduce:
1.start guest win2k8-R2/virtio-net-pci
   /usr/libexec/qemu-kvm -M rhel6.4.0 -m 6G -smp 8,cores=8 -cpu cpu64-rhel6,+x2apic,+sep,family=0xf -usb -device usb-tablet -drive file=win2k8-R2.qcow2,format=qcow2,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:13:23:43:22:41,bus=pci.0,addr=0x4,id=virtio-net-pci0 -uuid 744e5d6b-8a99-4754-a27a-ae7f3b73844a -rtc-td-hack -no-kvm-pit-reinjection -rtc base=localtime,clock=host,driftfix=slew -chardev socket,id=111a,path=/tmp/monitor-win2k8-R2-network,server,nowait -mon chardev=111a,mode=readline -name win2k8-R2-network -spice port=5931,disable-ticketing -vga qxl -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio


2.Ping between guest and external host 
  from external host to guest: ping -c 10 $guest_ip
  from guest to external host: ping -n 10 $external-host_ip

3.Hibernate (S4) 
  "ctrl+alt+del"--"Hibernate"

4.After qemu quit, reboot guest with the step1's script again.

5.After wake from S4,login to guest

6.Repeat the step 2.
   
Actual results:
 
  step2 and step6: ping normally.

Expected results:
   
 step2 and step6: ping normally.

so the issues has been fixed on build 63, thanks!

Comment 11 Mike Cao 2013-06-04 02:16:31 UTC
Move status to VERIFIED according to comment #10

Comment 15 errata-xmlrpc 2013-11-22 00:05:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1729.html


Note You need to log in before you can comment on or make changes to this bug.