Bug 957819 - Fedora 18 64bit live install anaconda installer fails on first screen (language and keyboard selection)
Fedora 18 64bit live install anaconda installer fails on first screen (langua...
Status: CLOSED DUPLICATE of bug 893892
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-29 11:30 EDT by Valent Turkovic
Modified: 2013-07-01 11:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 980178 (view as bug list)
Environment:
Last Closed: 2013-05-13 10:42:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda log (322.36 KB, text/plain)
2013-04-30 04:05 EDT, Valent Turkovic
no flags Details

  None (edit)
Description Valent Turkovic 2013-04-29 11:30:09 EDT
Description of problem:
Fedora 18 64bit live install anaconda installer fails on first screen (language and keyboard selection).

When I start Fedora 18 64bit installed I can't get from first screen, I can scroll all language choices but no matter which one I choose and click on "Continue" button nothing happens.

Logs will be attached.

This is a critical bug because stops installations from Live media...

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Click in Fedora installer
2. Try to click continue
3. Nothing happens
  
Actual results:


Expected results:


Additional info:
[root@localhost ~]# liveinst 
umount: /isodevice: not found
localuser:root being added to access control list
Starting installer, one moment...
anaconda 18.37.11 for Fedora 18 started.
Exception in thread AnaNetworkThread:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/threading.py", line 551, in __bootstrap_inner
    self.run()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 95, in run
    sys.excepthook(*sys.exc_info())
  File "/usr/lib/python2.7/site-packages/meh/handler.py", line 162, in <lambda>
    sys.excepthook = lambda ty, value, tb: self.handleException((ty, value, tb), obj)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/exception.py", line 82, in handleException
    (ty, value, tb), obj)
  File "/usr/lib/python2.7/site-packages/meh/handler.py", line 108, in handleException
    win = self.intf.mainExceptionWindow(str(self.exn), self.exnText)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 188, in mainExceptionWindow
    lightbox = AnacondaWidgets.lb_show_over(self._currentAction.window)
AttributeError: 'NoneType' object has no attribute 'window'


(anaconda:2966): Gtk-CRITICAL **: gtk_tree_model_filter_get_path: assertion `GTK_TREE_MODEL_FILTER (model)->priv->stamp == iter->stamp' failed

(anaconda:2966): Gtk-WARNING **: Overriding tab label for notebook
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 77, in <lambda>
    self.window.connect("continue-clicked", lambda *args: self._on_continue_clicked(cb))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 287, in _on_continue_clicked
    StandaloneSpoke._on_continue_clicked(self, cb)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 73, in _on_continue_clicked
    cb()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 234, in _on_continue_clicked
    nextAction = self._instantiateAction(self._actions[1])
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 77, in _instantiateAction
    obj = actionClass(self.data, self.storage, self.payload, self.instclass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 1091, in __init__
    self.network_control_box.hostname = self.data.network.hostname
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 960, in hostname
    self.entry_hostname.set_text(value)
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 47, in function
    return info.invoke(*args, **kwargs)
TypeError: Argument 1 does not allow None as a value





(anaconda:2966): Gtk-WARNING **: Overriding tab label for notebook
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 77, in <lambda>
    self.window.connect("continue-clicked", lambda *args: self._on_continue_clicked(cb))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 287, in _on_continue_clicked
    StandaloneSpoke._on_continue_clicked(self, cb)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 73, in _on_continue_clicked
    cb()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 234, in _on_continue_clicked
    nextAction = self._instantiateAction(self._actions[1])
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 77, in _instantiateAction
    obj = actionClass(self.data, self.storage, self.payload, self.instclass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 1091, in __init__
    self.network_control_box.hostname = self.data.network.hostname
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 960, in hostname
    self.entry_hostname.set_text(value)
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 47, in function
    return info.invoke(*args, **kwargs)
TypeError: Argument 1 does not allow None as a value
Comment 1 Chris Lumens 2013-04-29 16:04:33 EDT
Please attach the complete /tmp/anaconda-tb-* file to this bug report.
Comment 2 Valent Turkovic 2013-04-30 04:05:00 EDT
Created attachment 741787 [details]
Anaconda log

Anaconda log
Comment 3 Radek Vykydal 2013-05-13 10:42:45 EDT
This is most probably a duplicate of bug 893892. You can try if the soulution described in

https://fedoraproject.org/wiki/Common_F18_bugs#livecd-with-wwan-card

or F19 Alpha works for you.

*** This bug has been marked as a duplicate of bug 893892 ***
Comment 4 Rob 2013-07-01 11:11:38 EDT
I am having this bug exactly. I have no WWAN hardware, and the solution given in the Common F18 Bugs does not work for me.

Note You need to log in before you can comment on or make changes to this bug.