Bug 957867 - Unable to import dbus.mainloop.qt: ImportError: No module named _dbus_qt.qt
Unable to import dbus.mainloop.qt: ImportError: No module named _dbus_qt.qt
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: PyQt4 (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
abrt_hash:b092d59514844b823570149dedd...
:
: 959698 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-29 14:32 EDT by Raphos
Modified: 2013-05-21 23:20 EDT (History)
6 users (show)

See Also:
Fixed In Version: PyQt4-4.10.1-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-21 23:20:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.77 KB, text/plain)
2013-04-29 14:32 EDT, Raphos
no flags Details
File: core_backtrace (950 bytes, text/plain)
2013-04-29 14:32 EDT, Raphos
no flags Details
File: environ (263 bytes, text/plain)
2013-04-29 14:32 EDT, Raphos
no flags Details

  None (edit)
Description Raphos 2013-04-29 14:32:19 EDT
Description of problem:
Launch live - usb creator. Application doesn't start just crash.

Version-Release number of selected component:
liveusb-creator-3.11.8-1.fc18

Additional info:
cmdline:        /usr/bin/python -tt /usr/sbin/liveusb-creator
dso_list:       dbus-python-1.1.1-3.fc18.x86_64
executable:     /usr/sbin/liveusb-creator
kernel:         3.8.5-201.fc18.x86_64
runlevel:       N 5
uid:            0
ureports_counter: 1

Truncated backtrace:
connection.py:400:add_signal_receiver:RuntimeError: To make asynchronous calls, receive signals or export objects, D-Bus connections must be attached to a main loop by passing mainloop=... to the constructor or calling dbus.set_default_main_loop(...)

Traceback (most recent call last):
  File "/usr/sbin/liveusb-creator", line 97, in <module>
    main()
  File "/usr/sbin/liveusb-creator", line 88, in main
    LiveUSBApp(opts, sys.argv)
  File "/usr/lib/python2.7/site-packages/liveusb/gui.py", line 60, in __init__
    self.mywindow = LiveUSBDialog(opts, args)
  File "/usr/lib/python2.7/site-packages/liveusb/gui.py", line 288, in __init__
    self.connect_slots()
  File "/usr/lib/python2.7/site-packages/liveusb/gui.py", line 381, in connect_slots
    self.populate_devices)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 544, in connect_to_signal
    dbus_interface, **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 369, in connect_to_signal
    **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/bus.py", line 148, in add_signal_receiver
    path, **keywords)
  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 400, in add_signal_receiver
    self._require_main_loop()
RuntimeError: To make asynchronous calls, receive signals or export objects, D-Bus connections must be attached to a main loop by passing mainloop=... to the constructor or calling dbus.set_default_main_loop(...)

Local variables in innermost frame:
dbus_interface: 'org.freedesktop.UDisks'
signal_name: 'DeviceAdded'
self: <dbus._dbus.SystemBus (system) at 0x1e6fcb0>
handler_function: <bound method LiveUSBDialog.populate_devices of <liveusb.gui.LiveUSBDialog object at 0x1e80b00>>
bus_name: dbus.UTF8String(':1.66')
keywords: {}
path: '/org/freedesktop/UDisks'
Comment 1 Raphos 2013-04-29 14:32:23 EDT
Created attachment 741613 [details]
File: backtrace
Comment 2 Raphos 2013-04-29 14:32:26 EDT
Created attachment 741614 [details]
File: core_backtrace
Comment 3 Raphos 2013-04-29 14:32:28 EDT
Created attachment 741615 [details]
File: environ
Comment 4 Luke Macken 2013-05-03 13:14:13 EDT
This seems to be a regression in PyQt4.


>>> import dbus.mainloop.qt
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/dbus/mainloop/qt.py", line 1, in <module>
    from _dbus_qt.qt import *
ImportError: No module named _dbus_qt.qt


PyQt4-4.10.1-2.fc19.x86_64
dbus-python-1.1.1-5.fc19.x86_64
Comment 5 Rex Dieter 2013-05-03 13:24:44 EDT
toshio and I worked (well, mostly my watching toshio work) on cleaning/fixing some dbus/mainloop packaing issues, but we couldn't find any good consumer or test-cases for the code.

Looks like that problem is solved. :-/
Comment 6 Rex Dieter 2013-05-03 13:26:05 EDT
See bug #957260 for that conversation, fyi
Comment 7 Fedora Update System 2013-05-03 16:14:05 EDT
PyQt4-4.10.1-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-7337/PyQt4-4.10.1-4.fc19
Comment 8 Fedora Update System 2013-05-04 14:53:16 EDT
Package PyQt4-4.10.1-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing PyQt4-4.10.1-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-7337/PyQt4-4.10.1-4.fc19
then log in and leave karma (feedback).
Comment 9 Rex Dieter 2013-05-04 22:43:55 EDT
*** Bug 959698 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2013-05-21 23:20:26 EDT
PyQt4-4.10.1-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.