Bug 957915 - segfault in OsLookupColor
Summary: segfault in OsLookupColor
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 18
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 977104 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-29 22:19 UTC by Zbigniew Jędrzejewski-Szmek
Modified: 2018-06-07 22:50 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-10-01 23:22:03 UTC
Type: Bug


Attachments (Terms of Use)
xorg log from the crashed instance (41.16 KB, text/plain)
2013-04-29 22:19 UTC, Zbigniew Jędrzejewski-Szmek
no flags Details

Description Zbigniew Jędrzejewski-Szmek 2013-04-29 22:19:33 UTC
Created attachment 741697 [details]
xorg log from the crashed instance

Description of problem:
[ 35224.741] (EE) Backtrace:
[ 35224.743] (EE) 0: Xorg (OsLookupColor+0x139) [0x472509]
[ 35224.767] (EE) 1: /lib64/libpthread.so.0 (__restore_rt+0x0) [0x31e900efff]
[ 35224.768] (EE) 2: /lib64/libdrm_nouveau.so.2 (nouveau_pushbuf_data+0x52c) [0x7f092b02764c]
[ 35224.768] (EE) 3: /lib64/libdrm_nouveau.so.2 (nouveau_pushbuf_kick+0x10) [0x7f092b027c60]
[ 35224.858] (EE) 4: /usr/lib64/dri/nouveau_dri.so (_nvfx_fragprog_translate+0xd31) [0x7f09298ee181]
[ 35224.858] (EE) 5: /usr/lib64/dri/nouveau_dri.so (driQueryOptionf+0x109fe4) [0x7f0929821e04]
[ 35224.859] (EE) 6: /usr/lib64/xorg/modules/extensions/libglx.so (_glthread_GetID+0x28bc) [0x7f092b4be83c]
[ 35224.859] (EE) 7: /usr/lib64/xorg/modules/extensions/libglx.so (_glthread_GetID+0x6c83) [0x7f092b4c7013]
[ 35224.860] (EE) 8: Xorg (SendErrorToClient+0x41a) [0x43990a]
[ 35224.860] (EE) 9: Xorg (_init+0x3a7a) [0x42b98a]
[ 35224.916] (EE) 10: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x31e8c21a05]
[ 35224.916] (EE) 11: Xorg (_start+0x29) [0x428621]
[ 35224.916] (EE) 
[ 35224.916] (EE) Segmentation fault at address 0x0


Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.13.3-3.fc18.x86_64

How reproducible:
Happened just once.

Steps to Reproduce:
X was started from a tty session. I was running gnome shell (gnome-shell-3.6.2-3.fc18.x86_64) started from an xterm. Segfault happened when I clicked on a link in firefox to open a tab, but of course this might be unrelated. X closed and I was returned to the console. For some reason the coredump was lost, so it's unlikely that I can provide much more information.

Comment 1 Harald Hoyer 2013-05-27 10:53:41 UTC
Similar to:

(EE) Backtrace:
(EE) 0: X (OsLookupColor+0x139) [0x472509]
(EE) 1: /lib64/libpthread.so.0 (__restore_rt+0x0) [0x3e84c0efff]
(EE) 2: X (xf86PlatformDeviceCheckBusID+0xaf) [0x4b1b0f]
(EE) 3: X (xf86PlatformMatchDriver+0x340) [0x4ad3a0]
(EE) 4: X (xf86CallDriverProbe+0x27) [0x47f6f7]
(EE) 5: X (DoConfigure+0xa70) [0x47f0e0]
(EE) 6: X (InitOutput+0x128c) [0x48e92c]
(EE) 7: X (_init+0x3886) [0x42b796]
(EE) 8: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x3e84021a05]
(EE) 9: X (_start+0x29) [0x428621]

Comment 2 Maksim Burnin 2013-06-07 13:43:46 UTC
Same configuration but i am running ATI Catalyst.
When i try to start Adobe Photoshop via Wine i am getting this:

[274068.428] (EE) 0: /usr/bin/Xorg (OsLookupColor+0x139) [0x472509]
[274068.429] (EE) 1: /lib64/libpthread.so.0 (__restore_rt+0x0) [0x3cc1e0efff]
[274068.430] (EE) 2: /lib64/libc.so.6 (____strtod_l_internal+0x7c) [0x3cc163d3ac]
[274068.431] (EE) 3: /usr/lib64/xorg/modules/extensions/catalyst/libglx.so (GlxInitVisuals2D+0x24602) [0x7f03a39e3d42]
[274068.433] (EE) 4: /usr/lib64/xorg/modules/extensions/catalyst/libglx.so (__glXSetTexBufferInfo+0x22d7) [0x7f03a399c737]
[274068.433] (EE) 5: /usr/bin/Xorg (SendErrorToClient+0x41a) [0x43990a]
[274068.434] (EE) 6: /usr/bin/Xorg (_init+0x3a7a) [0x42b98a]
[274068.435] (EE) 7: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x3cc1621a05]
[274068.435] (EE) 8: /usr/bin/Xorg (_start+0x29) [0x428621]
[274068.435] (EE) 
[274068.435] (EE) Segmentation fault at address 0x0

Installed xorg package:
xorg-x11-server-Xorg.x86_64  1.13.3-3.fc18

Comment 3 Maxim Egorushkin 2013-06-15 15:42:24 UTC
Happens to me as well. I am also using ATI Catalyst driver.

Since an update a few days ago KDE OpenGL compositing started crashing.

[    30.227] (EE) Backtrace:
[    30.228] (EE) 0: /usr/bin/X (OsLookupColor+0x139) [0x472509]
[    30.228] (EE) 1: /lib64/libpthread.so.0 (__restore_rt+0x0) [0x3fd2a0efff]
[    30.228] (EE) 2: /lib64/libc.so.6 (____strtod_l_internal+0x7c) [0x3fd263d3ac]
[    30.229] (EE) 3: /usr/lib64/xorg/modules/extensions/catalyst/libglx.so (GlxInitVisuals2D+0x24602) [0x7f11a70fad42]
[    30.229] (EE) 4: /usr/lib64/xorg/modules/extensions/catalyst/libglx.so (__glXSetTexBufferInfo+0x22d7) [0x7f11a70b3737]
[    30.229] (EE) 5: /usr/bin/X (SendErrorToClient+0x41a) [0x43990a]
[    30.229] (EE) 6: /usr/bin/X (_init+0x3a7a) [0x42b98a]
[    30.230] (EE) 7: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x3fd2621a05]
[    30.230] (EE) 8: /usr/bin/X (_start+0x29) [0x428621]
[    30.230] (EE) 
[    30.230] (EE) Segmentation fault at address 0x0

Installed xorg package:
xorg-x11-server-Xorg-1.13.3-3.fc18.x86_64

Comment 4 Maxim Egorushkin 2013-06-16 19:25:46 UTC
It looks like recently automatically installed xorg-x11-glamor-0.5.0-5.20130401git81aadb8.fc18.x86_64 was causing crashes on my machine. After uninstalling it I experience no crashes.

Comment 5 Maksim Burnin 2013-06-16 20:26:57 UTC
(In reply to Maxim Yegorushkin from comment #4)
> It looks like recently automatically installed
> xorg-x11-glamor-0.5.0-5.20130401git81aadb8.fc18.x86_64 was causing crashes
> on my machine. After uninstalling it I experience no crashes.

Thank you very much. This workaround works for me.

Uninstalled xorg-x11-glamor and xorg-x11-ati by dependency, restarted Xorg and it does not fall anymore

Comment 6 Matthew Woehlke 2013-07-02 18:10:39 UTC
I am experiencing the same bug. It is 100% reproducible by running qtconfig (from a local Qt 4.7.1 build) over X forwarding from a CentOS 5.9 machine using QT_GRAPHICSSYSTEM=opengl1. I'm going to do some quick tests to see if I can narrow that down, but posting first since a successful test will eat my X session.

Comment 7 Matthew Woehlke 2013-07-02 18:49:40 UTC
Also crashes with the default subsystem. Doesn't crash with another F18 machine; not sure yet if it's CentOS or Qt 4.7 that's the problem.

Comment 8 Matthew Woehlke 2013-07-02 20:55:01 UTC
Additional information:

- This is reproducible with an NVidia card.
- Removing xorg-x11-glamor (and downgrading to the previous xorg-x11-ati) did NOT resolve the problem for me.

Comment 9 Shantanu Goel 2013-07-06 13:10:28 UTC
This is happening for me regularly while using the nouveau driver with my Nvidia card as well on Fedora 19.

[  3945.384] (EE) 
[  3945.385] (EE) Backtrace:
[  3945.497] (EE) 0: /usr/bin/Xorg (OsLookupColor+0x129) [0x46e539]
[  3945.501] (EE) 1: /lib64/libpthread.so.0 (__restore_rt+0x0) [0x342600ef9f]
[  3945.514] (EE) 2: /usr/lib64/xorg/modules/drivers/nouveau_drv.so (_init+0x49f
0) [0x7fe9465e0dc0]
[  3945.514] (EE) 3: /usr/bin/Xorg (xorgGetVersion+0x554d) [0x4a35ed]
[  3945.515] (EE) 4: /usr/bin/Xorg (XvdiGetPortAttribute+0x95f) [0x4e570f]
[  3945.515] (EE) 5: /usr/bin/Xorg (SendErrorToClient+0x3f7) [0x436e47]
[  3945.515] (EE) 6: /usr/bin/Xorg (_init+0x3ab2) [0x429ae2]
[  3945.549] (EE) 7: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x3425c21b75]
[  3945.549] (EE) 8: /usr/bin/Xorg (_start+0x29) [0x426741]
[  3945.550] (EE) 9: ? (?+0x29) [0x29]
[  3945.550] (EE) 
[  3945.550] (EE) Segmentation fault at address 0x7fe940293000
[  3945.550] 
Fatal server error:
[  3945.550] Caught signal 11 (Segmentation fault). Server aborting
[  3945.550] 
[  3945.550] (EE)

Comment 10 Kevin Masaryk 2013-07-25 23:43:53 UTC
I'm also experiencing frequent x.org crashes and have been for months. I've tried both the nouveau and nvidia drivers, xfce, gnome and cinnamon and still get crashes. The crashes aren't predictable either other than it always happens when I try to open a new app. It's happened with Thunar, xterm, emacs, shell windows, etc, etc. Seems like anything can trigger it at any time.

[ 91744.986] (EE) 
[ 91744.986] (EE) Backtrace:
[ 91744.990] (EE) 0: /usr/bin/Xorg (OsLookupColor+0x139) [0x472509]
[ 91744.990] (EE) 1: /lib64/libpthread.so.0 (__restore_rt+0x0) [0x3f3100efff]
[ 91744.991] (EE) 2: /usr/bin/Xorg (FontWakeup+0x61) [0x43a0d1]
[ 91744.991] (EE) 3: /usr/bin/Xorg (doListFontsWithInfo+0x72c) [0x43ae8c]
[ 91744.991] (EE) 4: /usr/bin/Xorg (ProcessWorkQueue+0x21) [0x43dec1]
[ 91744.991] (EE) 5: /usr/bin/Xorg (WaitForSomething+0x62) [0x469dd2]
[ 91744.991] (EE) 6: /usr/bin/Xorg (SendErrorToClient+0xe1) [0x4395d1]
[ 91744.991] (EE) 7: /usr/bin/Xorg (_init+0x3a7a) [0x42b98a]
[ 91744.991] (EE) 8: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x3f30821a05]
[ 91744.991] (EE) 9: /usr/bin/Xorg (_start+0x29) [0x428621]
[ 91744.991] (EE) 
[ 91744.991] (EE) Segmentation fault at address 0x14
[ 91744.991] 
Fatal server error:
[ 91744.991] Caught signal 11 (Segmentation fault). Server aborting
[ 91744.991] 
[ 91744.991] (EE)

Comment 11 jamie 2013-08-04 18:01:00 UTC
Had this any-time I tried to run anything that uses Mesa. Workaround in comment #5 fixed the issue for me.

Comment 12 jamie 2013-08-05 02:35:15 UTC
Just a note you might need to re-install the video drivers after applying the fix in comment #5.

Comment 13 Michal Nowak 2013-08-11 16:48:27 UTC
This is the upstream bug: https://bugs.freedesktop.org/show_bug.cgi?id=66515

Comment 14 Andrew Travneff 2013-09-20 13:26:04 UTC
Have same. 100% reproducible with launching "Savage: The Battle For Newerth" game. Disabling glamor (related: [1]) fixes it.

Xorg trace:

(EE) Backtrace:
(EE) 0: /usr/bin/X (OsLookupColor+0x129) [0x46ee59]
(EE) 1: /lib64/libpthread.so.0 (__restore_rt+0x0) [0x3f4140ef9f]
(EE) 2: /usr/lib64/dri/r600_dri.so (driQueryOptionf+0x8f4eb) [0x7f79d7e349cb]
(EE) 3: /usr/lib64/xorg/modules/extensions/libglx.so (_init+0x5e31) [0x7f79d9989051]
(EE) 4: /usr/lib64/xorg/modules/extensions/libglx.so (_glthread_GetID+0x41db) [0x7f79d99b0bcb]
(EE) 5: /usr/lib64/xorg/modules/extensions/libglx.so (_glthread_GetID+0x62f8) [0x7f79d99b4ee8]
(EE) 6: /usr/bin/X (SendErrorToClient+0x3f7) [0x436fe7]
(EE) 7: /usr/bin/X (_init+0x3aaa) [0x429b8a]
(EE) 8: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x3f41021b75]
(EE) 9: /usr/bin/X (_start+0x29) [0x4267f1]
(EE) 10: ? (?+0x29) [0x29]
(EE)
(EE) Segmentation fault at address 0xde5

HW: AMD HD6450
SW: Fedora 19 x64
  xorg-x11-drv-ati-7.1.0-5.20130408git6e74aacc5.fc19.x86_64
  xorg-x11-glamor-0.5.0-5.20130401git81aadb8.fc19.x86_64

1: https://bugzilla.redhat.com/show_bug.cgi?id=1010298

Comment 15 Pasi Karkkainen 2013-09-20 13:35:22 UTC
I'm able to reproduce the Xorg OsLookupColor crash with simply trying to disable a nouveau DVI output with xrandr in Xorg, when Nouveau+intel Optimus is in use on Lenovo T430 laptop running Fedora 19.

When I run "xrandr --output DP-2 --off" I get this Xorg crash:

[   138.763] reporting 5 7 17 134
[   139.048] have a master to look out for
[   139.048] (EE) 
[   139.048] (EE) Backtrace:
[   139.052] (EE) 0: /usr/bin/X (OsLookupColor+0x129) [0x46ee59]
[   139.052] (EE) 1: /lib64/libpthread.so.0 (__restore_rt+0x0) [0x36f2e0ef9f]
[   139.053] (EE) 2: /lib64/libdrm_intel.so.1 (drm_intel_bufmgr_fake_init+0xe3b) [0x7f2bd9ff2f3b]
[   139.054] (EE) 3: /lib64/libdrm_intel.so.1 (drm_intel_bufmgr_fake_init+0x2924) [0x7f2bd9ff6134]
[   139.055] (EE) 4: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x9f22) [0x7f2bda22cf12]
[   139.055] (EE) 5: /usr/lib64/xorg/modules/drivers/intel_drv.so (_init+0x6075) [0x7f2bda225285]
[   139.056] (EE) 6: /usr/bin/X (xf86PruneDuplicateModes+0x1df7) [0x4c84e7]
[   139.056] (EE) 7: /usr/bin/X (RRCrtcSet+0x589) [0x502b39]
[   139.056] (EE) 8: /usr/bin/X (ProcRRSetCrtcConfig+0x3d9) [0x503c99]
[   139.056] (EE) 9: /usr/bin/X (SendErrorToClient+0x3f7) [0x436fe7]
[   139.057] (EE) 10: /usr/bin/X (_init+0x3aaa) [0x429b8a]
[   139.058] (EE) 11: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x36f2621b75]
[   139.058] (EE) 12: /usr/bin/X (_start+0x29) [0x4267f1]
[   139.059] (EE) 13: ? (?+0x29) [0x29]
[   139.059] (EE) 
[   139.059] (EE) Segmentation fault at address 0x8
[   139.059] (EE) 
Fatal server error:
[   139.059] (EE) Caught signal 11 (Segmentation fault). Server aborting
[   139.059] (EE) 
[   139.059] (EE) 
Please consult the Fedora Project support 
         at http://wiki.x.org
 for help. 
[   139.059] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   139.059] (EE) 
[   139.060] (II) AIGLX: Suspending AIGLX clients for VT switch
[   139.543] (EE) Server terminated with error (1). Closing log file.

Comment 16 Garrett Mitchener 2013-09-26 13:36:46 UTC
Possibly related: https://bugs.freedesktop.org/show_bug.cgi?id=64912

Comment 17 Pasi Karkkainen 2013-10-01 16:27:24 UTC
Any updates about this bug? 

The "Possibly related" freedesktop.org bugzilla entry is now fixed, and there's a patch available.. https://bugs.freedesktop.org/show_bug.cgi?id=64912

commit 83f87f3bb8a0c18c3218695b1eb14065a82e8819
Author: Michel Dänzer <michel.daenzer@amd.com>
Date:   Fri Sep 20 10:41:10 2013 +0200

    Reset traps_count and ptrap when necessary for the next trapezoid cliprect

Comment 18 Kevin Masaryk 2013-10-01 16:38:52 UTC
My issue was caused by a RHEL box on our network which was exporting it's X fonts. Whenever I would ssh to that machine, my fontpath would be appended with the exported one and the next time I spawned a window of any kind my desktop would crash.

You can use "xset q" to see your fontpath and "xset fp" to reset it back to your default.

Comment 19 Pasi Karkkainen 2013-10-01 16:41:01 UTC
(In reply to Kevin Masaryk from comment #18)
> My issue was caused by a RHEL box on our network which was exporting it's X
> fonts. Whenever I would ssh to that machine, my fontpath would be appended
> with the exported one and the next time I spawned a window of any kind my
> desktop would crash.
> 
> You can use "xset q" to see your fontpath and "xset fp" to reset it back to
> your default.
>

Ok, so you might be seeing a different issue than me.

For me running "xrandr --output DP-2 --off" crashes Xorg with the "OsLookupColor" stuff in the backtrace.

Comment 20 Hans Ecke 2013-10-01 17:59:18 UTC
For me amarok and google chrome trigger the bug. My home media pc worked fine with a non-updated F19 but is now crippled. Just another anecdote...

Comment 21 Pasi Karkkainen 2013-10-01 19:02:43 UTC
Yep, I'm seeing the Xorg server crashes on Fedora 19 aswell.

Comment 22 Maksim Burnin 2013-10-01 19:14:02 UTC
(In reply to Hans Ecke from comment #20)
> For me amarok and google chrome trigger the bug. My home media pc worked
> fine with a non-updated F19 but is now crippled. Just another anecdote...

You could try to help people investigate the issue by adding your stack trace and vga driver name. 
Your stacktrace may look like the ones posted above ("OsLookupColor" in frame 0), but there is a possibility that there is more than one bug causing "OsLookupColor" issue. 
Stacktraces in comment #2 and comment #3 are identical(see frame 3) and in both cases the problem was solved by workaround in comment #4. However, this workaround does not help to other people, indicating that the issue was caused by different bugs.

Comment 23 Hans Ecke 2013-10-01 21:26:19 UTC
My stacktrace includes the proprietary nvidia module. The reason I'm using that is that for my home media pc, vdpau gives me the best performance in decoding 1080p video (1% CPU load while watching the full resolution Avatar BluRay). I understand most developers will not look at a problem if the stacktrace includes the nvidia module. I can't blame them, but there you go.

So, would you like me to post my stacktrace, even if it includes the nvidia module?

Comment 24 Dave Airlie 2013-10-01 23:22:03 UTC
guys I doubt anyone is seeing the same bug, stop me tooing on this.

OsLookupColor is just a default function the backtracer seems to pick up when it craps itself out.

please refile clean bugs without the me toos if your backtraces are different.

Don't file nvidia backtraces because really we can't do anything about it.

Comment 25 Maxim Egorushkin 2013-10-27 12:17:15 UTC
Removing xorg-x11-glamor still fixes this problem for me on Fedora 19 with: 

kernel-3.11.6-200.fc19.x86_64
xorg-x11-server-Xorg-1.14.3-1.fc19.x86_64
xorg-x11-drv-catalyst-13.9-1.fc19.x86_64
xorg-x11-drv-catalyst-libs-13.9-1.fc19.x86_64
akmod-catalyst-13.9-2.fc19.x86_64

Comment 26 jamie 2018-06-07 22:50:04 UTC
*** Bug 977104 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.