Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 958300 - Keyboard shortcuts doesn't work in Gnome if a non-US keyboard layout is active
Keyboard shortcuts doesn't work in Gnome if a non-US keyboard layout is active
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
: 981570 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-30 16:53 EDT by Hedayat Vatankhah
Modified: 2013-12-09 09:06 EST (History)
9 users (show)

See Also:
Fixed In Version: libreoffice-4.1.3.2-7.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 09:06:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 41169 None None None Never
Launchpad 1246583 None None None Never

  None (edit)
Description Hedayat Vatankhah 2013-04-30 16:53:31 EDT
Description of problem:
In Gnome applications (e.g. gedit), keyboard shortcuts work regardless of the active keyboard layout. Therefore, if I press Ctrl+S (Even if S is not mapped to "S" in the active keybaord layout, for example when Persian layout is active), it saves the current file. However, in libreoffice Ctrl+S doesn't work unless US keyboard layout is active. Therefore, if I want to save a file while I'm writing in Persian, I should change the layout to English and press Ctrl+S, and then switch back to Persian to continue typing. This is both inconvenient and also inconsistent with the normal behavior. I've seen this problem in both F18 and F19 Alpha.
Comment 1 David Tardon 2013-07-10 00:59:54 EDT
*** Bug 981570 has been marked as a duplicate of this bug. ***
Comment 2 Mosaab Alzoubi 2013-11-15 03:39:07 EST
Freedesktop bug #41169 set to (highest critical) 10 days ago.

Not only (non-US_English) but also at all (non-Latin).


== TESTS WE DO ==

This bug found in:
- Fedora 19 Gnome Shell
- Fedora 19 Mate
- Ubuntu 12.04 Unity
- Ubuntu 12.04 Cinnamon
- Ubuntu 13.10

This bug not found in:
- Fedora 19 KDE
- Mint 15 Cinnamon
- Mint 15 XFCE
- Debian 7.1
- Debian - nonstable XFCE
- Ubuntu 10.04 Gnome 2.30
- Arch KDE

Current behavior:
Accelators don't work
Expected behavior:
Accelators works

              
Operating System: Linux (Other)
Version: 4.1.2.3 release
Comment 3 Alexey 2013-11-15 04:23:42 EST
This is not only LibreOffice bug but all java applications. For example, all JetBrains products have the same behaviour. This bug appeared after GNOME ibus integration in 3.6 (https://wiki.gnome.org/ThreePointFive/Features/IBus). So, maybe this is a Java bug (incorrect interaction with IBus? )?
Comment 4 Mosaab Alzoubi 2013-11-15 05:57:08 EST
So relating to our tests, bug found at GNOME related enviroments. KDE not.
Comment 5 Caolan McNamara 2013-11-22 08:15:59 EST
I can reproduce this, and I think I can fix it
Comment 6 Mosaab Alzoubi 2013-11-22 08:28:16 EST
Thank You :) Caolan.
Comment 8 Hedayat Vatankhah 2013-12-09 02:31:20 EST
thanks, it is fixed. This bug can be closed. :)

Note You need to log in before you can comment on or make changes to this bug.