Bug 958427 - 19 Final TC3 x86_64 LXDE Live is oversized (larger than 700 MiB)
Summary: 19 Final TC3 x86_64 LXDE Live is oversized (larger than 700 MiB)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: LiveCD - LXDE
Version: 19
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact:
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F19-accepted, F19FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2013-05-01 12:55 UTC by Andre Robatino
Modified: 2013-06-25 06:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-25 06:43:15 UTC


Attachments (Terms of Use)

Description Andre Robatino 2013-05-01 12:55:12 UTC
Description of problem:

Fedora-Live-LXDE-i686-19-Beta-TC1-1.iso : 740,294,656 bytes (706 MiB)
Fedora-Live-LXDE-x86_64-19-Beta-TC1-1.iso : 775,946,240 bytes (740 MiB)

As indicated at https://fedoraproject.org/wiki/QA:Testcase_Mediakit_ISO_Size and https://fedoraproject.org/wiki/Releases/19/Spins , the size limit is 734,003,200 bytes = 700 MiB.

Version-Release number of selected component (if applicable):
19 Beta TC1

Comment 1 Andre Robatino 2013-05-01 12:58:17 UTC
Automatic Freeze Exception by https://fedoraproject.org/wiki/QA:SOP_freeze_exception_bug_process#Automatic_freeze_exceptions : "Any non-release-blocking Beta or Final TC/RC image exceeding its target size (failures of QA:Testcase_Mediakit_ISO_Size)"

Comment 2 Andre Robatino 2013-05-02 00:58:26 UTC
Still oversized in 19 Beta TC2.

Fedora-Live-LXDE-i686-19-Beta-TC2-1.iso : 741,343,232 bytes (707 MiB)
Fedora-Live-LXDE-x86_64-19-Beta-TC2-1.iso : 774,897,664 bytes (739 MiB)

Comment 3 Andre Robatino 2013-05-04 05:19:54 UTC
Still oversized in 19 Beta TC3.

Fedora-Live-LXDE-i686-19-Beta-TC3-1.iso : 740,294,656 bytes (706 MiB)
Fedora-Live-LXDE-x86_64-19-Beta-TC3-1.iso : 774,897,664 bytes (739 MiB)

Comment 4 Andre Robatino 2013-05-10 18:45:57 UTC
Still oversized in 19 Beta TC4.

Fedora-Live-LXDE-i686-19-Beta-TC4-1.iso : 742,391,808 bytes (708 MiB)
Fedora-Live-LXDE-x86_64-19-Beta-TC4-1.iso : 778,043,392 bytes (742 MiB)

Comment 5 Christoph Wickert 2013-05-13 16:17:46 UTC
LXDE will continue to target 700 MiB. First attempt to slim things down:

https://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?id=d3b94b4 and https://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?h=f19&id=8f64207

Comment 6 Andre Robatino 2013-05-16 05:36:38 UTC
In 19 Beta RC1, 64-bit is oversized, but 32-bit is not.

Fedora-Live-LXDE-i686-19-Beta-1.iso : 709,885,952 bytes (677 MiB)
Fedora-Live-LXDE-x86_64-19-Beta-1.iso : 745,537,536 bytes (711 MiB)

Comment 7 Andre Robatino 2013-05-17 06:51:19 UTC
64-bit is still oversized in 19 Beta RC2.

Fedora-Live-LXDE-i686-19-Beta-1.iso : 709,885,952 bytes (677 MiB)
Fedora-Live-LXDE-x86_64-19-Beta-1.iso : 744,488,960 bytes (710 MiB)

Comment 8 Andre Robatino 2013-05-22 04:50:15 UTC
64-bit is still oversized in 19 Beta RC3.

Fedora-Live-LXDE-i686-19-Beta-1.iso : 711,983,104 bytes (679 MiB)
Fedora-Live-LXDE-x86_64-19-Beta-1.iso : 746,586,112 bytes (712 MiB)

Comment 9 Andre Robatino 2013-05-23 06:10:52 UTC
64-bit is still oversized in 19 Beta RC4.

Fedora-Live-LXDE-i686-19-Beta-1.iso : 710,934,528 bytes (678 MiB)
Fedora-Live-LXDE-x86_64-19-Beta-1.iso : 746,586,112 bytes (712 MiB)

Comment 10 Andre Robatino 2013-06-04 20:08:49 UTC
64-bit is still oversized in 19 Final TC1.

Fedora-Live-LXDE-i686-19-TC1-1.iso : 711,983,104 bytes (679 MiB)
Fedora-Live-LXDE-x86_64-19-TC1-1.iso : 749,731,840 bytes (715 MiB)

Comment 11 Andre Robatino 2013-06-07 17:23:06 UTC
Both 32- and 64-bit are oversized in 19 Final TC2.

Fedora-Live-LXDE-i686-19-TC2-1.iso : 748,683,264 bytes (714 MiB)
Fedora-Live-LXDE-x86_64-19-TC2-1.iso : 781,189,120 bytes (745 MiB)

Comment 12 Christoph Wickert 2013-06-10 00:39:31 UTC
The size increase compared to F18 was caused by mtpaint depending on /usr/bin/kprinter (see bug 964588), which then pulls in kdebase3 and lots of KDE 3 stuff.

I removed mtpaint from the lxde-apps group in comps, see
https://git.fedorahosted.org/cgit/comps.git/commit/?id=df80c4293b
I've explicitly excluded it in the kickstart, too:
https://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?h=f19&id=23c62b5

Comment 13 Andre Robatino 2013-06-13 06:41:31 UTC
64-bit is still oversized in 19 Final TC3.

Fedora-Live-LXDE-i686-19-TC3-1.iso : 706,740,224 bytes (674 MiB)
Fedora-Live-LXDE-x86_64-19-TC3-1.iso : 742,391,808 bytes (708 MiB)

Comment 14 Christoph Wickert 2013-06-13 15:42:07 UTC
Ok, this should hopefully do:
https://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?h=f19&id=62e1df1b6

Comment 15 Andre Robatino 2013-06-18 03:32:06 UTC
Both images are okay in 19 Final TC5. There were no Lives or Spins for TC4.

Fedora-Live-LXDE-i686-19-TC5-1.iso : 689,963,008 bytes (658 MiB)
Fedora-Live-LXDE-x86_64-19-TC5-1.iso : 722,468,864 bytes (689 MiB)

Comment 16 Adam Williamson 2013-06-25 06:43:15 UTC
Also OK in RC1. At this point I think we can consider this fixed.


Note You need to log in before you can comment on or make changes to this bug.