Bug 958953 - erlang-R14B-04.2.el6.ppc64 segfaults on RHEL6.4
Summary: erlang-R14B-04.2.el6.ppc64 segfaults on RHEL6.4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: erlang
Version: el6
Hardware: ppc64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-02 18:54 UTC by Brent Baude
Modified: 2013-12-06 00:32 UTC (History)
4 users (show)

Fixed In Version: erlang-R14B-04.3.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-06 00:32:11 UTC
Type: Bug


Attachments (Terms of Use)
abrt report (52.30 KB, application/octet-stream)
2013-05-02 19:05 UTC, Brent Baude
no flags Details
core (2.50 MB, application/octet-stream)
2013-05-02 19:06 UTC, Brent Baude
no flags Details

Description Brent Baude 2013-05-02 18:54:48 UTC
Description of problem:

Running 'erl' results in a coredump currently on RHEL6.4

Version-Release number of selected component (if applicable):
# rpm -qa | grep erlang
erlang-hipe-R14B-04.2.el6.ppc64
erlang-ssl-R14B-04.2.el6.ppc64
erlang-cosProperty-R14B-04.2.el6.ppc64
erlang-eunit-R14B-04.2.el6.ppc64
erlang-webtool-R14B-04.2.el6.ppc64
erlang-typer-R14B-04.2.el6.ppc64
erlang-syntax_tools-R14B-04.2.el6.ppc64
erlang-public_key-R14B-04.2.el6.ppc64
erlang-cosNotification-R14B-04.2.el6.ppc64
erlang-cosEventDomain-R14B-04.2.el6.ppc64
erlang-ic-R14B-04.2.el6.ppc64
erlang-et-R14B-04.2.el6.ppc64
erlang-dialyzer-R14B-04.2.el6.ppc64
erlang-appmon-R14B-04.2.el6.ppc64
erlang-kernel-R14B-04.2.el6.ppc64
erlang-stdlib-R14B-04.2.el6.ppc64
erlang-xmerl-R14B-04.2.el6.ppc64
erlang-orber-R14B-04.2.el6.ppc64
erlang-cosTime-R14B-04.2.el6.ppc64
erlang-ssh-R14B-04.2.el6.ppc64
erlang-cosFileTransfer-R14B-04.2.el6.ppc64
erlang-cosTransactions-R14B-04.2.el6.ppc64
erlang-parsetools-R14B-04.2.el6.ppc64
erlang-jinterface-R14B-04.2.el6.ppc64
erlang-gs-R14B-04.2.el6.ppc64
erlang-tools-R14B-04.2.el6.ppc64
erlang-pman-R14B-04.2.el6.ppc64
erlang-common_test-R14B-04.2.el6.ppc64
erlang-toolbar-R14B-04.2.el6.ppc64
erlang-examples-R14B-04.2.el6.ppc64
erlang-crypto-R14B-04.2.el6.ppc64
erlang-compiler-R14B-04.2.el6.ppc64
erlang-snmp-R14B-04.2.el6.ppc64
erlang-inets-R14B-04.2.el6.ppc64
erlang-edoc-R14B-04.2.el6.ppc64
erlang-docbuilder-R14B-04.2.el6.ppc64
erlang-wx-R14B-04.2.el6.ppc64
erlang-diameter-R14B-04.2.el6.ppc64
erlang-erl_interface-R14B-04.2.el6.ppc64
erlang-observer-R14B-04.2.el6.ppc64
erlang-test_server-R14B-04.2.el6.ppc64
erlang-tv-R14B-04.2.el6.ppc64
erlang-os_mon-R14B-04.2.el6.ppc64
erlang-odbc-R14B-04.2.el6.ppc64
erlang-erts-R14B-04.2.el6.ppc64
erlang-mnesia-R14B-04.2.el6.ppc64
erlang-asn1-R14B-04.2.el6.ppc64
erlang-inviso-R14B-04.2.el6.ppc64
erlang-debugger-R14B-04.2.el6.ppc64
erlang-reltool-R14B-04.2.el6.ppc64
erlang-debuginfo-R14B-04.2.el6.ppc64
erlang-runtime_tools-R14B-04.2.el6.ppc64
erlang-cosEvent-R14B-04.2.el6.ppc64
erlang-otp_mibs-R14B-04.2.el6.ppc64
erlang-percept-R14B-04.2.el6.ppc64
erlang-erl_docgen-R14B-04.2.el6.ppc64
erlang-sasl-R14B-04.2.el6.ppc64
erlang-megaco-R14B-04.2.el6.ppc64
erlang-R14B-04.2.el6.ppc64



How reproducible:


Steps to Reproduce:
1. Install RHEL 6.4
2. Install EPEL
3. yum install erlang
4. run 'erl'
  
Actual results:


Expected results:


Additional info:

Comment 1 Brent Baude 2013-05-02 18:55:15 UTC
GDB hints as follows:

[root@dhcp-9-5-170-60 ~]# !gdb
gdb -c core.6278 
GNU gdb (GDB) Red Hat Enterprise Linux (7.2-60.el6)
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "ppc64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Reading symbols from /usr/lib64/erlang/erts-5.8.5/bin/erlexec...Reading symbols from /usr/lib/debug/usr/lib64/erlang/erts-5.8.5/bin/erlexec.debug...done.
done.
[New Thread 6278]
Reading symbols from /lib64/libm-2.12.so...Reading symbols from /usr/lib/debug/lib64/libm-2.12.so.debug...done.
done.
Loaded symbols for /lib64/libm-2.12.so
Reading symbols from /lib64/libc-2.12.so...Reading symbols from /usr/lib/debug/lib64/libc-2.12.so.debug...done.
done.
Loaded symbols for /lib64/libc-2.12.so
Reading symbols from /lib64/ld-2.12.so...Reading symbols from /usr/lib/debug/lib64/ld-2.12.so.debug...done.
done.
Loaded symbols for /lib64/ld-2.12.so
Reading symbols from /lib/modules/2.6.32-358.el6.ppc64/vdso/vdso64.so...Reading symbols from /usr/lib/debug/lib/modules/2.6.32-358.el6.ppc64/vdso/vdso64.so.debug...done.
done.
Loaded symbols for /lib/modules/2.6.32-358.el6.ppc64/vdso/vdso64.so
Core was generated by `/usr/lib64/erlang/erts-5.8.5/bin/erlexec '.
Program terminated with signal 11, Segmentation fault.
#0  0x00000fff7a4f26e0 in _int_free (av=0xfff7a620888, p=0x10035d10710, 
    have_lock=<value optimized out>) at malloc.c:4984
4984	      unlink(av, p, bck, fwd);
(gdb) bt
#0  0x00000fff7a4f26e0 in _int_free (av=0xfff7a620888, p=0x10035d10710, 
    have_lock=<value optimized out>) at malloc.c:4984
#1  0x00000fff7a520480 in __closedir (dirp=<value optimized out>)
    at ../sysdeps/unix/closedir.c:52
#2  0x0000000010006860 in read_topology (cpuinfo=0x10035d10010) at common/erl_misc_utils.c:973
#3  0x0000000010006d2c in erts_cpu_info_update (cpuinfo=0x10035d10010)
    at common/erl_misc_utils.c:414
#4  0x0000000010006f00 in erts_cpu_info_create () at common/erl_misc_utils.c:232
#5  0x00000000100030ec in main (argc=1, argv=0xfffed5703c8) at ./erlexec.c:458
(gdb) quit

Comment 2 Brent Baude 2013-05-02 19:04:35 UTC
Ive got abrt working now, Ill attach its report

Comment 3 Brent Baude 2013-05-02 19:05:17 UTC
Created attachment 742865 [details]
abrt report

Comment 4 Brent Baude 2013-05-02 19:06:22 UTC
Created attachment 742866 [details]
core

Comment 5 Peter Lemenkov 2013-05-25 08:39:15 UTC
I don't have access to the hardware, so I can't help here.

Comment 6 Brent Baude 2013-05-28 14:14:07 UTC
I can provide access to a machine.  Let's work together on this. It also fails to build from source.

Comment 7 Peter Lemenkov 2013-06-28 05:35:15 UTC
(In reply to baude from comment #6)
> I can provide access to a machine.  Let's work together on this.

I can't help you, sorry.

> It also fails to build from source.

Sorry but it doesn't fail. 

http://koji.fedoraproject.org/koji/buildinfo?buildID=399212

I seriously think that there is something with your configuration. Maybe some ABI incompatible updates were pushed recently to EL6 PPC64 branch. 

Anyway I don't have resources to work on this. If you want to fix it then you're more than welcome. Otherwise I'm going to limit Erlang to x86/x86_64 where it works for sure.

Comment 8 Peter Lemenkov 2013-06-28 12:56:26 UTC

*** This bug has been marked as a duplicate of bug 979406 ***

Comment 9 Gustavo Luiz Duarte 2013-11-08 21:49:00 UTC
The following patch fixes this issue:
https://github.com/erlang/otp/commit/8c34a2dc70070cca8d97ad3c0f2dfbec1a0d82d8.patch

Comment 10 Dan Horák 2013-11-12 15:35:03 UTC
scratch build with patch from comment #9 applied = http://koji.fedoraproject.org/koji/taskinfo?taskID=6170472

Comment 11 Peter Lemenkov 2013-11-12 16:38:36 UTC
(In reply to Dan Horák from comment #10)
> scratch build with patch from comment #9 applied =
> http://koji.fedoraproject.org/koji/taskinfo?taskID=6170472

Somebody should run this update (just typing /usr/bin/erl is enough)  and it everything is ok, then a new maintainer should update erlang for EL6.

Comment 12 Gustavo Luiz Duarte 2013-11-12 17:31:22 UTC
FWIW, I tested the packages from Dan's scratch build and it works fine.

Comment 13 Dan Horák 2013-11-19 09:41:56 UTC
per discussion with new maintainer I'm going to include the fix in the package

Comment 14 Fedora Update System 2013-11-19 11:11:54 UTC
erlang-R14B-04.3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/erlang-R14B-04.3.el6

Comment 15 Fedora Update System 2013-11-20 17:24:29 UTC
Package erlang-R14B-04.3.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing erlang-R14B-04.3.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-12148/erlang-R14B-04.3.el6
then log in and leave karma (feedback).

Comment 16 Fedora Update System 2013-12-06 00:32:11 UTC
erlang-R14B-04.3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.