Bug 958966 - Can not disable display through Windows screen resolution utility.
Summary: Can not disable display through Windows screen resolution utility.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.4
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: 6.5
Assignee: Marc-Andre Lureau
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 961452 961455
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-02 19:46 UTC by Paul Vine
Modified: 2013-11-21 08:08 UTC (History)
11 users (show)

Fixed In Version: virt-viewer-0.5.6-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: Disable display through Windows screen resolution utility Consequence: Display is still there and selection was reverted. Fix: Rebase to virt-viewer 0.5.6. Result: Display disabled and selection retained.
Clone Of:
Environment:
Last Closed: 2013-11-21 08:08:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1578 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2013-11-20 21:39:50 UTC

Description Paul Vine 2013-05-02 19:46:31 UTC
Description of problem:
I have a 4 display guest running (W7-64) and I disconnect display 4 and then select apply or OK. As soon as that occurs the displays refresh and I still have display 4. If I click "save changes" my selection of disconnect display is changed back to "extend desktop to this display".

Version-Release number of selected component (if applicable):
Client: RHEL 6.4 64bit
virt-viewer-0.5.2-18.el6_4.2.x86_64
spice-gtk-0.14-7.el6.x86_64

Guest: Windows 7 Enterprise 64bit
RHEV-Tools 3.2.5 with vdagent-win-0.1-17

How reproducible:
Every time.

Steps to Reproduce:
1.Start connection to to that has 4 displays enabled.
2.When connected verify you have 4 displays.
3.Enter screen res utility, slect display 4, checge to disconne3ct this display and select ok or apply.
4.Then select keep changes and notice the display is still there and selection was reverted.
  
Actual results:
See steps.

Expected results:
Display disabled and selection retained.

Additional info:

Comment 1 Marc-Andre Lureau 2013-05-08 15:54:58 UTC
there has been a bit of back and forth, since there is no reliable way to know if a monitor is disabled by user settings or normally during reboot, we settled on keeping the display windows opened in bug 918997. Hence, the best way to remove a monitor is from virt-viewer display menu.

Comment 2 Marc-Andre Lureau 2013-05-10 17:31:09 UTC
the bug has been best described in 868970 before

reopening since rebase will improve behaviour

Comment 3 David Blechter 2013-05-10 19:42:27 UTC
As the result of re-base, the rhel client behavior will match the one in mingw-virt-viewer

Comment 9 CongDong 2013-07-05 08:53:24 UTC
I can reproduce this bug:
Version:
virt-viewer-0.5.2-18.el6_4.2.x86_64
spice-gtk-0.14-7.el6.x86_64

Setps:
As description.

result:
Can not disable display through Windows screen resolution utility

Verify:
virt-viewer-0.5.6-1.el6
spice-glib-0.20-1.el6.x86_64
spice-gtk-0.20-1.el6.x86_64

Steps:
As description

result:
Can disable display through Windows screen resolution utility

Comment 10 errata-xmlrpc 2013-11-21 08:08:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1578.html


Note You need to log in before you can comment on or make changes to this bug.