Bug 959426 - WSDL endpoints deployed via war files cannot be reloaded in EAP 6.1.0
Summary: WSDL endpoints deployed via war files cannot be reloaded in EAP 6.1.0
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Services
Version: 6.1.0
Hardware: x86_64
OS: All
unspecified
urgent
Target Milestone: ER1
: EAP 6.2.0
Assignee: Emmanuel Hugonnet (ehsavoie)
QA Contact: Rostislav Svoboda
Russell Dickenson
URL:
Whiteboard:
Depends On: 988630
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-03 12:51 UTC by Horia Chiorean
Modified: 2013-12-15 16:21 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-15 16:21:45 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker JBWS-3671 Major Closed AbstractServerConfig keep stale reference to server config after reboot 2018-08-09 22:05:40 UTC
Red Hat Bugzilla 987904 None None None Never
JBoss Issue Tracker MODE-1913 Blocker Closed CMIS web application fails to restart in EAP 6.1.0.Alpha1 2018-08-09 22:05:40 UTC
JBoss Issue Tracker WFLY-843 Major Closed Cannot restart webapp bundle after activation failure 2018-08-09 22:05:40 UTC

Internal Links: 987904

Description Horia Chiorean 2013-05-03 12:51:15 UTC
Description of problem: 
Given an EAP 6.1.0 installation which contains one or more web applications deployed that expose WSDL endpoints, upon server reload/restart the WSDL endpoints cannot be restarted.


Version-Release number of selected component (if applicable):
EAP 6.1.0.Alpha/Beta

How reproducible:
Always

Steps to Reproduce:
1. Download the ModeShape EAP kit from http://downloads.jboss.org/modeshape/3.2.0.Final/modeshape-3.2.0.Final-jbosseap-61-dist.zip
2. Extract the contents into an existing EAP 6.1.0.Beta distribution
3. Start the server with "standalone.sh -c standalone-modeshape.xml"
4. Start a CLI session and connect to the server via "jboss-cli.sh"
5. In the CLI command window, enter: ":reload"
  
Actual results:

15:14:03,838 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-4) MSC00001: Failed to start service jboss.deployment.unit."modeshape-cmis.war".INSTALL: org.jboss.msc.service.StartException in service jboss.deployment.unit."modeshape-cmis.war".INSTALL: JBAS018733: Failed to process phase INSTALL of deployment "modeshape-cmis.war"
        at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:127) [jboss-as-server-7.2.0.Alpha1-redhat-4.jar:7.2.0.Alpha1-redhat-4]
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [rt.jar:1.6.0_29]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [rt.jar:1.6.0_29]
        at java.lang.Thread.run(Thread.java:662) [rt.jar:1.6.0_29]
Caused by: java.lang.IllegalStateException
        at org.jboss.msc.value.InjectedValue.getValue(InjectedValue.java:47) [jboss-msc-1.0.4.GA.jar:1.0.4.GA]
        at org.jboss.as.webservices.config.ServerConfigImpl.getServerEnvironment(ServerConfigImpl.java:80)
        at org.jboss.as.webservices.config.ServerConfigImpl.getServerDataDir(ServerConfigImpl.java:58)
        at org.jboss.wsf.stack.cxf.deployment.WSDLFilePublisher.getPublishLocation(WSDLFilePublisher.java:161)
        at org.jboss.wsf.stack.cxf.deployment.WSDLFilePublisher.publishWsdlFiles(WSDLFilePublisher.java:69)
        at org.jboss.wsf.stack.cxf.deployment.EndpointImpl.publishContractToFilesystem(EndpointImpl.java:132)
        at org.jboss.wsf.stack.cxf.deployment.EndpointImpl.doPublish(EndpointImpl.java:72)
        at org.apache.cxf.jaxws.EndpointImpl.publish(EndpointImpl.java:250)
        at org.apache.cxf.jaxws.EndpointImpl.publish(EndpointImpl.java:536)
        at org.jboss.wsf.stack.cxf.configuration.NonSpringBusHolder.configure(NonSpringBusHolder.java:116)
        at org.jboss.wsf.stack.cxf.deployment.aspect.BusDeploymentAspect.startDeploymentBus(BusDeploymentAspect.java:128)
        at org.jboss.wsf.stack.cxf.deployment.aspect.BusDeploymentAspect.start(BusDeploymentAspect.java:67)
        at org.jboss.as.webservices.deployers.AspectDeploymentProcessor.deploy(AspectDeploymentProcessor.java:74)


Expected results:
The web application(s) should be restarted without any problem

Additional info:
The problem seems to be that on server restart, the ServerEnvironment instance cannot be injected into the ServerConfigImpl used by the WSDLFilePublisher.

Comment 1 Horia Chiorean 2013-05-03 12:52:59 UTC
This affects the ModeShape CMIS web application, which is part of the ModeShape kit.

Comment 3 JBoss JIRA Server 2013-05-22 13:20:07 UTC
Randall Hauch <rhauch@jboss.org> made a comment on jira MODE-1913

[~oleg.kulikov], have you made progress on tracking down this problem? It's marked as a blocker for the release, so we need to get this resolved soon.

Comment 4 JBoss JIRA Server 2013-05-22 13:24:08 UTC
Horia Chiorean <hchiorea@redhat.com> made a comment on jira MODE-1913

[~rhauch]: imo this is out of our hands. There are both BZ and JIRA issues opened on AS/EAP but they have been ignored so far. Since 6.1.0.GA is out, i doubt any fix for this will make it in.

So IMO we have the following options:
a) remove modeshape-cmis.war from the KIT
b) leave it as is and mark it as a known issue, pointing people to the open issues when they inquire

Comment 5 JBoss JIRA Server 2013-05-22 13:24:08 UTC
Horia Chiorean <hchiorea@redhat.com> made a comment on jira MODE-1913

[~rhauch]: imo this is out of our hands. There are both BZ and JIRA issues opened on AS/EAP but they have been ignored so far. Since 6.1.0.GA is out, i doubt any fix for this will make it in.

So IMO we have the following options:
a) remove modeshape-cmis.war from the KIT
b) leave it as is and mark it as a known issue, pointing people to the open issues when the inquire

Comment 7 JBoss JIRA Server 2013-05-24 13:12:00 UTC
Horia Chiorean <hchiorea@redhat.com> made a comment on jira MODE-1913

I can confirm that the problem still manifests itself in EAP 6.1.0.GA. The solution to this issue will have to be (a) from above.

Comment 8 JBoss JIRA Server 2013-05-29 08:43:29 UTC
Horia Chiorean <hchiorea@redhat.com> made a comment on jira MODE-1913

Removed the CMIS webapp from the EAP xml configuration file. The web application will still be packaged & distributed, but will not start together with the subsystem.

Comment 9 baranowb 2013-06-03 12:14:07 UTC
This issue should not be in "NEW" Status.

Comment 10 JBoss JIRA Server 2013-06-03 12:29:59 UTC
Thomas Diesler <thomas.diesler@jboss.org> made a comment on jira WFLY-843

This is an OSGi issue. Is the above webapp really an OSGi bundle?

Comment 11 Horia Chiorean 2013-06-03 12:39:45 UTC
No, it isn't. It's a web application that exposes SOAP endpoints via SAAJ.

Comment 12 Horia Chiorean 2013-06-03 12:42:38 UTC
To be even more specific, the endpoints are provided by Apache Chemistry.

Comment 13 Horia Chiorean 2013-06-03 12:52:35 UTC
Even though the web app itself isn't packaged as an OSGI bundle, one of its libs:
chemistry-opencmis-server-jcr-0.9.0-beta-1-classes.jar is.

However, I don't know if that's enough to qualify the entire web app as an OSGI bundle. Also, the jar which provides the implementation of the endpoints, isn't an OSGI bundle.

Comment 15 JBoss JIRA Server 2013-06-28 10:16:08 UTC
Thomas Diesler <thomas.diesler@jboss.org> updated the status of jira WFLY-843 to Resolved

Comment 16 JBoss JIRA Server 2013-06-28 10:16:08 UTC
Thomas Diesler <thomas.diesler@jboss.org> made a comment on jira WFLY-843

Won't Fix - OSGi is going to get removed

Comment 17 JBoss JIRA Server 2013-07-05 04:52:50 UTC
Thomas Diesler <thomas.diesler@jboss.org> updated the status of jira WFLY-843 to Reopened

Comment 18 Emmanuel Hugonnet (ehsavoie) 2013-07-23 09:42:50 UTC
This bug is not linked to OSGI but to org.jboss.ws.common.management.AbstractServerConfig having a stale version of the ServerConfigImpl after the code introduced in https://issues.jboss.org/browse/JBWS-3576

Comment 19 JBoss JIRA Server 2013-07-24 14:12:21 UTC
Alessio Soldano <asoldano@redhat.com> updated the status of jira JBWS-3671 to Resolved

Comment 20 Emmanuel Hugonnet (ehsavoie) 2013-07-26 13:21:27 UTC
https://github.com/jbossas/jboss-eap/pull/259

Comment 21 Rostislav Svoboda 2013-09-20 12:45:38 UTC
Verified on EAP 620 ER2, issue simulated on EAP 610 GA and verified on EAP 620 ER2 with custom war archive. 

Latest Modeshape 3.5.0 is not possible to deploy on EAP 6.2.0.

Comment 25 JBoss JIRA Server 2013-10-21 14:07:56 UTC
Alessio Soldano <asoldano@redhat.com> updated the status of jira JBWS-3671 to Closed


Note You need to log in before you can comment on or make changes to this bug.