Bug 987904 - CLI - unable to deploy war with webservice after server reload if it was deployed and undeployed before reload
Summary: CLI - unable to deploy war with webservice after server reload if it was depl...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Services
Version: 6.1.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ER4
: EAP 6.1.1
Assignee: Alessio Soldano
QA Contact:
URL:
Whiteboard:
Depends On: 988630
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-24 11:54 UTC by Petr Sakař
Modified: 2014-06-18 07:20 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-16 20:25:06 UTC
Type: Bug


Attachments (Terms of Use)
deployed war (3.81 KB, application/zip)
2013-07-24 11:54 UTC, Petr Sakař
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 959426 None None None Never
Red Hat Bugzilla 989597 None None None Never

Internal Links: 959426 989597

Description Petr Sakař 2013-07-24 11:54:06 UTC
Created attachment 777745 [details]
deployed war

Description of problem:
war containing webservice (annotation based) can not be undeployed and deployed again after server reload

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Start AS   
  ./bin/standalone.sh
2. Connect CLI 
  ./bin/jboss-cli.sh -c
3. Deploy attached war
  deploy /tmp/CLIWebservicesWsdlPortTestCase.war
4. Undeploy deployd webapp
  undeploy CLIWebservicesWsdlPortTestCase.war
5. Reload AS
  reload
6. Deploy attached war
  deploy /tmp/CLIWebservicesWsdlPortTestCase.war

Actual results:
{"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-2" => {"JBAS014671: Failed services" => {"jboss.deployment.unit.\"CLIWebservicesWsdlPortTestCase.war\".INSTALL" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"CLIWebservicesWsdlPortTestCase.war\".INSTALL: JBAS018733: Failed to process phase INSTALL of deployment \"CLIWebservicesWsdlPortTestCase.war\"
    Caused by: java.lang.IllegalStateException"}}}}

Expected results:
no error and application deployed


Additional info:

To deploy application again server has to be restarted.


Server exception:
13:50:11,394 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015951: Admin console listening on http://127.0.0.1:9990
13:50:11,395 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015874: JBoss EAP 6.1.1.GA (AS 7.2.1.Final-redhat-4) started in 211ms - Started 123 of 177 services (53 services are passive or on-demand)
13:50:31,867 INFO  [org.jboss.as.repository] (management-handler-thread - 2) JBAS014900: Content added at location /home/development/jbossqe/JBEAP-6.1.1-ER3/jboss-eap-6.1/standalone/data/content/5a/ad6ac47ebdca413454e5250ab0c2fa4fc9709b/content
13:50:31,871 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-5) JBAS015876: Starting deployment of "CLIWebservicesWsdlPortTestCase.war" (runtime-name: "CLIWebservicesWsdlPortTestCase.war")
13:50:31,938 INFO  [org.jboss.ws.cxf.metadata] (MSC service thread 1-4) JBWS024061: Adding service endpoint metadata: id=org.jboss.test.ws.cli.AnnotatedServiceImpl
 address=http://localhost:8080/CLIWebservicesWsdlPortTestCase/AnnotatedSecurityService
 implementor=org.jboss.test.ws.cli.AnnotatedServiceImpl
 serviceName={http://www.jboss.org/jbossws/ws-extensions/wssecuritypolicy}AnnotatedSecurityService
 portName={http://www.jboss.org/jbossws/ws-extensions/wssecuritypolicy}AnnotatedSecurityServicePort
 annotationWsdlLocation=null
 wsdlLocationOverride=null
 mtomEnabled=false
13:50:31,950 INFO  [org.apache.cxf.service.factory.ReflectionServiceFactoryBean] (MSC service thread 1-4) Creating Service {http://www.jboss.org/jbossws/ws-extensions/wssecuritypolicy}AnnotatedSecurityService from class org.jboss.test.ws.cli.AnnotatedServiceIface
13:50:31,977 INFO  [org.apache.cxf.endpoint.ServerImpl] (MSC service thread 1-4) Setting the server's publish address to be http://localhost:8080/CLIWebservicesWsdlPortTestCase/AnnotatedSecurityService
13:50:31,979 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-4) MSC000001: Failed to start service jboss.deployment.unit."CLIWebservicesWsdlPortTestCase.war".INSTALL: org.jboss.msc.service.StartException in service jboss.deployment.unit."CLIWebservicesWsdlPortTestCase.war".INSTALL: JBAS018733: Failed to process phase INSTALL of deployment "CLIWebservicesWsdlPortTestCase.war"
	at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:127) [jboss-as-server-7.2.1.Final-redhat-4.jar:7.2.1.Final-redhat-4]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_25]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_25]
	at java.lang.Thread.run(Thread.java:724) [rt.jar:1.7.0_25]
Caused by: java.lang.IllegalStateException
	at org.jboss.msc.value.InjectedValue.getValue(InjectedValue.java:47) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at org.jboss.as.webservices.config.ServerConfigImpl.getServerEnvironment(ServerConfigImpl.java:80)
	at org.jboss.as.webservices.config.ServerConfigImpl.getServerDataDir(ServerConfigImpl.java:58)
	at org.jboss.wsf.stack.cxf.deployment.WSDLFilePublisher.getPublishLocation(WSDLFilePublisher.java:161)
	at org.jboss.wsf.stack.cxf.deployment.WSDLFilePublisher.publishWsdlFiles(WSDLFilePublisher.java:69)
	at org.jboss.wsf.stack.cxf.deployment.EndpointImpl.publishContractToFilesystem(EndpointImpl.java:131)
	at org.jboss.wsf.stack.cxf.deployment.EndpointImpl.doPublish(EndpointImpl.java:71)
	at org.apache.cxf.jaxws.EndpointImpl.publish(EndpointImpl.java:250)
	at org.apache.cxf.jaxws.EndpointImpl.publish(EndpointImpl.java:536)
	at org.jboss.wsf.stack.cxf.configuration.NonSpringBusHolder.configure(NonSpringBusHolder.java:116)
	at org.jboss.wsf.stack.cxf.deployment.aspect.BusDeploymentAspect.startDeploymentBus(BusDeploymentAspect.java:128)
	at org.jboss.wsf.stack.cxf.deployment.aspect.BusDeploymentAspect.start(BusDeploymentAspect.java:67)
	at org.jboss.as.webservices.deployers.AspectDeploymentProcessor.deploy(AspectDeploymentProcessor.java:74)
	at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:120) [jboss-as-server-7.2.1.Final-redhat-4.jar:7.2.1.Final-redhat-4]
	... 5 more

13:50:31,988 ERROR [org.jboss.as.server] (management-handler-thread - 2) JBAS015870: Deploy of deployment "CLIWebservicesWsdlPortTestCase.war" was rolled back with the following failure message: 
{"JBAS014671: Failed services" => {"jboss.deployment.unit.\"CLIWebservicesWsdlPortTestCase.war\".INSTALL" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"CLIWebservicesWsdlPortTestCase.war\".INSTALL: JBAS018733: Failed to process phase INSTALL of deployment \"CLIWebservicesWsdlPortTestCase.war\"
    Caused by: java.lang.IllegalStateException"}}
13:50:31,995 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-4) JBAS015877: Stopped deployment CLIWebservicesWsdlPortTestCase.war (runtime-name: CLIWebservicesWsdlPortTestCase.war) in 7ms

Comment 1 Rostislav Svoboda 2013-07-25 10:52:19 UTC
Issue is WS based, fix in upstream available - https://issues.jboss.org/browse/JBWS-3671 The same problem found in BZ 959426.

Comment 2 Petr Sakař 2013-07-25 12:49:58 UTC
fix is just https://source.jboss.org/changelog/JBossWS?cs=17808


Note You need to log in before you can comment on or make changes to this bug.