Bug 960045 - f19 Beta TC4 soas live fails to boot after "liveinst" install but @sugar-desktop installed with yum works
Summary: f19 Beta TC4 soas live fails to boot after "liveinst" install but @sugar-des...
Keywords:
Status: CLOSED DUPLICATE of bug 964965
Alias: None
Product: Fedora
Classification: Fedora
Component: spin-kickstarts
Version: 19
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jeroen van Meeuwen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F19Beta-accepted, F19BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2013-05-06 13:34 UTC by satellitgo
Modified: 2013-05-21 01:05 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-21 01:05:14 UTC
Type: Bug


Attachments (Terms of Use)
sugar-desktop after liveinst from f19 DVD install-stuck on "X" (40.24 KB, image/png)
2013-05-06 15:04 UTC, satellitgo
no flags Details
SoaS-x86_64 BetaRC2 first screen after install and reboot (16.29 KB, image/png)
2013-05-17 16:25 UTC, satellitgo
no flags Details

Description satellitgo 2013-05-06 13:34:41 UTC
Description of problem:
f19 Beta TC3 soas fails to boot but @sugar-desktop installed with yum works

Version-Release number of selected component (if applicable):
f19 Beta TC3 soas (both archs)

How reproducible:


Steps to Reproduce:
1.start soas live.iso in VirtualBox
2.
3.
  
Actual results:
boot stops with "X" cursor.


Expected results:
sugar-desktop to start

Additional info:
netinstall Beta-TC3 of Mate 1.6.0  or gnome3.8: then "yum install @sugar-desktop sugar-emulator" sugar-desktop works fine.
Some component is missing from Soas.ks

Comment 1 satellitgo 2013-05-06 13:54:57 UTC
(In reply to comment #0)
> Description of problem:
> f19 Beta TC3 soas fails to boot but @sugar-desktop installed with yum works
> 
> Version-Release number of selected component (if applicable):
> f19 Beta TC3 soas (both archs)
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1.start soas live.iso in VirtualBox
> 2.
> 3.
>   
> Actual results:
> boot stops with "X" cursor.
> 
> 
> Expected results:
> sugar-desktop to start
> 
> Additional info:
> netinstall Beta-TC3 of Mate 1.6.0  or gnome3.8: then "yum install
> @sugar-desktop sugar-emulator" sugar-desktop works fine.
> Some component is missing from Soas.ks

correction: soas live starts and runs; "liveinst" to HD fails with the "X" cursor after install.

Note also that some languages are displayed as boxes [] [] etc... and cursor leaves "X" ghost tracs on started live CD(In reply to comment #0)
> Description of problem:
> f19 Beta TC3 soas fails to boot but @sugar-desktop installed with yum works
> 
> Version-Release number of selected component (if applicable):
> f19 Beta TC3 soas (both archs)
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1.start soas live.iso in VirtualBox
> 2.
> 3.
>   
> Actual results:
> boot stops with "X" cursor.
> 
> 
> Expected results:
> sugar-desktop to start
> 
> Additional info:
> netinstall Beta-TC3 of Mate 1.6.0  or gnome3.8: then "yum install
> @sugar-desktop sugar-emulator" sugar-desktop works fine.
> Some component is missing from Soas.ks
correction :
f19 Beta TC3 soas fails to boot after "liveinst" install (starts to "X" cursor) but @sugar-desktop installed with yum works

Comment 2 satellitgo 2013-05-06 15:04:59 UTC
Created attachment 744218 [details]
sugar-desktop after liveinst from f19 DVD install-stuck on "X"

Comment 3 satellitgo 2013-05-12 04:35:41 UTC
Added Proposed BetaFreezeException
I hope that this is done correctly
This bug prevents soas spin and netinstall and DVD (both arches)from launching sugar.
sugar desktop installed from Yum in gnome3 and KDE BetaTC4 works as expected.

Looks like the kickstarts used for sugar-dektop and soas spin iare missing something that is already installed with the 2 DE's

Comment 4 satellitgo 2013-05-12 20:44:37 UTC
the same "X" cursor freeze occurs in a netinstall of cinnamon (TC4 Beta x86_64)

May be the same missing files. Both work if installed after desktop (gnome3) or KDE are installed.

Comment 5 Kevin Fenzi 2013-05-14 16:20:14 UTC
So, some thoughts: 

If you could boot the SoAS live, then get a 'show-installed' output, then install mate/gnome and install sugar-desktop (the non booting state), then get another 'show-installed' we may be able to compare the two and see what is missing on the spin. 

Also, if you can get to a vty when it's freezing (control-alt-f2) and login as root, the /var/log/Xorg.0.log and dmesg might be useful to see where it's hung.

Comment 6 Adam Williamson 2013-05-15 23:38:14 UTC
Discussed at 2013-05-15 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-15/f19beta-blocker-review-6.2013-05-15-16.02.html . Accepted as a freeze exception issue as a showstopper bug for a non-blocking (but shipped) desktop.

Comment 7 satellitgo 2013-05-17 16:25:34 UTC
Created attachment 749414 [details]
SoaS-x86_64 BetaRC2 first screen after install and reboot

SoaS-x86_64 BetaRC2 first screen after install and reboot

Comment 8 Adam Williamson 2013-05-21 01:05:14 UTC
Pretty sure this is the same as 964965 . I understand that pbrobinson is planning to switch the spin to lightdm so as not to pull in Shell, but for now, gdm fixing its requires will fix this.

*** This bug has been marked as a duplicate of bug 964965 ***


Note You need to log in before you can comment on or make changes to this bug.