Bug 964965 - gdm should require it's own deps to function.
gdm should require it's own deps to function.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
AcceptedFreezeException
:
: 960045 (view as bug list)
Depends On:
Blocks: F19Beta-accepted/F19BetaFreezeException
  Show dependency treegraph
 
Reported: 2013-05-20 04:23 EDT by atlee
Modified: 2013-05-24 16:36 EDT (History)
6 users (show)

See Also:
Fixed In Version: gdm-3.8.1.1-5.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 16:36:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description atlee 2013-05-20 04:23:21 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install from netinstall, Select Cinnamon DE
2. Reboot
3. Stop after fedora boot screen

Actual results:
Nothing happens after fedora boot screen, it's meant to init the GDM.

Expected results:
GDM is meant to load.

Additional info:

Cinnamon is missing the below dependency packages:


telepathy-glib-0.20.2-1.fc19.x86_64
mutter-3.8.2-1.fc19.x86_64
gnome-session-xsession-3.8.2-1.fc19.x86_64
telepathy-filesystem-0.0.2-5.fc19.noarch
telepathy-logger-0.8.0-2.fc19.x86_64
gdm-libs-3.8.1.1-3.fc19.x86_64
gnome-shell-3.8.2-2.fc19.x86_64
Comment 1 leigh scott 2013-05-20 05:44:37 EDT
Reassigned to GDM.

gdm should require it's own deps to function.
Comment 2 Adam Williamson 2013-05-20 13:21:37 EDT
Proposing as a Beta FE - cinnamon is switching to lightdm, but I think SoaS is still on gdm and this bug is breaking the SoaS spin. And there may be other ways to hit it. Making gdm work more reliably seems like a good thing to get in.
Comment 3 Adam Williamson 2013-05-20 14:57:03 EDT
Discussed at 2013-05-20 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-20/f19beta-blocker-review-7.2013-05-20-16.07.log.txt . Accepted as a freeze exception issue on the condition that we will only push a fix through freeze that meets these conditions:

a) only adds Requires: lines to the gdm spec, does not touch gdm code at all
b) is tested not to add packages to or increase the size of the desktop spin
Comment 4 Peter Robinson 2013-05-20 15:11:53 EDT
(In reply to Adam Williamson from comment #2)
> Proposing as a Beta FE - cinnamon is switching to lightdm, but I think SoaS
> is still on gdm and this bug is breaking the SoaS spin. And there may be
> other ways to hit it. Making gdm work more reliably seems like a good thing
> to get in.

I'm going to move SoaS to lightdm as gdm now unfortunately needs gnome-shell and all the stuff it pulls in.
Comment 5 Fedora Update System 2013-05-20 16:33:22 EDT
gdm-3.8.1.1-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gdm-3.8.1.1-5.fc19
Comment 6 Adam Williamson 2013-05-20 21:05:14 EDT
*** Bug 960045 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2013-05-21 13:19:22 EDT
Package gdm-3.8.1.1-5.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gdm-3.8.1.1-5.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8761/gdm-3.8.1.1-5.fc19
then log in and leave karma (feedback).
Comment 8 Adam Williamson 2013-05-23 11:31:46 EDT
this build does require gnome-shell, verified.
Comment 9 Fedora Update System 2013-05-24 16:36:44 EDT
gdm-3.8.1.1-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.