Bug 960579 - Synaptics vertical scroll function broken in F19 beta-TC3
Summary: Synaptics vertical scroll function broken in F19 beta-TC3
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon
Version: 19
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 968565 969318 981522 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-07 12:34 UTC by pizza306
Modified: 2015-04-12 02:51 UTC (History)
27 users (show)

Fixed In Version: gnome-settings-daemon-3.8.5-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-09 09:29:14 UTC


Attachments (Terms of Use)
Xorg.log (26.47 KB, text/plain)
2013-05-15 18:43 UTC, pizza306
no flags Details
dracut.log (25.81 KB, text/x-log)
2013-05-15 18:44 UTC, pizza306
no flags Details

Description pizza306 2013-05-07 12:34:03 UTC
Description of problem:
as title.

Version-Release number of selected component (if applicable):
Fedora 19 Beta-TC3 x86_64 live (Gnome)
kernel-3.9.0-301.fc19.x86_64
Gnome 3.8.1

How reproducible:
always.

Steps to Reproduce:
1. boot into F19 live desktop.
2. try to use vertical scroll in somewhere.
3.
  
Actual results:
page/screen wouldn't scroll

Expected results:
scroll should be fine and smooth as always.

Additional info:
there's a similar bug #177868 as in Fedora 4, but that happend due to udev hasn't been update yet, not sure is same for this case, either.
beside, here's another similar bug like #577620, since that case was can't select two finger scroll, my setting was ticked by default and can't pick off (grayed out).

Comment 1 pizza306 2013-05-07 12:36:58 UTC
here is the adiitional info from /proc/bus/input/devices:

I: Bus=0011 Vendor=0002 Product=0007 Version=01b1
N: Name="SynPS/2 Synaptics TouchPad"
P: Phys=isa0060/serio4/input0
S: Sysfs=/devices/platform/i8042/serio4/input/input6
U: Uniq=
H: Handlers=mouse0 event6 
B: PROP=1
B: EV=b
B: KEY=420 30003 0 0 0 0
B: ABS=11000003

I: Bus=0011 Vendor=0001 Product=0001 Version=ab41
N: Name="AT Translated Set 2 keyboard"
P: Phys=isa0060/serio0/input0
S: Sysfs=/devices/platform/i8042/serio0/input/input4
U: Uniq=
H: Handlers=sysrq kbd event4 
B: PROP=0
B: EV=120013
B: KEY=402000000 3803078f800d001 feffffdfffefffff fffffffffffffffe
B: MSC=10
B: LED=7

Comment 2 Josh Boyer 2013-05-08 19:05:01 UTC
What kind of machine is this?

What version of xorg-x11-drv-synaptics do you have?

Does this issue first start with kernel-3.9.0-301, or did you hit this with older kernels?

Comment 3 pizza306 2013-05-09 20:50:29 UTC
it's a clevo M740SU laptop.

it show as 'xorg-x11-drv-synaptics.x86_64-1.7.0-2.fc19   @koji-override-0/$releasever' in yum list.

i use fedora on this laptop since F15 and find this problem on this live version only, so it may first start with kernel-3.9.0-301, daily use on F18 fully updated was fine.

p.s. the function can manually enable via configure 'synclient VertEdgeScroll=1', so it's weird why this value has changed to 0?

Comment 4 Josh Boyer 2013-05-10 13:03:13 UTC
If the function works by changing VertEdgeScroll=1 then the kernel is working as it should.  Moving this to the synaptics driver.

Comment 5 Peter Hutterer 2013-05-12 21:40:17 UTC
In System settings → Mouse & Touchpad, is "Two finger scroll" enabled? If so, does disabling it make it work again?

Please attach your Xorg.log as well.

Comment 6 pizza306 2013-05-15 18:43:27 UTC
Created attachment 748444 [details]
Xorg.log

sorry for late reply, log as attached.

Comment 7 pizza306 2013-05-15 18:44:18 UTC
Created attachment 748446 [details]
dracut.log

Comment 8 pizza306 2013-05-15 18:45:39 UTC
and yes, two finger scroll option is checked but can't unchecked (grey out)

Comment 9 Peter Hutterer 2013-05-15 23:24:27 UTC
run this command below. that should uncheck it and enable edge scrolling. Did you move your home directory from a different machine that supported two-finger scrolling or so?


gsettings set org.gnome.settings-daemon.peripherals.touchpad scroll-method 'edge-scrolling'

Comment 10 pizza306 2013-05-17 01:53:28 UTC
sweet, the command works. but i didn't move my home directory, i either run on live image and fresh install on my machine.

Comment 11 Peter Hutterer 2013-05-19 22:39:18 UTC
reassigning, unclear why this was set. problem is fixed for now, but it may be worth investigating how that option was set in the first place if the device never supported two-finger scrolling

possibly the install default that can't be unset?

Comment 12 David Paige 2013-07-04 18:29:50 UTC
I have the same vertical scrolling issue on an Acer Aspire 5742.  I cannot use the vertical scrolling, but I can use the two-finger scroll.

Comment 13 Vitezslav Zivota 2013-07-06 08:37:20 UTC
The same vertical scrolling issue is on my HP 550 in final F19. After fresh install the 'Two finger scroll' option was enabled and gray and vertical scrolling didn't work. This old laptop doesn't support two finger scrolling.

Command from https://bugzilla.redhat.com/show_bug.cgi?id=960579#c9 helped.

F15, F16 and F18 on this laptop were without this issue.

here is the adiitional info from my /proc/bus/input/devices:

I: Bus=0011 Vendor=0002 Product=0007 Version=01b1
N: Name="SynPS/2 Synaptics TouchPad"
P: Phys=isa0060/serio4/input0
S: Sysfs=/devices/platform/i8042/serio4/input/input4
U: Uniq=
H: Handlers=mouse0 event4 
B: PROP=1
B: EV=b
B: KEY=420 30000 0 0 0 0
B: ABS=11000003

Comment 14 rimbotede 2013-07-12 21:19:30 UTC
The command https://bugzilla.redhat.com/show_bug.cgi?id=960579#c9 didn't help.
Lenovo Thinkpad T500

Comment 16 Phil 2013-07-17 13:09:54 UTC
Same issue on a T61. Suggested command doesn't help. However, synclient VertEdgeScroll=1 does.

Comment 17 Phil 2013-07-17 13:11:56 UTC
Sorry. I ran the command sudo not as user. Running it as user does work as suggested.

Comment 18 rimbotede 2013-07-18 09:02:42 UTC
The command does work when issued NOT as sudo https://bugzilla.redhat.com/show_bug.cgi?id=960579#c9 but the scrolling works in reverse! Unthicking 'content sticks to fingers' in the GUI does not help.

Comment 19 richard 2013-07-21 16:50:53 UTC
I have the same issue with my laptop a Toshiba satellite where edge scroll didnt work and the command ( gsettings set org.gnome.settings-daemon.peripherals.touchpad scroll-method 'edge-scrolling') caused the scroll to be reversed! What I did was write a bash file that i intend to have run on login (havent figured that part out cause im new to linux). My file has the following commands:

synclient VertEdgeScroll=1
synclient HorizEdgeScroll=1
synclient VertScrollDelta=123
synclient HorizScrollDelta=123

The delta was defult to -123 so i just made the value positive an well that fixed it. Note: for windows open b4 the delta is set to 123, the scroll will  still work in reverse so just close and reopen those applications.

Cheers.

Comment 20 richard 2013-07-21 16:51:22 UTC
I have the same issue with my laptop a Toshiba satellite where edge scroll didnt work and the command ( gsettings set org.gnome.settings-daemon.peripherals.touchpad scroll-method 'edge-scrolling') caused the scroll to be reversed! What I did was write a bash file that i intend to have run on login (havent figured that part out cause im new to linux). My file has the following commands:

synclient VertEdgeScroll=1
synclient HorizEdgeScroll=1
synclient VertScrollDelta=123
synclient HorizScrollDelta=123

The delta was defult to -123 so i just made the value positive an well that fixed it. Note: for windows open b4 the delta is set to 123, the scroll will  still work in reverse so just close and reopen those applications.

Cheers.

Comment 21 Alexander van Loon 2013-08-18 08:00:09 UTC
Fortunately I just found this bug before I filed my own. I was already preparing to attach my own output of lspci, lsusb, xinput list and /proc/bus/input/devices, but disabling "Two finger scroll" as suggested in comment #5 worked for me. I did not need to use the command given in comment #9.

I can provide further information if necessary, but in summary my case concerns a fully updated laptop with F19. Vertical scrolling had been working fine out of the box when I was still using F17 and F18 on this laptop.

Comment 22 Rui Matos 2013-09-05 14:50:29 UTC
*** Bug 968565 has been marked as a duplicate of this bug. ***

Comment 23 Rui Matos 2013-09-05 14:50:34 UTC
*** Bug 969318 has been marked as a duplicate of this bug. ***

Comment 24 Rui Matos 2013-09-05 14:50:40 UTC
*** Bug 981522 has been marked as a duplicate of this bug. ***

Comment 25 Mikhail Zabaluev 2013-09-05 20:31:21 UTC
Filed upstream: https://bugzilla.gnome.org/show_bug.cgi?id=707593

Comment 26 Rui Matos 2013-09-09 09:29:14 UTC
This should be fixed now.


Note You need to log in before you can comment on or make changes to this bug.