Bug 968565 - No easy way to switch from two-finger scrolling to edge scrolling for an unsupportive touchpad
No easy way to switch from two-finger scrolling to edge scrolling for an unsu...
Status: CLOSED DUPLICATE of bug 960579
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
19
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-29 16:44 EDT by Mikhail Zabaluev
Modified: 2013-09-05 10:50 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-05 10:50:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail Zabaluev 2013-05-29 16:44:18 EDT
Description of problem:
On a ThinkPad T500, the touchpad supports edge scrolling, but apparently not two-finger scrolling. After upgrading to Fedora 19, the default dconf setting in /org/gnome/settings-daemon/peripherals/touchpad/scroll-method disables edge scrolling that used to work, but does not make two-finger scrolling work. Switching the value to edge scrolling makes edge scrolling work as expected. In GNOME settings for the touchpad, the "two-finger scrolling" checkbox reflects the dconf setting, but is disabled for input, and there is no way to enable edge scrolling.

Version-Release number of selected component (if applicable):
3.8.2-1.fc19

How reproducible:
always

Steps to Reproduce:
1. Upgraded Fedora 18 -> 19 on a Lenovo Thinkpad T500.
2. In a GTK+ application that features a scroll bar, try edge scrolling or two-finger scrolling.
3. In GNOME settings for mouse and touchpad, check the setting for two-finger scrolling.

Actual results:
Neither scrolling gesture works. The control panel setting is enabled, but grayed.

Expected results:
Either two-finger scrolling should work, or it should be disabled by default (as a result of input device autodetection?). Edge scrolling should be available as an option, or work out of the box.
Comment 1 Filip Krska 2013-06-03 04:52:53 EDT
The unsolicited configuration change from edge scrolling to two-finger scrolling during upgrade is a bug per se.
Comment 2 Jeroen Besse 2013-07-14 03:49:29 EDT
Setting can be changed manually from terminal:

gsettings set org.gnome.settings-daemon.peripherals.touchpad scroll-method 'edge-scrolling'

After this, scroll setting is changed, and setting is changed in settings panel, but checkbox is still disabled for input.
Comment 4 Rui Matos 2013-09-05 10:50:29 EDT

*** This bug has been marked as a duplicate of bug 960579 ***

Note You need to log in before you can comment on or make changes to this bug.