Bug 960896 - SELinux is preventing /usr/libexec/postfix/local from read, write access on the file /var/spool/postfix/pid/unix.local.
SELinux is preventing /usr/libexec/postfix/local from read, write access on t...
Status: CLOSED DUPLICATE of bug 960894
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:9b28e8fae1acd016e77bb4cc7d0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-08 05:32 EDT by Nicolas Mailhot
Modified: 2013-05-08 10:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-08 10:52:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2013-05-08 05:32:55 EDT
Description of problem:
SELinux is preventing /usr/libexec/postfix/local from read, write access on the file /var/spool/postfix/pid/unix.local.

*****  Plugin catchall (100. confidence) suggests  ***************************

If vous pensez que local devrait être autorisé à accéder read write sur unix.local file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep local /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:postfix_local_t:s0
Target Context                system_u:object_r:postfix_var_run_t:s0
Target Objects                /var/spool/postfix/pid/unix.local [ file ]
Source                        local
Source Path                   /usr/libexec/postfix/local
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           postfix-2.10.0-1.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-41.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.10.0-0.rc0.git21.1.fc20.x86_64
                              #1 SMP Tue May 7 19:47:51 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-08 11:27:37 CEST
Last Seen                     2013-05-08 11:27:37 CEST
Local ID                      06cdf514-35fe-463a-b812-e34f0beeb26d

Raw Audit Messages
type=AVC msg=audit(1368005257.88:108): avc:  denied  { read write } for  pid=2431 comm="local" name="unix.local" dev="dm-0" ino=3024628 scontext=system_u:system_r:postfix_local_t:s0 tcontext=system_u:object_r:postfix_var_run_t:s0 tclass=file


type=AVC msg=audit(1368005257.88:108): avc:  denied  { open } for  pid=2431 comm="local" path="/var/spool/postfix/pid/unix.local" dev="dm-0" ino=3024628 scontext=system_u:system_r:postfix_local_t:s0 tcontext=system_u:object_r:postfix_var_run_t:s0 tclass=file


type=SYSCALL msg=audit(1368005257.88:108): arch=x86_64 syscall=open success=yes exit=ENOEXEC a0=7f320eec9740 a1=2 a2=0 a3=0 items=0 ppid=2381 pid=2431 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=local exe=/usr/libexec/postfix/local subj=system_u:system_r:postfix_local_t:s0 key=(null)

Hash: local,postfix_local_t,postfix_var_run_t,file,read,write

audit2allow

#============= postfix_local_t ==============
allow postfix_local_t postfix_var_run_t:file { read write open };

audit2allow -R
require {
	type postfix_local_t;
	type postfix_var_run_t;
	class file { read write open };
}

#============= postfix_local_t ==============
allow postfix_local_t postfix_var_run_t:file { read write open };


Additional info:
hashmarkername: setroubleshoot
kernel:         3.10.0-0.rc0.git21.1.fc20.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-05-08 10:52:44 EDT

*** This bug has been marked as a duplicate of bug 960894 ***

Note You need to log in before you can comment on or make changes to this bug.