This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 960894 - SELinux is preventing /usr/libexec/postfix/cleanup from read, write access on the file /var/spool/postfix/pid/unix.cleanup.
SELinux is preventing /usr/libexec/postfix/cleanup from read, write access on...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c4778184ef63297b97f3c9180db...
:
: 960895 960896 960898 960900 960901 960902 960903 961059 961061 961660 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-08 05:31 EDT by Nicolas Mailhot
Modified: 2013-05-22 08:23 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-08 10:52:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2013-05-08 05:31:40 EDT
Description of problem:
SELinux is preventing /usr/libexec/postfix/cleanup from read, write access on the file /var/spool/postfix/pid/unix.cleanup.

*****  Plugin catchall (100. confidence) suggests  ***************************

If vous pensez que cleanup devrait être autorisé à accéder read write sur unix.cleanup file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep cleanup /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:postfix_cleanup_t:s0
Target Context                system_u:object_r:postfix_var_run_t:s0
Target Objects                /var/spool/postfix/pid/unix.cleanup [ file ]
Source                        cleanup
Source Path                   /usr/libexec/postfix/cleanup
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           postfix-2.10.0-1.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-41.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.10.0-0.rc0.git21.1.fc20.x86_64
                              #1 SMP Tue May 7 19:47:51 UTC 2013 x86_64 x86_64
Alert Count                   4
First Seen                    2013-05-08 11:25:15 CEST
Last Seen                     2013-05-08 11:27:36 CEST
Local ID                      80d54443-1433-4ab4-8e99-84d743d52237

Raw Audit Messages
type=AVC msg=audit(1368005256.674:104): avc:  denied  { read write } for  pid=2412 comm="cleanup" name="unix.cleanup" dev="dm-0" ino=3024616 scontext=system_u:system_r:postfix_cleanup_t:s0 tcontext=system_u:object_r:postfix_var_run_t:s0 tclass=file


type=AVC msg=audit(1368005256.674:104): avc:  denied  { open } for  pid=2412 comm="cleanup" path="/var/spool/postfix/pid/unix.cleanup" dev="dm-0" ino=3024616 scontext=system_u:system_r:postfix_cleanup_t:s0 tcontext=system_u:object_r:postfix_var_run_t:s0 tclass=file


type=SYSCALL msg=audit(1368005256.674:104): arch=x86_64 syscall=open success=yes exit=ENOEXEC a0=7f1414bb4480 a1=2 a2=0 a3=0 items=0 ppid=2381 pid=2412 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=cleanup exe=/usr/libexec/postfix/cleanup subj=system_u:system_r:postfix_cleanup_t:s0 key=(null)

Hash: cleanup,postfix_cleanup_t,postfix_var_run_t,file,read,write

audit2allow

#============= postfix_cleanup_t ==============
allow postfix_cleanup_t postfix_var_run_t:file { read write open };

audit2allow -R
require {
	type postfix_cleanup_t;
	type postfix_var_run_t;
	class file { read write open };
}

#============= postfix_cleanup_t ==============
allow postfix_cleanup_t postfix_var_run_t:file { read write open };


Additional info:
hashmarkername: setroubleshoot
kernel:         3.10.0-0.rc0.git21.1.fc20.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-05-08 10:52:21 EDT
Fixed in selinux-policy-3.12.1-43
Comment 2 Daniel Walsh 2013-05-08 10:52:38 EDT
*** Bug 960895 has been marked as a duplicate of this bug. ***
Comment 3 Daniel Walsh 2013-05-08 10:52:44 EDT
*** Bug 960896 has been marked as a duplicate of this bug. ***
Comment 4 Daniel Walsh 2013-05-08 10:52:50 EDT
*** Bug 960898 has been marked as a duplicate of this bug. ***
Comment 5 Daniel Walsh 2013-05-08 10:52:56 EDT
*** Bug 960900 has been marked as a duplicate of this bug. ***
Comment 6 Daniel Walsh 2013-05-08 10:53:01 EDT
*** Bug 960901 has been marked as a duplicate of this bug. ***
Comment 7 Daniel Walsh 2013-05-08 10:53:33 EDT
*** Bug 960902 has been marked as a duplicate of this bug. ***
Comment 8 Miroslav Grepl 2013-05-09 04:42:17 EDT
*** Bug 961059 has been marked as a duplicate of this bug. ***
Comment 9 Miroslav Grepl 2013-05-09 04:42:59 EDT
*** Bug 961061 has been marked as a duplicate of this bug. ***
Comment 10 Miroslav Grepl 2013-05-09 04:49:42 EDT
*** Bug 960903 has been marked as a duplicate of this bug. ***
Comment 11 Miroslav Grepl 2013-05-10 04:43:51 EDT
*** Bug 961660 has been marked as a duplicate of this bug. ***
Comment 12 Joel Uckelman 2013-05-22 07:31:56 EDT
This is a problem in selinux-policy-3.11.1-95.fc18 as well. Will this fix be backported? Or F18 upgraded to 3.12.1-43?
Comment 13 Miroslav Grepl 2013-05-22 08:23:55 EDT
It has been fixed in selinux-policy-3.11.1-96.fc18 which is now going to the stable.

Note You need to log in before you can comment on or make changes to this bug.