Bug 960902 - SELinux is preventing /usr/libexec/postfix/smtpd from read, write access on the file /var/spool/postfix/pid/inet.192.168.0.4:smtp.
Summary: SELinux is preventing /usr/libexec/postfix/smtpd from read, write access on t...
Keywords:
Status: CLOSED DUPLICATE of bug 960894
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:41d0a577626b2c31ad356315f11...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-08 09:34 UTC by Nicolas Mailhot
Modified: 2013-05-08 14:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-08 14:53:32 UTC


Attachments (Terms of Use)

Description Nicolas Mailhot 2013-05-08 09:34:53 UTC
Description of problem:
SELinux is preventing /usr/libexec/postfix/smtpd from read, write access on the file /var/spool/postfix/pid/inet.192.168.0.4:smtp.

*****  Plugin catchall (100. confidence) suggests  ***************************

If vous pensez que smtpd devrait être autorisé à accéder read write sur inet.192.168.0.4:smtp file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep smtpd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:postfix_smtpd_t:s0
Target Context                system_u:object_r:postfix_var_run_t:s0
Target Objects                /var/spool/postfix/pid/inet.192.168.0.4:smtp [
                              file ]
Source                        smtpd
Source Path                   /usr/libexec/postfix/smtpd
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           postfix-2.10.0-1.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-41.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.10.0-0.rc0.git21.1.fc20.x86_64
                              #1 SMP Tue May 7 19:47:51 UTC 2013 x86_64 x86_64
Alert Count                   3
First Seen                    2013-05-08 11:27:40 CEST
Last Seen                     2013-05-08 11:28:57 CEST
Local ID                      7465bc83-c6c1-4ef8-ba51-f34eedce5c82

Raw Audit Messages
type=AVC msg=audit(1368005337.423:130): avc:  denied  { read write } for  pid=3263 comm="smtpd" name="inet.192.168.0.4:smtp" dev="dm-0" ino=3024468 scontext=system_u:system_r:postfix_smtpd_t:s0 tcontext=system_u:object_r:postfix_var_run_t:s0 tclass=file


type=AVC msg=audit(1368005337.423:130): avc:  denied  { open } for  pid=3263 comm="smtpd" path="/var/spool/postfix/pid/inet.192.168.0.4:smtp" dev="dm-0" ino=3024468 scontext=system_u:system_r:postfix_smtpd_t:s0 tcontext=system_u:object_r:postfix_var_run_t:s0 tclass=file


type=SYSCALL msg=audit(1368005337.423:130): arch=x86_64 syscall=open success=yes exit=ENOEXEC a0=7f6cc3e8a5b0 a1=2 a2=0 a3=0 items=0 ppid=2381 pid=3263 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=smtpd exe=/usr/libexec/postfix/smtpd subj=system_u:system_r:postfix_smtpd_t:s0 key=(null)

Hash: smtpd,postfix_smtpd_t,postfix_var_run_t,file,read,write

audit2allow

#============= postfix_smtpd_t ==============
allow postfix_smtpd_t postfix_var_run_t:file { read write open };

audit2allow -R
require {
	type postfix_smtpd_t;
	type postfix_var_run_t;
	class file { read write open };
}

#============= postfix_smtpd_t ==============
allow postfix_smtpd_t postfix_var_run_t:file { read write open };


Additional info:
hashmarkername: setroubleshoot
kernel:         3.10.0-0.rc0.git21.1.fc20.x86_64
type:           libreport

Potential duplicate: bug 960075

Comment 1 Daniel Walsh 2013-05-08 14:53:32 UTC

*** This bug has been marked as a duplicate of bug 960894 ***


Note You need to log in before you can comment on or make changes to this bug.