Bug 960906 - SELinux is preventing /usr/libexec/postfix/smtp from 'getattr' accesses on the file /var/spool/postfix/pid/unix.smtp.
SELinux is preventing /usr/libexec/postfix/smtp from 'getattr' accesses on th...
Status: CLOSED DUPLICATE of bug 960903
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:3933030833ea68bd4c2c2ffbbe7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-08 05:37 EDT by Nicolas Mailhot
Modified: 2013-05-09 04:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-09 04:48:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2013-05-08 05:37:17 EDT
Description of problem:
SELinux is preventing /usr/libexec/postfix/smtp from 'getattr' accesses on the file /var/spool/postfix/pid/unix.smtp.

*****  Plugin catchall (100. confidence) suggests  ***************************

If vous pensez que smtp devrait être autorisé à accéder getattr sur unix.smtp file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep smtp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:postfix_smtp_t:s0
Target Context                system_u:object_r:postfix_var_run_t:s0
Target Objects                /var/spool/postfix/pid/unix.smtp [ file ]
Source                        smtp
Source Path                   /usr/libexec/postfix/smtp
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           postfix-2.10.0-1.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-41.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.10.0-0.rc0.git21.1.fc20.x86_64
                              #1 SMP Tue May 7 19:47:51 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-08 11:32:23 CEST
Last Seen                     2013-05-08 11:32:23 CEST
Local ID                      069a5e72-f86e-47ef-b914-6b9bc0d4c7bf

Raw Audit Messages
type=AVC msg=audit(1368005543.125:157): avc:  denied  { getattr } for  pid=3938 comm="smtp" path="/var/spool/postfix/pid/unix.smtp" dev="dm-0" ino=3024610 scontext=system_u:system_r:postfix_smtp_t:s0 tcontext=system_u:object_r:postfix_var_run_t:s0 tclass=file


type=SYSCALL msg=audit(1368005543.125:157): arch=x86_64 syscall=fstat success=yes exit=0 a0=8 a1=7ffff85d71c0 a2=7ffff85d71c0 a3=0 items=0 ppid=2381 pid=3938 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=smtp exe=/usr/libexec/postfix/smtp subj=system_u:system_r:postfix_smtp_t:s0 key=(null)

Hash: smtp,postfix_smtp_t,postfix_var_run_t,file,getattr

audit2allow

#============= postfix_smtp_t ==============
allow postfix_smtp_t postfix_var_run_t:file getattr;

audit2allow -R
require {
	type postfix_smtp_t;
	type postfix_var_run_t;
	class file getattr;
}

#============= postfix_smtp_t ==============
allow postfix_smtp_t postfix_var_run_t:file getattr;


Additional info:
hashmarkername: setroubleshoot
kernel:         3.10.0-0.rc0.git21.1.fc20.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-05-09 04:48:10 EDT

*** This bug has been marked as a duplicate of bug 960903 ***

Note You need to log in before you can comment on or make changes to this bug.