Bug 960903 - SELinux is preventing /usr/libexec/postfix/smtpd from 'getattr' accesses on the file /var/spool/postfix/pid/inet.192.168.0.4:smtp.
SELinux is preventing /usr/libexec/postfix/smtpd from 'getattr' accesses on t...
Status: CLOSED DUPLICATE of bug 960894
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:5dffc989ec9b1c21e0691ad5bd1...
:
: 960904 960905 960906 960907 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-08 05:35 EDT by Nicolas Mailhot
Modified: 2013-05-09 04:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-09 04:49:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2013-05-08 05:35:23 EDT
Description of problem:
SELinux is preventing /usr/libexec/postfix/smtpd from 'getattr' accesses on the file /var/spool/postfix/pid/inet.192.168.0.4:smtp.

*****  Plugin catchall (100. confidence) suggests  ***************************

If vous pensez que smtpd devrait être autorisé à accéder getattr sur inet.192.168.0.4:smtp file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep smtpd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:postfix_smtpd_t:s0
Target Context                system_u:object_r:postfix_var_run_t:s0
Target Objects                /var/spool/postfix/pid/inet.192.168.0.4:smtp [
                              file ]
Source                        smtpd
Source Path                   /usr/libexec/postfix/smtpd
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           postfix-2.10.0-1.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-41.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.10.0-0.rc0.git21.1.fc20.x86_64
                              #1 SMP Tue May 7 19:47:51 UTC 2013 x86_64 x86_64
Alert Count                   3
First Seen                    2013-05-08 11:27:40 CEST
Last Seen                     2013-05-08 11:28:57 CEST
Local ID                      a278b705-aea3-43d3-aa46-8de15da5e16f

Raw Audit Messages
type=AVC msg=audit(1368005337.423:131): avc:  denied  { getattr } for  pid=3263 comm="smtpd" path="/var/spool/postfix/pid/inet.192.168.0.4:smtp" dev="dm-0" ino=3024468 scontext=system_u:system_r:postfix_smtpd_t:s0 tcontext=system_u:object_r:postfix_var_run_t:s0 tclass=file


type=SYSCALL msg=audit(1368005337.423:131): arch=x86_64 syscall=fstat success=yes exit=0 a0=8 a1=7fffc2b67f80 a2=7fffc2b67f80 a3=0 items=0 ppid=2381 pid=3263 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=smtpd exe=/usr/libexec/postfix/smtpd subj=system_u:system_r:postfix_smtpd_t:s0 key=(null)

Hash: smtpd,postfix_smtpd_t,postfix_var_run_t,file,getattr

audit2allow

#============= postfix_smtpd_t ==============
allow postfix_smtpd_t postfix_var_run_t:file getattr;

audit2allow -R
require {
	type postfix_smtpd_t;
	type postfix_var_run_t;
	class file getattr;
}

#============= postfix_smtpd_t ==============
allow postfix_smtpd_t postfix_var_run_t:file getattr;


Additional info:
hashmarkername: setroubleshoot
kernel:         3.10.0-0.rc0.git21.1.fc20.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-05-09 04:47:47 EDT
*** Bug 960904 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2013-05-09 04:48:01 EDT
*** Bug 960905 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2013-05-09 04:48:10 EDT
*** Bug 960906 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2013-05-09 04:48:25 EDT
*** Bug 960907 has been marked as a duplicate of this bug. ***
Comment 5 Miroslav Grepl 2013-05-09 04:49:42 EDT

*** This bug has been marked as a duplicate of bug 960894 ***

Note You need to log in before you can comment on or make changes to this bug.