Bug 961034 - libvirt live migration got unexpected fail
libvirt live migration got unexpected fail
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.4
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Eric Blake
Virtualization Bugs
: ZStream
Depends On: 927176
Blocks: 966707
  Show dependency treegraph
 
Reported: 2013-05-08 11:09 EDT by Eric Blake
Modified: 2013-11-21 04:00 EST (History)
18 users (show)

See Also:
Fixed In Version: libvirt-0.10.2-19.el6
Doc Type: Bug Fix
Doc Text:
Prior to this update, the F_DUPFD_CLOEXEC operation with the fcntl() function expected a single argument, specifying the minimum file descriptor (FD) number, but was provided none. Consequently, random stack data were accessed as the FD number and a libvirt live migration could then terminate unexpectedly. This update ensures that the argument is provided in the described scenario, thus fixing this bug.
Story Points: ---
Clone Of: 927176
Environment:
Last Closed: 2013-11-21 04:00:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Eric Blake 2013-05-08 11:10:11 EDT
6.5 will pick up the fix via rebase, but the problem is real enough to warrant a backport to 6.4.z.
Comment 4 yanbing du 2013-07-09 07:09:42 EDT
Verify this bug:

#rpm -q libvirt
libvirt-0.10.2-19.el6.x86_64

Following the steps in bug description, do live migrate
# virsh migrate --live tsu-1 qemu+ssh://10.66.85.73/system --verbose
root@10.66.85.73's password: 
Migration: [100 %]

And the guest running on dest host, so move this bug to VERIFIED.
Comment 6 errata-xmlrpc 2013-11-21 04:00:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1581.html

Note You need to log in before you can comment on or make changes to this bug.