Bug 966707 - libvirt live migration got unexpected fail
libvirt live migration got unexpected fail
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.4
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Eric Blake
Virtualization Bugs
: ZStream
Depends On: 961034
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 14:11 EDT by Chris Pelland
Modified: 2013-06-18 08:17 EDT (History)
19 users (show)

See Also:
Fixed In Version: libvirt-0.10.2-18.el6_4.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-18 08:17:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Pelland 2013-05-23 14:11:06 EDT
This bug has been copied from bug #961034 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 6 weizhang 2013-05-31 01:48:07 EDT
Do migration loop on both
libvirt-0.10.2-18.el6_4.5.x86_64
libvirt-0.10.2-18.el6_4.6.x86_64

Can not reproduce the problem on both version, so I check the source code of libvirt-0.10.2-18.el6_4.6.x86_64, find the patch already in
src/rpc/virnetsocket.c

int virNetSocketDupFD(virNetSocketPtr sock, bool cloexec)
{
    int fd;

    if (cloexec)
        fd = fcntl(sock->fd, F_DUPFD_CLOEXEC, 0);
    else
        fd = dup(sock->fd);
    if (fd < 0) {
...

So verify pass.
Comment 8 errata-xmlrpc 2013-06-18 08:17:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0951.html

Note You need to log in before you can comment on or make changes to this bug.