Bug 961047 - chronyd.service should not pull in chrony-wait.service via Wants=. This adds a 20s delay to the boot!
chronyd.service should not pull in chrony-wait.service via Wants=. This adds ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: chrony (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
: 963976 (view as bug list)
Depends On:
Blocks: WhyWeBootSoSlow
  Show dependency treegraph
 
Reported: 2013-05-08 11:43 EDT by Lennart Poettering
Modified: 2013-05-16 19:04 EDT (History)
3 users (show)

See Also:
Fixed In Version: chrony-1.27-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-15 13:28:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2013-05-08 11:43:23 EDT
Currently chronyd.service pulls in chronyd.service via Wants=. That's a pretty bad idea, since on my machine this delays boot-up for 20s! (Try "systemd-analyze blame" and "systemd-analyze critical-chain" to check). This is not OK, especially since almost nobody needs this at all... cronie certainly doesn't, since its even granularity is 1min anyway, so the hw RTC should be totally enough to schedule time events shortly after boot.

Shipping chrony-wait.service is certainly a good idea, but it should not be enabled by default. (In fact, currently by usage of Wants= it cannot even turned off by the admin except via masking) So, please remove the "Wants=chrony-wait.service" line from chronyd.service. (Also, while you are at it, please drop the After=syslog.target, too. syslog.target is redundant these days, syslog is available anyway for all normal services).

Please make sure to include both chronyd.service and chrony-wait.service in the systemd macro lines in the rpm spec, so that both are enabled based on the preset logic. Since "chronyd.service" is listed in the fedora preset file it will be enabled on all new installations this way. And since "chrony-wait.service" is not listed there, it won't. However, if an admin decides that he wants to enable chrony-wait.service globally on all his systems he can drop-in a additional preset file that also enables "chrony-wait.service".
Comment 1 Miroslav Lichvar 2013-05-09 06:14:58 EDT
The Wants dependency is now removed in chrony-1.27-3.fc19. Thanks for the report.
Comment 2 Fedora Update System 2013-05-09 06:28:12 EDT
chrony-1.27-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/chrony-1.27-3.fc19
Comment 3 Lennart Poettering 2013-05-09 08:51:35 EDT
Thank you for the quick response!
Comment 4 Fedora Update System 2013-05-09 13:54:50 EDT
Package chrony-1.27-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing chrony-1.27-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-7744/chrony-1.27-3.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-05-15 13:28:15 EDT
chrony-1.27-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Chris Murphy 2013-05-16 19:04:13 EDT
*** Bug 963976 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.