Bug 963976 - long startup times
long startup times
Status: CLOSED DUPLICATE of bug 961047
Product: Fedora
Classification: Fedora
Component: chrony (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks: WhyWeBootSoSlow
  Show dependency treegraph
 
Reported: 2013-05-16 18:48 EDT by Chris Murphy
Modified: 2013-05-16 19:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-16 19:04:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Murphy 2013-05-16 18:48:38 EDT
Description of problem:
On baremetal and in VM, chronyd.service times are exceptionally high.

Version-Release number of selected component (if applicable):
chrony-1.27-1.fc19.x86_64

How reproducible:
Always

Steps to Reproduce:
1. boot the computer or VM with or without wired connection
  
Actual results with systemd-analyze blame

Baremetal with network connection:
          12.443s chronyd.service
chrony-wait.service doesn't make the list


qemu on above baremetal with network connection:
         30.021s chrony-wait.service
          1.091s chronyd.service


Expected results:
Less than 10 seconds for wait. The service file says: Wait up to ~10 minutes for chronyd to synchronize and the remaining clock correction to be less than 0.1 seconds. Yet I see times of 30 seconds for wait and 1 second for the actual service.


Additional info from the VM with 30 second wait:
[root@tragic ~]# journalctl -b | grep chrony
May 16 16:37:01 tragic.localdomain chronyd[307]: chronyd version 1.27 starting
May 16 16:37:01 tragic.localdomain chronyd[307]: Linux kernel major=3 minor=9 patch=0
May 16 16:37:01 tragic.localdomain chronyd[307]: hz=100 shift_hz=7 freq_scale=1.00000000 nominal_tick=10000 slew_delta_tick=833 max_tick_bias=1000 shift_pll=2
May 16 16:37:02 tragic.localdomain chronyd[307]: Frequency -1.059 +/- 28.723 ppm read from /var/lib/chrony/drift
May 16 16:37:02 tragic.localdomain systemd[1]: Starting Wait for chrony to synchronize system clock...
May 16 16:37:20 tragic.localdomain chronyd[307]: Selected source 204.2.134.162
May 16 16:37:32 tragic.localdomain systemd[1]: Started Wait for chrony to synchronize system clock.
May 16 16:38:26 tragic.localdomain chronyd[307]: Selected source 108.61.73.244
Comment 1 Igor Gnatenko 2013-05-16 18:55:21 EDT
See bug 961047 . Update chrony to chrony-1.27-3.fc19.
Comment 2 Chris Murphy 2013-05-16 19:04:12 EDT

*** This bug has been marked as a duplicate of bug 961047 ***

Note You need to log in before you can comment on or make changes to this bug.