Bug 961061 - SELinux is preventing /usr/libexec/postfix/smtpd from 'lock' accesses on the file /var/spool/postfix/pid/inet.smtp.
Summary: SELinux is preventing /usr/libexec/postfix/smtpd from 'lock' accesses on the ...
Keywords:
Status: CLOSED DUPLICATE of bug 960894
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b861bfe8a588b395068a127402f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-05-08 16:52 UTC by Michael S.
Modified: 2013-05-09 08:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-09 08:42:58 UTC


Attachments (Terms of Use)

Description Michael S. 2013-05-08 16:52:51 UTC
Description of problem:
starting postfix
SELinux is preventing /usr/libexec/postfix/smtpd from 'lock' accesses on the file /var/spool/postfix/pid/inet.smtp.

*****  Plugin catchall (100. confidence) suggests  ***************************

If vous pensez que smtpd devrait être autorisé à accéder lock sur inet.smtp file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep smtpd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:postfix_smtpd_t:s0
Target Context                system_u:object_r:postfix_var_run_t:s0
Target Objects                /var/spool/postfix/pid/inet.smtp [ file ]
Source                        smtpd
Source Path                   /usr/libexec/postfix/smtpd
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           postfix-2.10.0-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-42.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.0-301.fc19.x86_64 #1 SMP Mon
                              Apr 29 13:44:05 UTC 2013 x86_64 x86_64
Alert Count                   17
First Seen                    2013-05-07 00:04:17 CEST
Last Seen                     2013-05-08 18:48:16 CEST
Local ID                      0a568352-3101-43fe-a149-fcb33349cbfb

Raw Audit Messages
type=AVC msg=audit(1368031696.47:1328): avc:  denied  { lock } for  pid=2838 comm="smtpd" path="/var/spool/postfix/pid/inet.smtp" dev="dm-2" ino=2369652 scontext=system_u:system_r:postfix_smtpd_t:s0 tcontext=system_u:object_r:postfix_var_run_t:s0 tclass=file


type=SYSCALL msg=audit(1368031696.47:1328): arch=x86_64 syscall=flock success=yes exit=0 a0=9 a1=2 a2=2 a3=7fff2003a0a0 items=0 ppid=2635 pid=2838 auid=4294967295 uid=89 gid=89 euid=89 suid=89 fsuid=89 egid=89 sgid=89 fsgid=89 ses=4294967295 tty=(none) comm=smtpd exe=/usr/libexec/postfix/smtpd subj=system_u:system_r:postfix_smtpd_t:s0 key=(null)

Hash: smtpd,postfix_smtpd_t,postfix_var_run_t,file,lock

audit2allow

#============= postfix_smtpd_t ==============
allow postfix_smtpd_t postfix_var_run_t:file lock;

audit2allow -R
require {
	type postfix_smtpd_t;
	type postfix_var_run_t;
	class file lock;
}

#============= postfix_smtpd_t ==============
allow postfix_smtpd_t postfix_var_run_t:file lock;


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.0-301.fc19.x86_64
type:           libreport

Potential duplicate: bug 960904

Comment 1 Miroslav Grepl 2013-05-09 08:42:58 UTC

*** This bug has been marked as a duplicate of bug 960894 ***


Note You need to log in before you can comment on or make changes to this bug.