Bug 961065 - Error checking software dependencies with base environment KDE Plasma Workspaces while having additional languages selected in Language Support
Error checking software dependencies with base environment KDE Plasma Workspa...
Status: CLOSED DUPLICATE of bug 959610
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F19Beta/F19BetaBlocker
  Show dependency treegraph
 
Reported: 2013-05-08 13:28 EDT by Reartes Guillermo
Modified: 2013-05-08 13:51 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-08 13:51:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen-shot of software selection (108.29 KB, image/png)
2013-05-08 13:28 EDT, Reartes Guillermo
no flags Details
anaconda.log (8.33 KB, text/plain)
2013-05-08 13:29 EDT, Reartes Guillermo
no flags Details
program.log (42.30 KB, text/plain)
2013-05-08 13:29 EDT, Reartes Guillermo
no flags Details
storage.log (155.96 KB, text/plain)
2013-05-08 13:29 EDT, Reartes Guillermo
no flags Details
packaging log (871.27 KB, text/plain)
2013-05-08 13:30 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2013-05-08 13:28:32 EDT
Created attachment 745321 [details]
screen-shot of software selection

Description of problem:

When one selects an additional language (Spanish) in Language Support and then one selects the KDE Plasma Workspace base environment, Software Selection reports a dependency problem.

* per-DBD-MySQL-4.023-1.fc19.x86_64 requieres libmysqlclient.so.1018()(64bit)
* per-DBD-MySQL-4.023-1.fc19.x86_64 requieres 


Version-Release number of selected component (if applicable):
F19b TC3 (19.24-1)

How reproducible:
always

Steps to Reproduce:

0. Reach the Main Hub, leave deaults (English) at the Welcome Screen. (Set English for F19b TC3 if it is not default).
1. Change the Keyboard to Spanish; Castilian (Spanish)
2. Change the Time Zone to America/Argentina/Buenos_Aires and disable NTP.
3. Enter Language Support and select Español (España) ~ Spanish (Spain) as an additional language.
4. Enter Software Selection and select 'KDE Plasma Workspace' base environment 
   NOTE: I also tested with 'KDE Applications', 'KDE Educational applications', 'KDE Multimedia support' and 'KDE Office' Add-ONs.
5. Software Selection shows thw warning: "Error checking software selection".
6. Enter Software Selection again, the Yellow Banner will read "Error checking software dependencies. Click for details.".
7. Click the Yellow-banner, it will reveal that: 
   * per-DBD-MySQL-4.023-1.fc19.x86_64 requieres libmysqlclient.so.1018()(64bit)
   * per-DBD-MySQL-4.023-1.fc19.x86_64 requieres libmysqlclient.so.1018(libmysqlclient_16)(64bit)
   
8. Removing the additional language (spanish) and entering Software Selection again makes the problem go away.   

Actual results:
unresolved dependencies (cannot install) for package "per-DBD-MySQL-4.023-1.fc19.x86_64" if one selects an additional language.

Expected results:
no unresolved dependencies.

Additional info:

(packaging.log)
14:21:47,660 WARN packaging: perl-DBD-MySQL-4.023-1.fc19.x86_64 requires libmysqlclient.so.1018()(64bit)
14:21:47,661 WARN packaging: perl-DBD-MySQL-4.023-1.fc19.x86_64 requires libmysqlclient.so.1018(libmysqlclient_16)(64bit)
Comment 1 Reartes Guillermo 2013-05-08 13:29:10 EDT
Created attachment 745322 [details]
anaconda.log
Comment 2 Reartes Guillermo 2013-05-08 13:29:27 EDT
Created attachment 745323 [details]
program.log
Comment 3 Reartes Guillermo 2013-05-08 13:29:47 EDT
Created attachment 745324 [details]
storage.log
Comment 4 Reartes Guillermo 2013-05-08 13:30:20 EDT
Created attachment 745325 [details]
packaging log
Comment 5 Reartes Guillermo 2013-05-08 13:45:16 EDT
From: https://fedoraproject.org/wiki/Fedora_19_Alpha_Release_Criteria
When doing a graphical install using the dedicated installer images, the installer must be able to install each of the release blocking desktops, as well as the minimal package set. 

I am not sure if KDE is a blocker desktop or not from that text.
I propose this as a beta blocker or at leas a final blocker.
Comment 6 Andre Robatino 2013-05-08 13:48:16 EDT
KDE is a release-blocking desktop.
Comment 7 Adam Williamson 2013-05-08 13:51:10 EDT

*** This bug has been marked as a duplicate of bug 959610 ***

Note You need to log in before you can comment on or make changes to this bug.