Bug 961331 - RFE: enhance CPE logic to support layered RHEV-H images
RFE: enhance CPE logic to support layered RHEV-H images
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
node
: FutureFeature
Depends On:
Blocks: 988683
  Show dependency treegraph
 
Reported: 2013-05-09 08:26 EDT by Mike Burns
Modified: 2014-01-21 14:33 EST (History)
17 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-2.el6
Doc Type: Bug Fix
Doc Text:
A problem was caused by two different hypervisor images existing and using the same CPE information. This meant the CPE information could not be used to distinguish between the different hypervisor images To fix this, the CPE information of the base image was adjusted.This means the hypervisor base image can now be distinguished from other hypervisor images because it has its own CPE name.
Story Points: ---
Clone Of: 959153
Environment:
Last Closed: 2014-01-21 14:33:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17333 None None None Never

  None (edit)
Comment 7 Ying Cui 2013-10-28 05:26:47 EDT
Tested build on rhevh-6.5-20131024.1.0(ovirt-node-3.0.1-6.el6.noarch)
Verified test patch is added into this build.

until now, we are not sure the correct values of different cpe names to the different image types(rhevh for rhev, and rhevh base image, ...)

For rhevh 6.5 base image build, the output is here. 

# cat /etc/system-release-cpe 
cpe:/o:redhat:enterprise_linux:6:update5:hypervisor


We will verify this bug when the cpe name value is decided for different image types.
Comment 9 Cheryn Tan 2013-11-07 19:29:05 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 10 Charlie 2013-11-13 18:44:40 EST
Not quite sure what this enhancement does. Need more info to write it up in errata text. Thanks in advance.
Comment 13 Ying Cui 2014-01-07 01:10:52 EST
Verified this bug on following builds
1. rhevh-6.5-20131220.0, ovirt-node-3.0.1-13.el6_5.noarch
# cat /etc/system-release-cpe 
cpe:/o:redhat:enterprise_linux:6:update5:hypervisor-base

2.rhev-hypervisor6-6.5-20140102.0.el6ev, ovirt-node-3.0.1-13.el6_5.noarch
# cat /etc/system-release-cpe 
cpe:/o:redhat:enterprise_linux:6:update5:hypervisor
Comment 15 errata-xmlrpc 2014-01-21 14:33:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.